Tech Support Guy banner
Status
Not open for further replies.
1 - 12 of 12 Posts

·
Registered
Joined
·
6 Posts
Discussion Starter · #1 ·
I know this has been discussed many times, but I can't find a thread that answers my problem.

I have a desktop running XP, linked to a router by ethernet cable, and a laptop, running Vista, which connects wirelessly. They both access the Internet without problem, but I can't get them to see one another properly.

If I try to map a network drive on the desktop it finds the laptop, but fails to display any folders, so I can't connect. I can also ping the laptop from the desktop.

I can't ping the desktop from the laptop, and it doesn't see the dektop if I try to map a drive.

I have tried disabling the firewalls on both (the desktop uses Zone Alarm, the laptop the Windows firewall). I've read about adding ip addresses to firewall settings, but can't see how to do it, but this shouldn't matter if the firewakks are not operating.

Both are members of the same workgroup.

Any advice gratefully received
 

·
Registered
Joined
·
1,943 Posts
On the Vista computer, make sure the network is set as Private. That way, the firewall is out of the picture. On XP, make sure the network is allowed through the firewall or disable it.

Make sure you are actually sharing something on the computers. You can't map it unless it is set up to be shared.

Vista uses account access to verify access. That means whatever username/password you have on your XP machine must exist (exactly) on the Vista machine. The Vista machine doesn't have to actually be logged into that account, but it must exist.

Courtney
 

·
Super Moderator
Joined
·
82,234 Posts
Sometimes disabling ZoneAlarm is sufficient, but often you have to properly configure it or get it completely and cleanly uninstalled.

Courtney is a little confused on the account stuff. You have to have a password assigned on the Vista, but otherwise you needn't worry about accounts/passwords until when and if you run into such problems. As he said, you have to get pings working and you have to share a drive or folder before you can access it.
 

·
Registered
Joined
·
6 Posts
Discussion Starter · #4 ·
Thanks guys, for your help.

I moved on a bit last night, because I read about Link Layer Protocol, and installing this made a difference. Pings were working in both directions.

As a result I managed to access files on the desktop from the laptop, and installed the printer on the laptop, and that worked.

The desktop could see the laptop on the network, but any attempt to open folders returned an error message "access denied". I couldn't get past this.

I tried rebooting both machines, but all this did was to lose sight of the desktop from the laptop, and I can't see why or how to get it back.

Can you tell me how to make sure the network is set as Private?

I've set up sharing for folders, and changed permissions to full control.

I don't know anything about setting a username or password on either machine. Can you explain that a bit more? I don't need any password to access either. The XP machine has two users, the laptop only one.

I got everything working by disabling the firewalls. Can you tell me how to configure them to make it work? I can't see anything on Zone Alarm about adding an Ip address.

Sorry this is longwinded, but it's not exactly intuitive this stuff, is it?

Thanks again

Les
 

·
Registered
Joined
·
6 Posts
Discussion Starter · #6 ·
OK. The Vista network is private, and I've got a ping going in both directions. I can access the desktop (XP) from the laptop (Vista), and the desktop sees the laptop, but any attempt to access laptop folders I get the "access denied" error message.

I'm still running Vista with the Windows firewall disabled.

I set up a password on the Vista machine (which I don't want - it forces me to log in using a password which is unnecessary). That makes no difference.

The folders are shared with full permissions set.

What more do I need to do?
 

·
Super Moderator
Joined
·
82,234 Posts
You're sure there is no 3rd party firewall (security suite) running on the Vista? Or maybe one that used to be there and the uninstall did not go cleanly? Symantic and McAfee have Removal tools to clean up after their applications.

What are your settings for
File sharing,
Public folder sharing,
Password protected sharing?
 

·
Registered
Joined
·
6 Posts
Discussion Starter · #8 ·
File sharing is ON
Public folder sharing is ON
Password protected sharing is OFF

I tried to install Zone Alarm when I got the laptop, but the install failed, so I gave up. I can't see any evidence of it now. Could it still be there? How can I find out?

Thanks again
 

·
Registered
Joined
·
6 Posts
Discussion Starter · #9 ·
Another update. I installed Zone Alarm on the Vista machine, and included the IP address of the desktop in the trusted zone, but this has not made any difference.
 

·
Super Moderator
Joined
·
82,234 Posts
I do not know why you're getting the Access Denied. Maybe a permissions problem. You even get the error with the Public folder?

What you have done now with ZoneAlarm should be working for you. FYI, the usual method for making sure that particular firewall is completely gone is to uninstall, Restart, install it, and then immediately uninstall it again.
 

·
Registered
Joined
·
6 Posts
Discussion Starter · #11 ·
I didn't know until just now that Vista treats the Public folder differently. I tried it and I can access files in it from the XP machine. I can't access files that aren't in it, even though I can set them up as shared, and they are seen by the XP machine.

I can live with that if I have to, but it seems strange that you can get so far with sharing folders, but only Public is really accessible. Any idea why?

Many thanks

Les
 

·
Super Moderator
Joined
·
82,234 Posts
Every time I run into a sharing problem like that on my Vista it turns out to be a permissions problem. I don't understand the permissions well enough to guide somebody else, but with patience and exploration I get it working.

On the Vista right click on one of those folders and select 'Sharing...' or 'Properties.' With one or both you should be able to get into some permissions stuff, including Advanced Permissions. Don't make changes willy-nilly, but you should be able to get permissions set for 'Everyone' to read or read/write. Somewhere several levels down there is even the option to apply those permissions to sub-folders or just to the original folder. Good luck!
 
1 - 12 of 12 Posts
Status
Not open for further replies.
Top