Tech Support Guy banner
Status
Not open for further replies.
1 - 8 of 8 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter · #1 ·
When attemping to "shutdown" or "reboot", I have to do it twice. When I select "Start" then either shutdown or reboot, my desktop will flicker a couple of times, and then nothing appears to happen. I must select "start" again and then either shutdown or reboot and then they will work as expected. Any clues??
 

·
Registered
Joined
·
2,854 Posts
Well, my first guess is that you've got a bunch of programs running in the background or something, and when you first click shutdown it just manages to stop all of those processes. The second shutdown actually shuts down the computer.

I don't know, just a guess... try closing everything thats running, programs and everything in the system tray, and then shutting down. If it works on the first try then we can go from there.
 

·
Registered
Joined
·
2 Posts
Discussion Starter · #3 ·
I've narrowed to "Google Desktop Search" and "Quicktime" in my system tray. If I close BOTH of them before trying to shutdown, it will work on first attempt. Closing one OR the other, still requires that I try to shutdown twice.

It's a problem that I can live with, but......
 

·
Registered
Joined
·
2,854 Posts
You don't need either of those running the background...

Try going to Start -> Run... -> msconfig

Click the Startup tab (farthest one on the right)

Find the entries corresponding to Quicktime and the Google Search tool and uncheck them.
 

·
Registered
Joined
·
1,052 Posts
Together they may just take up to much for the system to shutdown properly.. and same goes for alone?
-blitze
 

·
Registered
Joined
·
2,548 Posts
Hi,
If you're comfortable editing the Registry there are a couple of settings that can speed up shutdown vis-a-vis hung or stubborn applications.

HKEY_CURRENT_USER/Control Panel/Desktop
In the right-hand pane:
AutoEndTasks - a Value of 1 will enable this.
HungAppTimeout - the Value is in milliseconds, so a value of 5000 (no commas) is 5 seconds (a reasonable wait time). This setting affects normal use.
WaitToKillAppTimeout - again a Value of 5000 would be good. This entry controls how long the operating system will wait to end an application on shutdown.

HKEY_LOCAL_MACHINE/System/CurrentControlSet/Control
In the right-hand pane WaitToKillServiceTimeout is the same as the application entry above, except this applies to hung Services. Again, a Value of 5000 is a good starting point.

--------------------------------------------------

To open the Registry Editor go to Start => Run and type in regedit

Always backup the key(s) you intend to edit or delete. To backup (export) a key, highlight the key and in the File drop-down menu select Export. Select a location you can remember and give the saved .reg file a suitable name.

To edit a Value, right-click on the Value and select Edit.
 

·
Registered
Joined
·
2,548 Posts
Hello,
Yes, I tried setting everything to 1 second myself in the past, but ran into a problem with one or two applications not having sufficient time to shutdown normally (they weren't "hung") (can't remember - Word may have been one). So I go to 5 seconds and work down from there. If 1 second works that's great!
 
1 - 8 of 8 Posts
Status
Not open for further replies.
Top