Tech Support Guy banner
Status
Not open for further replies.
1 - 5 of 5 Posts

·
Registered
Joined
·
44 Posts
Discussion Starter · #1 ·
I have a wireless network set up at home. Unfortunately, I'm still using dial-up. When you configure ICS on XP using the wizard, it makes itself a host computer, therefore a DHCP server and also configures itself to have an IP address of 192.168.0.1.

This conflicts with my D-Link DI-514 router because it is by default 192.168.0.1 and also a DHCP server. I changed its IP address to a static address of 192.168.0.2.

Now when I connect to the wireless network with my laptop, I cannot access the internet because on my laptop's default gateway is 192.168.0.2. My router sees itself as the default gateway and broadcasts that on the wireless network. How do I direct my router to see 192.168.0.1 as the Internet host? I am not using the WAN port on the router because that is made to be connected to a cable or DSL modem.

Any suggestions?
 

·
Registered
Joined
·
7,235 Posts
Did you turn off DHCP on your Router? It could be your laptop is getting the ip from the router and not the ICS machine therefor not getting the right Gateway.

Another way around it would be to hardcode your laptop IP.
 

·
Registered
Joined
·
44 Posts
Discussion Starter · #4 ·
Thanks for the advice. I'll try it. It is true that my laptop gets its IP address and such from the router and therefore gets incorrect information.

If I turn off DHCP in my router will the host computer assign IP addresses even across the wireless network? Can it assign an IP address to my router or does it need to?

I have hard coded the ip on my laptop and it works but I'm trying to work this out to use in real world situations where DHCP is necessary because of ignorant clients.
 
1 - 5 of 5 Posts
Status
Not open for further replies.
Top