Tech Support Guy banner
Status
Not open for further replies.
1 - 20 of 23 Posts

·
Registered
Joined
·
1,429 Posts
It's very common for the clock to either gain time or lose time before it syncs again with a NIST Internet time service. Your XP clock automatically only syncs every seven (7) days, which gives it plenty of time to get off. The easiest method to have a more accurate clock is a little utility that changes the sync update to as often as once an hour. That's a lot better than once every week!

Here: You'll like this

Or, if you'd like to have your clock sync even more often than once an hour I can tell you how to modify the registry and have it update every 30 minutes, 15 minutes, etc., etc.

Also, some people add a handful of additional NIST locations to their clock update list (via a registry addition). It comes with just three.
 

·
Registered
Joined
·
1,429 Posts
Thanx, Koot but I don't have Administer level privledges. You said something about a registry?
Yes, the registry can be modified easily to have the clock update as often as you elect...however, if you do not have Admin privileges I doubt you'll be able to mess with the registry either.

Can you click on START > RUN and type in "regedit" (without the quotes) and click on OK? What do you get - the registry trees?
 

·
Retired Moderator
Joined
·
106,726 Posts
It could be that something on the machine hooks the timer interrupt and is screwing up the timekeeping. :)
 

·
Registered
Joined
·
1,429 Posts
A window entitled "registry editor" opened.
Okay, maybe you will be able to change the registry. If so, do the following:

1. Type "regedit" in Run

2. Navigate to the following key in the left pane:
HKEY_LOCAL_MACHINE\SYSTEM\ControlSet001\Services\W32Time\TimeProviders\NtpClient

3. In the right pane, double click the entry called SpecialPollInterval.

4. In the Base section of the Edit DWord Value dialog box, click the Decimal option button.

5. Enter the desired interval in seconds (3600 = 1 hour, 1800 = 30 minutes, 900 = 15 minutes and so forth).

6. Click OK and close the registry editor.

Double click on your clock in the taskbar and click on the "Internet Time" tab. Click "Update Now". You will see the time that the clock synced...and below you will see when the clock will sync next. You should see that the clock will sync next in the number of minutes you set the registry.

If the next sync time is not for the amount of time you set in the registry you may have to change the value in the "CurrentControlSet" instead of the "ControlSet001" as noted above. First, try "ControlSet001".)
 

·
Registered
Joined
·
1,429 Posts
Doula, let me know if you were successful in changing how often the clock automatically syncs with a NIST time source.

Also, let me know if you are interested in adding some extra NIST time sources, which is easily done in the registry.
 

·
Registered
Joined
·
1,429 Posts
There is no entry called SpecialPollInterval!
If you have not already done so take a look in the registry tree “CurrentControlSet” instead of the “ControlSet001” to see if you have "SpecialPollInterval" there.
 

·
Registered
Joined
·
1,429 Posts
I lost you somewhere, but thanks for trying.
I'm not sure where you are having a problem. But...

You should be able to see the registry after typing "regedit" in RUN. Here is what you should see:


Click on HKEY_LOCAL_MACHINE. Then click on SYSTEM. Then click on the + to open further as you go. Click on "CurrentControlSet" and continue to click on + as you click on SERVICES, then W32TIME, then TIMEPROVIDERS, then NtpClient. Then on the right side of the page you should see "SpecialPollInterval". Double click on "SpecialPollInterval". Click the Decimal option button and enter the number of seconds to wish to use before the clock updates again, e.g. 900 seconds + 15 minutes.
 

·
Registered
Joined
·
1,429 Posts
I lost you somewhere, but thanks for trying.
I'm not sure where you are having a problem. But...

You should be able to see the registry after typing "regedit" in RUN. Here is what you should see:


From: HKEY_LOCAL_MACHINE click on SYSTEM. Then click on the + to open further as you go. Click on "CurrentControlSet" and continue to click on + and click on SERVICES, then W32TIME, then TIMEPROVIDERS, then NtpClient. Then on the right side of the page you should see "SpecialPollInterval". Double click on "SpecialPollInterval". Click the Decimal option button and change the value to the number of seconds you wish to use before the clock updates again, e.g. 900 seconds + 15 minutes.
 

·
Registered
Joined
·
16 Posts
Discussion Starter · #15 ·
I followed everything u said, but after i chged the value to 3600 (secs) it would go back to HEXADECIMAL & use e10 as the value data! any thoughts?
 

·
Super Moderator
Joined
·
46,575 Posts
I agree, you need to contact whomever has the admin rights on this computer. If it is a work computer, contact the IT dept.
 

·
Registered
Joined
·
1,429 Posts
I followed everything u said, but after i chged the value to 3600 (secs) it would go back to HEXADECIMAL & use e10 as the value data! any thoughts?
The problem could be that you do not have Administration privileges, yet you are [still] able to get into the registry. However, when you make changes it reverts back to the default settings.

Did you try this utility that I suggested earlier? If so, did it change the polling time? If it didn't - that pretty much tells me that you will not be able to modify your clock's polling time...because you do not have Administration privileges.
 

·
Registered
Joined
·
199 Posts
I followed everything u said, but after i chged the value to 3600 (secs) it would go back to HEXADECIMAL & use e10 as the value data! any thoughts?
You know it might have something to do with the little battery on the motherboard that controls time keeping. Chech that if all else fails, but I would advise you ask someone who knows how to dismantle and put it back together.
 
1 - 20 of 23 Posts
Status
Not open for further replies.
Top