Tech Support Guy banner

Windows ME- Cannot install directx or any windows updates

36846 Views 13 Replies 3 Participants Last post by  walkeriam
Anyone: HOWDY! I need to install directx 8.1b or higher to run a new game. I tried installing dx8.1b from the game CD, I downloaded it from Microsoft, I tried installing 9.0b as well but none will install. When I try to install 8.1b, the progress bar completes and i then get the message --- 'Searching for updated DirectX runtime components and updating as necessary. This may take a few minutes...' --- the progress bar simply never moves and the task manager shows the install as not responding and so I have to end task. This has been the case every time. When I tried installing 9.0b, nothing happens at all -- it is as though i never ran the executable.

On another note: I cannot run windows update as well. Maybe this is related somehow?! When I click "yes" to install windows update -- nothing happens and eventually the page is 'not responding'.

I have no clue what to do now.

If it is helpful:
I am running windows ME
Dell Dimension 8100
256 MB RAM
Intel x86 family 15 model 0 stepping 7, ~1296MHz
Directx 8.0 is currently installed (
32 MB NVIDIA GeForce2 MX with TV Out

I could probably let you know some more info if needed...

Thanks much!! :confused: :confused:
Not open for further replies.
1 - 14 of 14 Posts
For the Windows Update problem try this:
Open INTERNET OPTIONS in the CONTROL PANEL. Click on the ADVANCED TAB at the top. Scroll down to BROWSING and UN-CHECK if checked or CHECK if un-checked the following two boxes.
ENABLE INSTALL ON DEMAND [Internet Explorer] and

Then re-boot your computer and try the update site again.
Let us know if that helps!
It looks as though this will do the trick. i actually get a list of updated again -- i haven't updated anything yet (haven't had the time) but wanted to let you know that your advice was all good so far. :up:
i am hoping that this might solve the directx prob too. i'll let you know...
I tried running windows update and the first thing I tried to install was explorer 6.0. It appeared to be working properly, it downloaded fully, but when it started to install, it got stuck at 64% and never completed. I waited a good 20 minutes so I had to cancel installation and then the cancel would not complete, so I had to 'end task' on the whole process. Should I try again, or do I possibly need to do something else first?

BTW: it shouldn't take but 10-15 minutes to install this -- I have a DSL line.

Any thoughts? Does anyone think that this problem is related to my DirectX prob?

I have seen times when this install has taken a lot longer than the 10-15 minutes. Try downloading and in-stalling again with patience.
I went back to widows update and i was able to download and install:
NVIDIA display software update released on March 09 2002
812709: Security Update (Windows Me)
811630: Critical Update (Windows Me)
and some others, but i still cannot install DirectX 9.0 or any other version or update higher than 8.0, or Microsoft Internet Explorer 6 Service Pack 1 (Windows 98, Windows Me) as well as some other critical updates.

When i try to install Explorer 6 service pack, it downloads and starts to install, but gets "stuck" at 64%. i was very patient this last time (i let it run overnight), but i never got past 64%.

When i try to install DirectX 9.0, it downloads, installs almost fully (the progress bar goes all the way) but it never finishes. I let this sit overnight as well and the next day it was running but not any further. Since the progress bar is completly filled in, i guess the istallation is almost complete -- i dunno. I tried to close the installation window (can't cancel it as the cancel button is grayed out) then i get told that if i navigate away from the page that the installation will fail --- then choose continue or cancel. This tells me that directX is still installing -- so what the heck is up? Nothing takes 7 hours to install!

Any other thoughts or suggestions please!

See less See more
You may have Spyware on your computer that needs to be removed first. Have you ran SpyBot Search and Destroy or AdAware on your computer before? If not, I'll give you the link to them so you can DOWNLOAD, UPDATE, RUN and delete the spyware, then try the DirectX download.
I downloaded, installed, updated, and ran spybot. i deleted all the spyware and then tried installing Directx again. I'm sorry to say that i get the same problems as before. Same deal with trying to installed explorer 6.0.

Maybe i need to reinstall Windows? i was hoping not to have to do that. Would that mean that i have to reformat the hard drive. if i end up doing this, does anyone think i should invest in Windows XP and bag ME?

I appreciate the help and advise.

What do you think about this? i wasn't sure if maybe explorer 6 wouldn't install over 5.5 or not so i went and tried to update the 5.5 service pack2.

i said earlier that IE 6.0 just stopped installing at 64% and i was forced to cancel.

when i tried to install IE 5.5 SP2 it stopped running at @ 76% and i was forced to cancel.

i saw that an ME update (821559) did not properly install - so removed it and reinstalled it successfully.

i then tried to install IE 6.0 again and it made it all the way to 82% before it stopped this time.

so i tried IE 5.5 SP2 again and that made it all the way to 90% before it stopped.

Should i keep trying or what?

I'm still hopeful that eventually DirectX will install too.

...but who knows?
See less See more
Go here and download HighJackThis. Un-zip it and click on the Icon with the sticks of dynamite and click scan. When it's done scanning the SCAN button turns to SAVE LOG. Click the SAVE LOG button and save it to MY DOCUMENTS. Go to that file and "OPEN WITH" "WORD PAD". Then Copy and Paste it back here and we will take a look at it.
I haven't seen this problem in quite a while but the article below has helped others in the past with the same problem your experiencing. Take a look at this article below and be sure to follow the steps closely to locate and delete any 0kb OEM*.inf files they refer to in the article. Then try the installs again. Let us know what happens. ....;EN-US;Q281967
Thanks Bryan, I didn't find that in my search of MKB.
Thanks all! i did what Bryan said and everything is fantastic now! everything i needed to install installed properly and all is well. :D :up:
Great, glad to here it and thanks for the feedback!
1 - 14 of 14 Posts
Not open for further replies.