Tech Support Guy banner

Windows Can't open the file because you dont have permission

1838 Views 9 Replies 5 Participants Last post by  RT

I have been getting this error since i re installed Windows 7 on my PC.
Window photo viewer can't open
this picture because you don't hava correct .... cant open this photo because you do not have permission to access the file.

Files are in my external HDD.
This problem is only with the couple of folders (and files within).
I have tried some of the things by googling the error.
I have tried to take permissions, changing the ownership and attributes. Didnt work.
Now i dont know what to do and want those files restored or recovered. Please help me out.

Not open for further replies.
1 - 10 of 10 Posts
Seen this topic before. Tried it l. Didnt work. Thanks.
AB, I've had a similar problem. What worked for me is the download of Take Ownership. It adds a line in the right click context menu that says, appropriately enough, Take Ownership. It's worked for me every time. Not sure this is where I got it, as I applied it in 2012, but you can try this file ( a .zip ) here:

After you install it, right click the folder or file you want and you'll see Take Ownership in the context menu. Click that, and you may see a brief shell window pop up as it does it's thing. You should now be able to properly use the files or folders that you already actually thought you owned in the first place, as it should be. Hope it works for you.
Hi RT,

Unfortunately it didnt work even after installing take ownership software. Thank you.

Sorry it didn't work for you! Stick around, there's wiser folk than me here that might get you fixed.

Um, I'm wondering if the difficulty might stem from your external drive? Could you copy those to your HD on your main computer, then try Take Ownership? Perhaps you don't even have permission to copy, it was a thought...
I tried that too. I tried opening it in paint, upload on facebook, email as attachment. Nothing! Wont even let me copy it to my computer. So frustrating!
Last thing i want to hear is the file is corrupted.
I would suggest you to scan the folder using antivirus application that is installed on your computer and try to open it again.
If you know anything about linux or have a friend that does, boot into linux (it can be from a live USB stick), connect and mount the external drive with the folders.
Open one of the folders that you are having problems viewing.
Can you see the files in linux?

If so and the folders are fairly small, plug in a USB stick. Make sure linux sees the stick then copy the folders from the external drive to the stick.
Do not move. If there is a hiccup, then everything is lost. If there is a hiccup while trying to copy, all the originals are still on the external hard drive and you can try to copy again.
AB , have you tried some of the image/photo recovery tools available?
Search for image or photo recovery in Google, or whatever you prefer.

Sorry I can't give you a specific one to try , but I had to use such before, but it wasn't because of "permissions," so keep that in mind. But it did work for me at the time.
1 - 10 of 10 Posts
Not open for further replies.