Tech Support Guy banner
  • Please post in our Community Feedback thread for help with the new forum software! If you are having trouble logging in, please Contact Us for assistance.
Status
Not open for further replies.
1 - 4 of 4 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter · #1 ·
Hello! :) I did a cursory search of the forums for this issue but there are just too many cases to review them all so I figured I would post here anyways.

I'm using a Dell Inspiron 1525 and Windows Vista, and I've been having a lot of problems with it lately... but I have a question about one in particular right now.

My computer is running really slowly (regardless of whether I am online or offline or how many applications I have open). It doesn't take abnormally long to boot up the computer itself, but booting up separate applications takes forever.

My CPU also seems to spend a lot of it's time running at 80% or higher... it's staying between 50% and 60% right now but before I started typing this question it had spent about 10 minutes at 100% usage. I have only two programs open- Firefox and Microsoft Word. (I've since closed Word but I didn't notice any significant difference in CPU usage- it's staying around the same).

While the computer was at 100% CPU usage it was freezing every couple of minutes for just 30 seconds or so. I'd let it process or whatever until it was done freaking out and the usage had come down a bit and then try to type or do an internet search and it would shoot straight back up and freeze again.

I'm also wondering at the number of processes I have running - 77... although I've heard Vista runs a large number of processes and so maybe I shouldn't be worried about this? I've gotten rid of almost everything non-essential that I can think of (without messing around with any services that might be vital) but it still seems really high to me. I dunno.

This isn't really any huge error message issue, it's just irritating. All the other tips I've found here and there or got from friends haven't really made any difference.

PS: As far as I, McAfee, and MalwareBytes knows, I don't have any virus on my machine. :)

Thank you so much to everyone who responds.
 

·
Registered
Joined
·
2 Posts
Discussion Starter · #3 ·
I've only got 14 programs that start on boot, and they're all pretty much essential... several Intel services, my laptop touch pad, the anti-virus, etc. I guess iTunes doesn't really need to be there (I actually didn't know it was there, must have re-enabled itself after I downloaded the latest update) but other than that they all check out.

I've got 4GBs of RAM. And I guess while I'm here looking up my exact specs, I'm running Windows Vista Home Premium Service Pk 2, 32 bit version.
 

·
Registered
Joined
·
628 Posts
Hmm 14 start ups, I guess that is ok, I only have 7 but then again each user has different needs or requirements.
As for the RAMS you are more than A-OK.

Hopefully someone with much more experience than I will pop in soon.

Ray
 
1 - 4 of 4 Posts
Status
Not open for further replies.
Top