Tech Support Guy banner
Status
Not open for further replies.
1 - 5 of 5 Posts

·
Registered
Joined
·
16 Posts
Discussion Starter · #1 ·
Hi All.... i have a Epson RX500 printer and i keep getting a pop up box telling me this device will perform faster if i connect it to one of the available usb2 ports but it IS already... it says click here to see all available ports which it shows as all being empty even though other devices are plugged into them :confused: ....Thanks for any help!
 

·
Retired Moderator
Joined
·
106,726 Posts
Do the USB 2.0 ports work properly with other devices?
 

·
Registered
Joined
·
16 Posts
Discussion Starter · #3 ·
Hi John...everything seems to work fine.even the printer,just keep getting this pop up every time i use the printer...emailed Epson and they said its a microsoft fault...maybe the printer should be working faster but how would i know?...only have a mouse and a modem connected in the other ports but it says all 8 are vacant when there are only 5...puzzler ay!....Thanks!
 

·
Retired Moderator
Joined
·
106,726 Posts
What do you see in Device Manager under USB Controllers?
 

·
Registered
Joined
·
16 Posts
Discussion Starter · #5 ·
Hi John...there is 5 listings that says USB Root Hub...4 Intel(r)82801FB/FBM USB Universal Host Controller - 2658,2659,264A,265B and 1 Intel(r)82801FB/FBM USB2 Enhanced Host Controller - 265C...Thats 10 in all...no yellow triangles!?!.
I think its an Epson fault as i never get a pop up with any thing else i connect such as modem, mouse, joystick, digital camera or video etc...i downloaded latest drivers from epson... no good!...Thanks for your time mate!!
 
1 - 5 of 5 Posts
Status
Not open for further replies.
Top