Tech Support Guy banner
Status
Not open for further replies.
1 - 20 of 41 Posts

·
Registered
Joined
·
133 Posts
Discussion Starter · #1 ·
Hello. When I plug a usb device into my computer, such as my flash drive or wireless adapter, windows doesn't think anything is connected. Please help.
 

·
Registered
Joined
·
133 Posts
Discussion Starter · #3 ·
One of my ports on the back work. I put a 4 port hub in that port but windows will only recognize it if one device is plugged in
 

·
Trusted Advisor
Joined
·
25,684 Posts
Unplug the four port hub.
Go device manager on the view tab - show hidden devices.
On USB = any warnings.
When did the problem first occur please.

I presume G drive is an external usb drive - powered or just USB please
 

·
Registered
Joined
·
133 Posts
Discussion Starter · #6 ·
G is in the working port. It is my external hard drive. This has been going on for about a week. There are no warnings.
 

·
Trusted Advisor
Joined
·
25,684 Posts
I thought it must be the external is it powered or just usb

geekguy123.
Please check in the USB root hubs - device manager if in power mamagement it is configured for windows to turn off to save power.
If it is uncheck on all USB hubs.
Power down.
UNPLUG the power cord.
as front and rear ports were mentioned a desktop - I presume.
Connect a flash pen to one of the rear ports, not the four way hub.
Connect the power cord.
Reboot.
 

·
Registered
Joined
·
619 Posts
Answer the Q, is it USB powered or does it have a transformer/rectifier device plugged in to it?

On certain computers, USB powered devices can only work on certain ports. Some ports aren't capable of supplying enough power in those instances.
 

·
Registered
Joined
·
133 Posts
Discussion Starter · #9 ·
It plugs into the wall outlet for power
 

·
Registered
Joined
·
133 Posts
Discussion Starter · #10 ·
I did what Macboatmaster told me to do. It did not recognize the flash drive
 

·
Trusted Advisor
Joined
·
25,684 Posts
Please confirm that you did all that I recommended including the root hub - power management.
Were they set for power saving
 

·
Registered
Joined
·
133 Posts
Discussion Starter · #12 ·
they were not
 

·
Trusted Advisor
Joined
·
25,684 Posts
Unless you have already tried this - please plug in the flash pen with the computer running.
Do not worry - flash pens are hot pluggable.
DO NOT DO THAT WITH THE HDD
IF THIS DOES NOT THEN SEE THE FLASH PEN
Could you please confirm before I proceed with further tests that you have disconnected the four port hub.
I presume you do mean an external four port hub.

Would you then please disconnect ALL usb devices, except of course any necessary if you have usb keyboard.mouse.

Please now go device manager and check if any updates are available on the usb root hub drivers.
Before attempting update check that no usb device is using that hub.
 

·
Registered
Joined
·
133 Posts
Discussion Starter · #14 ·
I just tried it and it didn't work
 

·
Trusted Advisor
Joined
·
25,684 Posts
I have added to it please proceed as shown.
 

·
Trusted Advisor
Joined
·
25,684 Posts
I have just read the thread again and I notice that yoiu say it started about a week ago.
Has Norton by any chance been updated about this time.
Have you added any OTHER usb devices that were not there before - ie when it was OK
Have you by any chance used some sort of registry cleaner or other similar program.
 

·
Registered
Joined
·
133 Posts
Discussion Starter · #17 ·
There were no updates
 

·
Registered
Joined
·
133 Posts
Discussion Starter · #18 ·
Norton has not been updated
 

·
Registered
Joined
·
133 Posts
Discussion Starter · #19 ·
I haven't used registry cleaner
 

·
Trusted Advisor
Joined
·
25,684 Posts
Start in Safe Mode please.
Now try a usb device
 
1 - 20 of 41 Posts
Status
Not open for further replies.
Top