Tech Support Guy banner

USB-C hub not working on my thinkpad

5071 Views 19 Replies 3 Participants Last post by  Macboatmaster
Hi all.
I bought the Lenovo C116 USB-C hub (this one: for my Lenovo Ideapad 530S. It doesn't work, however. It seems to detect the device, as it makes a sound when I connect it, but I can't use the Loghitech keyboard or mouse, monitor or regular usb-pen. I just tested it on my colleagues Macbook pro, which worked just fine. It is plug and play so it shouldn't be so complicated. Does anyone know how to fix this problem?

Thanks in advance
Not open for further replies.
1 - 20 of 20 Posts
I appreciate that this is the NOT the USB Hub you have

Other than the general description of the device you have I cannot find any comprehensive literature regarding it on the Lenovo site
However the principle is the same with your device and the one I have linked to

Devices are ONLY plug and play if the computer can find the driver for the device
If it cannot the driver must be installed

I suggest you check that you have the device connected to the USB 3.0 port on your 530s
I also suggest you examine device manager to see what is listed for the device and scan for hardware changes after connecting it

What is serial number of the 530s as there are of course many different versions of 530s
See less See more
There are some cases where docks would need drivers for the parts on it. I suspect as Mac pointed out when you connect the dock, you will see some items requiring drivers.

I assume the computer was purchased in Asia? The website itself looks really suspicious, like a knock off from the real Lenovo site and they are not real official products.
Thanks for your replies.
I did not buy it from the page above but through an amazon seller. On the back of the hub it says Licensee website:, which is, allegedly, a Lenovo official Licensee in China and whose costumer service I have already been in contact with. They can't solve the problem, though, but offer a refund.

The computer itself is bought in Denmark. It is a Lenovo Ideapad 530S 14IKB.

It seem that the device is detected and configured on my PC and that the newest drivers are already installed. I have found that I can charge my phone through the hub, but that it doesn't take any input from mouse, screen, or the like.
If you want my help please send the serial number of the Ideapad as requested

The fact you can charge your phone means very little all you need for that is voltage from the USB port on the Lenovo Ideapad to the C116

If you answered the other questions we MAY make some progress - what is shown in device manager for the device the C116 and have you scanned for hardware changes in device manager.
Connect the device with the computer turned on, but not with your phone connected to it and then in device manager - scan for hardware changes
The model is a Lenovo Ideapad 530S 14IKB, model name 81EU. By serial number do you mean the factory ID?

It doesn't appear when I scan for new units/devices, however, it seems it already appear under my devices (bottom left corner), if this is endeed the hub. When I open properties it says it is started and configured, has the newest drivers installed, and should work correctly.
Product Font Software Screenshot Line
See less See more
Have you opened the link I sent on post 2 ?
after the question what is your serial number please.

What is shown in device manager please as I asked
That is Control Panel and then device manager
Windows key + X and click on device manager

You have three notifications on the bottom right corner of the taskbar - what are those please - is one of them connected with this USB hub

Connect the mouse straight to the USB port on the laptop - a USB 2.0 port NOT the hub and see if the mouse is recognised there.
See less See more
For the serial number, you can get it from Command Prompt by typing wmic bios get serialnumber

The serial number helps us determine your machine and find out what hardware you have.

One thing I noticed in the BIOS on my dell machine is that there is an option that will disable the USB ports on an external dock. Not sure if your machine has that capability.
IMHO that is the serial number of the BIOS chip
IF THAT is the same as the Lenovo serial number then I did NOT know this

I want the Lenovo serial number to ensure I have the correct model as there are so many variants of the 530S even with the 141KB and under model 81EU there are still variants

The reason I want the serial number is to ensure I find the correct hardware for the chipset and usb controllers

I am puzzled as to what can be easier than on the link I sent looking at the

label on the base of the laptop
See less See more
IMHO that is the serial number of the BIOS chip
IF THAT is the same as the Lenovo serial number then I did NOT know this

It shows the serial number for other machines that we use (HP and Dell), providing it has been entered in correctly at the plant (had one serial for a Dell that was 123456 because the technician didn't know the SN at the time o_O)

though if I remember correctly, the lenovo thinkpads L520s that we had were showing 7 digit serials... which is different to what you show there so it may be different for the IdeaPad... but the industry standard seems to be the SN that they assigned.
I did not know that
I still opine that unless the label is unreadable there an be nothing easier than copying it off the label

What I have shown is only an example of the Lenovo link I sent on post two - where to find the serial number, so the fact it is different means nothing
Sorry. The label is quite unreadable, however, I used the The Lenovo Service bridge. The serial number is PF1FHMKD.

The hub is not detected under device manager and there are no changes when I scan for hardware changes. This is what it shows:
The notification are not related to the usb hub.


See less See more
It may not be shown on USB entries but examine the whole of device manager for unknown or other devices and follow the procedure as here

I will post further when I have examined the details under the serial number

Seen that notifications do not relate to usb hub could you please confirm if the that dies not show when connected to the usb hub , does work when that mouse is connected directly to a usb port
I checked all devices, none are flagged with a yellow questions mark or marked "unknow" or the like. But as already mentioned, the PC does seem to detect the usb-c hub an automatically install a driver, see the picture of to EXPSM USB above. When I open properties for the device it says that the device is started, configured, and that the newest driver is installed. In other words, I am not sure the driver is the problem.

I am not quite sure I understand your second question, but if it regards the other ports - there are absolutely no problems, I can use a mouse, keyboard, sound interface etc.
Here is the link to your laptop
IF it stays on that link when you click it I suggest you click automatic driver update
I see a selection of updates that MAY help
especially the chipset updates and the Intel Management drivers, the latter enabling communication with various devices across the system
Rather than me select - I think it best to see what Lenovo suggests

As you can see at this time the link is on your device
Serial Number: PF1FHMKD
Machine Type Model: 81EU00LYMX
However my experience tells me that it will not always stay on that page
If it does not insert your serial number and go back to the page

The BIOS update does not appear to address anything connected with USB issues and as the laptop VERY new with - You have 665 Days remaining on your warranty
I suspect there is ONLY the one BIOS update

BIOS updates are cumulative, and include previous fixes and enhancements, - howver as I said I do not think there is any other than the ONE BIOS update for that computer
See less See more
Thank you for your reply. There doesn't seem to be a quick-fix and as I have now testet the hub also on another PC where it worked snappy and just as intended, I am certain the problem lies with my computer. As there is warranty, I will go to the store where I bought it and ask them to take a look at it.

By the way, maybe a stupid question, but is it unsafe to post the serial number of the device online?
No - there is no risk, otherwise I would not have asked for it.
If you do not wish to try the updates - the choice is yours of course
I agree it is likely to be something connected with the computer rather than the C116
Good luck with it
Okay. I will try the updates of course. Thank you for your help.
Perhaps if you know someone with a laptop with a USB-C port, maybe see it if will work with their computer?
I presume you are connecting to the correct usb port on the laptop
On the left hand side of the laptop it is the USB - 3.1 to the left of the audio jack connection

Type-C port (on select models)

Type-C port supports:

•USB 3.1

AND NOT the USB 3.0 port which is to the left of the 3.1 C and the right of the HDMI

I am also not sure that the usb image shown on your earlier post of device manager has the entries it should for the USB C 3.1 port. I will post further on this when I examined that situation.

FURTHER to the above as I suspected your device manager should show
  • Intel(R)USB 3.1 eXtensible Host Controller
  • Intel(R)USB 3.1 Root Hub.
and unless you have missed those entries off your screenshot - something is wrong with the setup
See less See more
1 - 20 of 20 Posts
Not open for further replies.