Tech Support Guy banner

USB-C Devices Not Recognized Upon First Connecting to Laptop

653 Views 6 Replies 2 Participants Last post by  Macboatmaster
Whenever I plug a device into my laptop's USB-C port, such as my headphones or my phone, I always have to unplug it and plug it back in for it to be recognized. The device is NEVER recognized the first time I plug it in, but it is ALWAYS recognized the second time. What would cause this?

I'm running Windows 10 latest version if that helps any.
Not open for further replies.
1 - 7 of 7 Posts
Go device manager
expand usb entry
right click usb root hub entries
click properties
click power management
allow computer to turn off power

You should be able to find with usb root hub is for the USB C
when you click properties it will show you on the general tab which usb port the hub is for
How are you doing with this - any progress please following my suggestion
How are you doing with this - any progress please following my suggestion
I tried what you suggested and had no problem following your instructions, but the issue still persists. It is very strange that it literally always recognizes the device on the second attempt and never on the first.
Does the problem still exist if the device is connected before you boot
OR only if it is connected after you have the system running
Are you connecting the device direct to the USB port or through a hub

What is the make and full model of the laptop

When it is connected and is NOT recognised what is shown in device manager for unknown devices or indeed for an entry on the usb section of device manager

Is the problem still apparent when the laptop is on mains power or ONLY when it is on battery power
So far I have only tried connecting things after the system is already booted up. It does not matter if the laptop is plugged in or running on battery. I am not using a hub; the only USB-C devices I have are my headphones and my phone. If I connect my phone it will charge right away, but I will still need to unplug it and reconnect it for the computer to recognize the device to transfer files and such. When the device is not being recognized after the first connection attempt, the device manager shows nothing. My laptop is an ASUS ROG STRIX GL702VS-RS71.
Please try connecting before booting to see if it makes a difference.

If it does then you may either stay with that procedure or try this
the first half of the suggestion on power plan - selective suspend
as you have already done the second option - allow computer to turn off power.
1 - 7 of 7 Posts
Not open for further replies.