Tech Support Guy banner

USB 2 not working with ext harddrive

2896 Views 34 Replies 6 Participants Last post by  Rich-M
Win xp pro service pack 2
mobo: gigabyte 8sq800 ultra

I've read similar problems to the one i've got but i think they differ slightly.

I've got a problem when connecting my Western Digital 'My Book' ext harddrive to my pc. Once connected it says it could work much faster if connected to a usb 2 port. As far as i'm aware it is usb 2. The mother board disc came with usb 2 drivers and i've tried updating as much as i can manually.

When i plug a small usb mem stick in it confirms that its usb2. But the harddrive dont like it. I tried all the usb ports with no luck, and tried it on 2 other machines and it works fine there.

Any ideas?
Not open for further replies.
1 - 15 of 35 Posts
hey ceri

All the latest driver i can get off gigabyte website for that mobo are installed and i've got all the latest updates for winxp service pack 2. I do have the Enhanced term in device manager and the HDD is externally powered so shudnt be a problem there. I find it odd how the little usb2 mem stick works on on usb2 and this won't ..odd
oh and my usb chips are these SiS USB Host Controllers
Thats the way i've been connecting it to the computer so far. Its in the off state and when i connect the usb it turns on. but i'm intrigued bby what you mean whe you say "it runs the setup", do you just mean that windows recognises it or something else?.

I got the 250Gb version from pc world
When i plug it in underneath where it says this could work faster in usb2 to click here to view available usb ports. Heres what the next window shows.

Sis PCI to USB Enhanced Host Controller
- USB Root Hub (6 ports)
-Unused Port
Unused Port
Unused Port
Unused Port
Unused Port
Unused Port

Dsiconnect the USB Mass Storage Device from its current port and then connect it to one of the ports on the hub shown inbold type.
See less See more
Thanks for the suggestion bud, did all that but i still have the same problem.
Well just did a full drive reformat and installed windows and service packs etc and still no luck.

Why does it work for smaller devices but not this 250Gb drive...
I've already reformatted the ext hdd once from fat32 to ntfs using quick format. I then tested it on 2 other computers and it worked usb2 but not mine
my god this copying is taking ages. Started copying 30GB ontot he drive at about 1 oclock. Its now at about 70% and its 8:20pm.


When i unplug the usb cable the drive automatically turns off, and then back on once i plug it back in. So you think its a fault with the drive?, Surely it must be the computer or more specifically the SiS chip controlling the usb's. How else would it work on the other computers.

Didnt install any of the stuff that came with the drive. This version doesnt come with firewire as it's the essentials version. i found a usb2 driver from their support site but it says it shouldnt be installed on xp because i it shouldnt need it. Should i try it out? Whats the worst that could happen?
I deleted the usb drivers for my computer and let xp restore them. HOw do i disable the auto on the XHD?
gunna try another ext hd on my comp once this copying finishes, then i'll get back to you
hmmm just tried my bro's ext hd caddy and it works fine on my usb2 slots. I guess its just western digital extHD dont like my SiS chip inside. Some sort of incompatability.
Well since i'm not going to be using this computer after i copy everything off it i can only hope it works on whatever other computer i plug it into (or just steer clear of SiS)

I sent an email to western digital support but i might be waiting until next xmas for a response if any.
1 - 15 of 35 Posts
Not open for further replies.