Tech Support Guy banner

Updated Bios - Corrupted Bios (I think)

758 Views 10 Replies 3 Participants Last post by  spawn99
Pls Help Me, I updated my Bios from the MSI Official Website, i followed their instruction on how to update the bios, after the update, My PC’s Fan would turn on but there is no Display on the Monitor and even all the Ports in the IO of my motherboard along with the Vid card’s Port. Ive tried removing the RAM, still no display and what not. Resetting the Bios and even removing the CMOS BATTERY, but no reaponse either. I am desperate. This is my First Gaming PC. My specs are:
Mobo: MSI H110M Pro D
Processor: Intel Pentium G4560
Ram: 1x8gb elite 2400ghz
GPU: Galax GTX 1050TI 4Gb OC
PSU: EVGA bronze 500 watt 80plus rating

Anyone pls help me. Thank You very Much
Not open for further replies.
1 - 11 of 11 Posts
OK. A lot of people here will ask you why you updated and also tell you that a Bios update should only be done if there's an issue with the present one. However, we all know that that won't help you. It's also likely that my suggestion(s) won't either.

Have you tried to do a Bios reset?

This procedure is taken directly from the manual available online.

1. Power off the computer and unplug the power cord
2. Use a jumper cap to short JBAT1 for about 5-10 seconds.
3. Remove the jumper cap from JBAT1.
4. Plug the power cord and power on the computer.

Secondly. Does the fan keep spinning when the system is turned on or does it start spinning and then stop? If it stops, it could be a busted power supply. If it does not then that probably isn't the issue.

Lastly. If the system is under warranty. You may want to give MSI tech support a call. Or the place from where you purchased the board/system.

PS. I'd try to, if at all possible, to see if a different powersupply would work. Unplug everything connected to it. Remove any and all external devices, with the exception of the monitor. Which you should connect to the on-board VGA/DVI.
See less See more
Thank you for your reply, i already tried the Bios reset-not working.
The Fans keep working same with the processor fan, also on there is a half second LED light on the Ez Debug LED CPU, and 3 secs Light on the DRAM, then the light goes off, but the fans keep spinning and with no Beep.
I will try to remove all the hardware one by one if that works.
Thank you very much for replying, i will update this after i do the recommendation that you offered. Thank u again.
Hello again, i tried removing everything except the CPU, didnt work. Still the same no display and no ports working.
OK, you might be able to recover the bios. Try the following;
1 On a working system, download whatever bios file you want to use; ie the latest one for your board would probably be what you want
2 Extract the bios file and put it on the root of a FAT32 formatted usb. For simplicity, have only the bios file on the usb; nothing else. Be sure you extract the file. Do not put the zipped folder on the usb. Be sure the usb is formatted as FAT32. Bios utilities cannot read ntfs
3 On the problem system, open the case and pull the pw connectors from ALL drives; both hd and optical. If you by chance have a M.2 drive, pull that out. You must have NO drives connected to the system
4 Insert the usb you made in step #2 into a rear usb 2 port. Do not use a front case port. Be sure the port you are using is usb 2 and not 3
5 Pw ON and wait. You should eventually get a screen asking what you want to do and allowing you to choose the bios file you copied to the flash drive. Select flash and the file. If you receive a msg that the flash is complete, you should be able to shutdown and connect drives. Pw ON and enter the bios. Make any custom settings you need ie boot order, sata mode, whatever. Save settings and restart.
Good luck. Sometimes it works and sometimes it does not work. Depends on whether or not the boot block area of the bios was corrupted.
See less See more
BTW never use a windows based program for flashing the bios. Always use the bios utility that is built into the bios. I think msi calls this MFlash; different mfg have different names however this is much more stable that a windows based flash program.
Hi, ive tried MFlash from the MsI website, they even have video tutorial on how to update the bios using the MFlash. Regarding the recover the bios, unfortunately the keyboards and mouse are not working when u plug it, if i plug the USB it just blinks 1 time then nothing. However there is LED on the Mobo, whenever i remove the RAM, the Ez Debug LED on the DRAM stays on. Thats all the activity i see on the mobo
Have you tried the procedure I outlined? If not, I would highly advise you to do so. It is your ONLY chance of recovering your bios; otherwise your board is bricked ie junk.
Yes sir, i have tried the method u posted, but no success, what if sir i use a CH341A 24 25 EEPROM Flash Bios USB, the one with the clamp? Do u think it will work?
If you have done exactly what was posted and not missed a step, then your only hope is to take the board to a shop and see if they can recover the bios. This is NOT cheap and will probably cost more than a new board.
I guess sir this is beyond me. Year-end Lesson Learned. I will update this thread of the PC diagnosis. If its repairable or its better to get a new Mobo.
Anyways sir, Thank You very much for your tips and support, i very much appreciate it. More Power to this Forum and Happy Holidays!
1 - 11 of 11 Posts
Not open for further replies.