Tech Support Guy banner
Status
Not open for further replies.
1 - 20 of 36 Posts

·
Registered
Joined
·
61 Posts
Discussion Starter · #1 ·
Hey everyone, :)

Im new to the forum but I hope to become a regular. Heres my problem.

Ive made an unattended install of 98 using the batch program to make my inf file. all went well (im assuming). Now the only thing i have left to do is make myself a customized boot menu. now i spoke to a friend and he helped me out with this part. he edited atuoexec.bat and confif.sys from boot98se.exe...i tested it out and everything seemed fine, so i put it on a cd

the cd went fine also..it booted andgave me 3 menus... install 98 en install 98 fr and boot to dos.

when i goto install windows...i was looking to have all the cabs put on my c drive like usual but it didnt work. i have a feeling we screwed up the script because when i click install 98 en i get the following error msgs. invalid drive specification,invalid directory,invalid drive specification,invalid directory,invalid directory,bad command or file name (all one after the other). heres my coding:

config.sys
[menu]
menuitem=EN, Install Windows 98 ( EN ).
menuitem=FR, Install Windows 98 ( FR ).
menuitem=DOS, Start computer in dos.
menudefault=DOS,30
menucolor=7,0

[EN]
device=himem.sys /testmem:eek:ff
device=oakcdrom.sys /D:mscd001
device=btdosm.sys
device=flashpt.sys
device=btcdrom.sys /D:mscd001
device=aspi2dos.sys
device=aspi8dos.sys
device=aspi4dos.sys
device=aspi8u2.sys
device=aspicd.sys /D:mscd001
[FR]
device=himem.sys /testmem:eek:ff
device=oakcdrom.sys /D:mscd001
device=btdosm.sys
device=flashpt.sys
device=btcdrom.sys /D:mscd001
device=aspi2dos.sys
device=aspi8dos.sys
device=aspi4dos.sys
device=aspi8u2.sys
device=aspicd.sys /D:mscd001
[DOS]
device=himem.sys /testmem:eek:ff
device=oakcdrom.sys /D:mscd001
device=btdosm.sys
device=flashpt.sys
device=btcdrom.sys /D:mscd001
device=aspi2dos.sys
device=aspi8dos.sys
device=aspi4dos.sys
device=aspi8u2.sys
device=aspicd.sys /D:mscd001

[COMMON]
files=10
buffers=10
dos=high,umb
stacks=9,256
devicehigh=ramdrive.sys /E 2048
lastdrive=z

autoexec.bat
@ECHO OFF
set EXPAND=YES
SET DIRCMD=/O:N
set LglDrv=27 * 26 Z 25 Y 24 X 23 W 22 V 21 U 20 T 19 S 18 R 17 Q 16 P 15
set LglDrv=%LglDrv% O 14 N 13 M 12 L 11 K 10 J 9 I 8 H 7 G 6 F 5 E 4 D 3 C
cls
call setramd.bat %LglDrv%
set temp=c:\
set tmp=c:\
path=%RAMD%:\;a:\;%CDROM%:\
copy command.com %RAMD%:\ > NUL
set comspec=%RAMD%:\command.com
copy extract.exe %RAMD%:\ > NUL
copy readme.txt %RAMD%:\ > NUL

:ERROR
IF EXIST ebd.cab GOTO EXT
echo Please insert Windows 98 Startup Disk 2
echo.
pause
GOTO ERROR

:EXT
%RAMD%:\extract /y /e /l %RAMD%: ebd.cab > NUL
echo The diagnostic tools were successfully loaded to drive %RAMD%.
echo.

IF "%config%"=="EN" GOTO EN
IF "%config%"=="FR" GOTO FR
IF "%config%"=="DOS" GOTO DOS

IF "%config%"=="NOCD" GOTO QUIT
IF "%config%"=="HELP" GOTO HELP
LH %ramd%:\MSCDEX.EXE /D:mscd001 /L:%CDROM%
echo.
GOTO QUIT

:EN
cls
echo Installing Windows 98 ( EN )
%CDROM%:
cd\
cd 98en
c:
md win98b
%CDROM%:
cd 98en
copy *.* c:\win98b\
c:
cd win98b
setup.exe msbatch.inf

GOTO QUIT

:FR
cls
echo Installing Windows 98 ( FR )
%CDROM%:
cd\
cd 98fr
c:
md win98b
%CDROM%:
cd 98fr
copy *.* c:\win98b\
c:
cd win98b
setup.exe msbatch.inf

GOTO QUIT

:DOS
cls
echo.
echo Welcome to dos!
echo.

GOTO QUIT

:HELP
cls
call help.bat
echo Your computer will now restart and the startup menu will appear.
echo.
echo.
echo.
echo.
echo.
echo.
echo.
echo.
echo.
echo.
restart.com
GOTO QUIT

:QUIT
echo To get help, type HELP and press ENTER.
echo.
rem clean up environment variables
set CDROM=
set LglDrv=

so if anyone knows what went wrong please let me know
thanks
 

·
Registered
Joined
·
469 Posts
The Mistake:

setup.exe msbatch.inf

Remove "msbatch.inf" as it is not needed. The msbatch.inf is automatically loaded by Windows Setup IF located in the same directory as the cab files -- c:\win98b.
 

·
Registered
Joined
·
469 Posts
In the AUTOEXEC.BAT change the "EN" and "FR" labels as follows:

:EN
cls
echo Installing Windows 98 ( EN )
md c:\win98b& copy %cdrom%:\98en\*.* c:\win98b
c:\win98b\setup.exe
GOTO QUIT

:FR
cls
echo Installing Windows 98 ( FR )
md c:\win98b& copy %cdrom%:\98fr\*.* c:\win98b
c:\win98b\setup.exe
GOTO QUIT
 

·
Registered
Joined
·
61 Posts
Discussion Starter · #8 ·
hey i did..i copied and pasted what you gave me..this is what it looks like now
@ECHO OFF
set EXPAND=YES
SET DIRCMD=/O:N
set LglDrv=27 * 26 Z 25 Y 24 X 23 W 22 V 21 U 20 T 19 S 18 R 17 Q 16 P 15
set LglDrv=%LglDrv% O 14 N 13 M 12 L 11 K 10 J 9 I 8 H 7 G 6 F 5 E 4 D 3 C
cls
call setramd.bat %LglDrv%
set temp=c:\
set tmp=c:\
path=%RAMD%:\;a:\;%CDROM%:\
copy command.com %RAMD%:\ > NUL
set comspec=%RAMD%:\command.com
copy extract.exe %RAMD%:\ > NUL
copy readme.txt %RAMD%:\ > NUL

:ERROR
IF EXIST ebd.cab GOTO EXT
echo Please insert Windows 98 Startup Disk 2
echo.
pause
GOTO ERROR

:EXT
%RAMD%:\extract /y /e /l %RAMD%: ebd.cab > NUL
echo The diagnostic tools were successfully loaded to drive %RAMD%.
echo.

IF "%config%"=="EN" GOTO EN
IF "%config%"=="FR" GOTO FR
IF "%config%"=="DOS" GOTO DOS
LH %ramd%:\MSCDEX.EXE /D:mscd001 /L:%CDROM%
echo.
GOTO QUIT

:EN
cls
echo Installing Windows 98 ( EN )
md c:\win98b& copy %cdrom%:\98en\*.* c:\win98b
c:\win98b\setup.exe
GOTO QUIT

:FR
cls
echo Installing Windows 98 ( FR )
md c:\win98b& copy %cdrom%:\98fr\*.* c:\win98b
c:\win98b\setup.exe
GOTO QUIT


:DOS
cls
echo.
echo Welcome to dos!
echo.

GOTO QUIT


:HELP
cls
call help.bat
echo Your computer will now restart and the startup menu will appear.
echo.
echo.
echo.
echo.
echo.
echo.
echo.
echo.
echo.
echo.
restart.com
GOTO QUIT

:QUIT
echo To get help, type HELP and press ENTER.
echo.
rem clean up environment variables
set CDROM=
set LglDrv=
 

·
Registered
Joined
·
469 Posts
Of course, the ampersand doesn't work on Win98 :( Sorry my bad! Change the EN and FR labels to this:

:EN
cls
echo Installing Windows 98 ( EN )
md c:\win98b
copy %cdrom%:\98en\*.* c:\win98b
c:\win98b\setup.exe
GOTO QUIT

:FR
cls
echo Installing Windows 98 ( FR )
md c:\win98b
copy %cdrom%:\98fr\*.* c:\win98b
c:\win98b\setup.exe
GOTO QUIT
 

·
Registered
Joined
·
61 Posts
Discussion Starter · #10 ·
now its invalid drive spceification and bad command or file name.....now i think that the probelm at this point is that i dont wanna waste anymore cds so im running it off a floppy....let me put it on a cd and ill come right back...thanks for all the upto this point btw
 

·
Registered
Joined
·
61 Posts
Discussion Starter · #11 ·
no :( still get the invalid drvie spec error...but what i find weird about it is that i cant access the cd drive at all through dos when i chose to install a lang...i figured that i would try it manually but the cd drive doesnt exist appently..seeing as how im getting an invalid drive spce error
 

·
Registered
Joined
·
61 Posts
Discussion Starter · #12 ·
how about i tell you exactly what i did step by step and maybe you can find my problem. My drive is formatted to fat 32. i got a win98 boot disk from bootdisk.com and extracted the files in order to get to the autoexec.bat and config.sys files. i then edited them and threw them on the floppy (after extracting all the files from boot98se.exe onto it) then i made a bootable cd with nero and dragged the files from 98en and 98fr onto it and burned it. i dont see what can be wrong besides my scripting.:(
 

·
Registered
Joined
·
469 Posts
Got it... Just looking at the batch script above ... Notice where it says:

path=%RAMD%:\;a:\;%CDROM%:\

Now (once again) change the EN and FR labels to this:

:EN
cls
echo Installing Windows 98 ( EN )
md c:\win98b
copy %cdrom%98en\*.* c:\win98b
c:\win98b\setup.exe
GOTO QUIT

:FR
cls
echo Installing Windows 98 ( FR )
md c:\win98b
copy %cdrom%98fr\*.* c:\win98b
c:\win98b\setup.exe
GOTO QUIT
What I did was remove the " :\ " from copy line... If you look at the path= statement you'll notice there's already a colon and slash...
 

·
Registered
Joined
·
61 Posts
Discussion Starter · #15 ·
wow lol thats what i hate about scripting..punctuatio-n will kill you:p

now ive run it off a floppy again i got file not found d98en\ *.* is that because its again on a floppy?
 

·
Registered
Joined
·
469 Posts
:EN
cls
echo Installing Windows 98 ( EN )
md c:\win98b
%cdrom%
cd 98en
copy *.* c:\win98b
c:\win98b\setup.exe
GOTO QUIT

:FR
cls
echo Installing Windows 98 ( FR )
md c:\win98b
%cdrom%
cd 98fr
copy *.* c:\win98b
c:\win98b\setup.exe
GOTO QUIT
 

·
Registered
Joined
·
61 Posts
Discussion Starter · #20 ·
alright im ready to give up:( now its copying the boot files from the cd to c:\win98b i dont know what the problem is and i dont wanna waste anymore of your time. this is really frustrating me
 
1 - 20 of 36 Posts
Status
Not open for further replies.
Top