Tech Support Guy banner

Toshiba Satellite Pro C660 - Keyboard Problems

10425 Views 8 Replies 3 Participants Last post by  Triple6
This question relates to a Toshiba Satellite Pro C660-1UX Laptop running Windows 7 Home Premium Service Pack 1.

Some of the onboard keys (E, T, U, I, O, A, B, N, together with the Enter key) fail to register. All of the other keys tested so far appear to register normally.

When connecting an external USB keyboard, all keys function properly. However, when using either the onboard keyboard or the external USB keyboard, it is necessary to hold down whatever key is selected for approx 2-3 seconds in order for its character to register. This makes typing incredibly slow and is understandably unacceptable. :down:

I've checked device manager looking for errors, but am unable to find any. The driver for the keyboard is listed as installed and working properly, and driver update says that the latest version is in already in use. :up:

I have also scanned for viruses using Malware Bytes and Spybot, and also with the laptops own pre-installed antivirus software. All of the full system scans return a no threat found message. :(

I have read that the keyboards on these machines are prone to failure, which could answer why only certain onboard keys function. The fact that all keys on the external USB keyboard work would seem to confirm this. However, the fact that both onboard and external keyboard is affected by the same slow keypress might also suggest a bios problem - but as this laptop is several years old and has been working perfectly, why would bios suddenly cause this problem. :confused:

I have visited the Toshiba website and based on this laptop having Part number: PSC0ME-02100SEN I have determined (rightly or wrongly) that the correct bios download version is 1.70-WIN, only when I read the following bios installation instructions I became pretty concerned, as the installation of the bios update appears far from simple.

Does anyone know if it is possible to download and install the correct bios by means of an automated update as opposed to the manual download and step by step installation, which, if not carried out as intended, could render the laptop totally unusable. :eek:

Has anyone reading this post experienced similar issues with this make and model of laptop and managed to successfully return it to proper working order. If so, how?

Any constructive advice would be gratefully received. ;)
See less See more
Not open for further replies.
1 - 9 of 9 Posts
The BIOS instructions are general and are for various models, you only need to the use the method applicable to yours and ignore all the other methods. If you download your BIOS it's one file that you just run, similar to methods 3, 4, or 5.

However, it's unlikely that's your issue.

The slow response could be due to the internal keyboard causing issues since it's faulty or an overall system performance issue. Easy test would be to disconnect the internal keyboard.
Thanks for the advice. I will try disconnecting the internal keyboard and see how things progress from there. I'll post back with an update once I've experimented further. :)
Don't be screwing with the bios, and don't be taking it apart to unplugg and replug the keyboad, that's not the issue. What it sounds like to me is the computer is so bogged down with things eating up CPU cycles and ram that it takes that long for the screen to show you typed something. I've seen that a million times. Now, boot into safe mode, open notepad, and test your keyboard again. All these things you're saying it might be wouldn't allow you to type at all, it wouldn't just be slow to respond.

Triple6 said "The slow response could be due to the internal keyboard causing issues since it's faulty or an overall system performance issue."

And that's exactly what I think it is. Don't go screwing with the bios or taking your laptop apart, you're barking up the wrong tree and you're likely to cause even worse problems.
All these things you're saying it might be wouldn't allow you to type at all, it wouldn't just be slow to respond.
What about some of the keys not working at all on the internal keyboard but working with an external keyboard?
OK I must have missed that there was a separate issue. Thing is, if it was anything that disconnecting and reconnecting the internal keyboard or messing with the bios could solve, no keys would be working at all. Sounds to me like it just needs a new keyboard but that's not going to solve the lag issue. Lag issue is common in computers that use shared RAM for the video, not enough RAM, and too many things running. The keyboard needs to be tested in safe mode.
If the same keys still don't work in safe mode (but I have a feeling the lag issue will be gone in safe mode) then you just straight up need to replace the keyboard.
Based on information and advice received from those who have contributed to this thread, I am pleased to say that after a considerable amount of time spent working my way through various tests and adjustments, this problem has now been solved. :D

The keyboard has been replaced, which has solved the problem with various keys not working.

I again scanned for malware and viruses using the latest version of Spybot, Malwarebytes, and Microsoft Security Essentials.

I also optimized for best performance, including running system cleanup, defragmenting the hard drive, reducing the amount of programs running at startup.

I also discovered that by deselecting (unticking) the box next to 'Turn On Filter Keys' (Start/Control Panel/Ease of Access/Make the Keyboard Easier to Use/Turn On Filter Keys) which appears associated with 'Ignore or slow down brief or repeated keystrokes and keyboard repeat rates' seems to have corrected the sluggish keyboard problem. I'm not sure whether or not this should or shouldn't be ticked by default, or how it could have become altered, but deselecting it works for me.

I did download the latest bios version (1.70) for this laptop, but have not installed it (and have now deleted it) as the laptop seems to work perfectly well without this. :)

I'd like to say thank a really big thank you to all of those who have offered their help and support relating to this issue. :up:
See less See more
Glad its all working. Filter keys is off by default. Holding the right Shift for 8 seconds enables it, which could have been by accident or due to a stuck key.
1 - 9 of 9 Posts
Not open for further replies.