Tech Support Guy banner
Status
Not open for further replies.
1 - 7 of 7 Posts

·
Registered
Joined
·
7 Posts
Discussion Starter · #1 ·
can any one help me i am playing a fairly oldish game, SpellForce: Order Of Dawn and i have installed all the lastest patches....but the game still laggs in the single player missionsthe game only recommends 64 meg of video ram?

my specs are:
P4 3.0 ghz cpu
9800Pro drivers 7.1 (lastest)
XP SP2
and i have a 22 cm fan hooked to the side of my case so its not heat related
 

·
Registered
Joined
·
6,649 Posts
Hi bobby boy,

Welcome to TSG ! :)

You should probably lower the resolution of your screen. 800x600 should solve your problem.
 

·
Registered
Joined
·
7 Posts
Discussion Starter · #3 ·
Thing Is I Shouldn't Have To My System Is Ample To Play At High Setting With That Card....when The 9800 Series Came Out It Pawned Off Games Like Speelforce With No Effort...but I Guess It Might Be Something Else...i Will Just O'c It And See What Happens....sorry For Caps
 

·
Super Moderator
Joined
·
43,961 Posts
Heat can be a factor, but my guess is that the hard drive is being used while you are playing it... make sure that nothing is running in the background.

What is your RAM size?
 

·
Super Moderator
Joined
·
43,961 Posts
I would have to admit that it happens to me too (love the game)... I'm not too sure why, unless your memory is being used up and it's using virtual memory (your hard drive) which would explain that.
 
1 - 7 of 7 Posts
Status
Not open for further replies.
Top