Tech Support Guy banner
Status
Not open for further replies.
1 - 7 of 7 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter · #1 ·
I switched to a wireless Linksys router from a crossover cable connection, and now file/printer sharing on my XP + Vista network isn't working. They can ping each other by ip address (not by name), and I've turned off firewalls, and the XP machine can see the Vista machine but not vice versa. Does anyone have any idea what I can try here? Thank you.
 

·
Retired Moderator
Joined
·
106,726 Posts
Let's see this for each of the two computers.

Hold the Windows key and press R, then type CMD to open a command prompt:

In the command prompt window that opens, type type the following commands, one at a time, followed by the Enter key:

Note that there is a space before the -n or the /ALL, but there is NOT a space after the - or / in the following commands.

NBTSTAT -n

IPCONFIG /ALL

Right click in the command window and choose Select All, then hit Enter to copy the contents to the clipboard.
Paste the results in a message here.

If you are on a machine with no network connection, use a floppy, USB disk, or a CD-RW disk to transfer a text file with the information to allow pasting it here.
 

·
Registered
Joined
·
3 Posts
Discussion Starter · #4 ·
Here is some information about my network. There is an XP workstation ("SEAN") and a Vista laptop connected with a linksys wireless router. Both are set to the "MSHOME" workgroup, and I turned the Vista sharing settings on. Sometimes the laptop shows up in the XP network neighborhood, but never vice versa. I had file sharing working until I switched from a crossover cable to the router.

XP Workstation SEAN:

C:\Documents and Settings\me>nbtstat -n
Local Area Connection:
Node IpAddress: [192.168.1.100] Scope Id: []
NetBIOS Local Name Table
Name Type Status
---------------------------------------------
SEAN <00> UNIQUE Registered
MSHOME <00> GROUP Registered
SEAN <20> UNIQUE Registered
MSHOME <1E> GROUP Registered
MSHOME <1D> UNIQUE Registered
..__MSBROWSE__.<01> GROUP Registered
C:\Documents and Settings\me>ifconfig /all
'ifconfig' is not recognized as an internal or external command,
operable program or batch file.
C:\Documents and Settings\me>ipconfig /all
Windows IP Configuration
Host Name . . . . . . . . . . . . : SEAN
Primary Dns Suffix . . . . . . . :
Node Type . . . . . . . . . . . . : Peer-Peer
IP Routing Enabled. . . . . . . . : No
WINS Proxy Enabled. . . . . . . . : No
DNS Suffix Search List. . . . . . : wildblue.com
Ethernet adapter Local Area Connection:
Connection-specific DNS Suffix . : wildblue.com
Description . . . . . . . . . . . : Realtek RTL8139 Family PCI Fast Ethe
rnet NIC
Physical Address. . . . . . . . . : 00-40-CA-37-65-9A
Dhcp Enabled. . . . . . . . . . . : Yes
Autoconfiguration Enabled . . . . : Yes
IP Address. . . . . . . . . . . . : 192.168.1.100
Subnet Mask . . . . . . . . . . . : 255.255.255.0
Default Gateway . . . . . . . . . : 192.168.1.1
DHCP Server . . . . . . . . . . . : 192.168.1.1
DNS Servers . . . . . . . . . . . : 75.106.192.61
Lease Obtained. . . . . . . . . . : Monday, April 13, 2009 9:11:30 AM
Lease Expires . . . . . . . . . . : Tuesday, April 14, 2009 9:11:30 AM

Vista Laptop "LAPTOP":

C:\Users\cdr>nbtstat -n

Local Area Connection:
Node IpAddress: [0.0.0.0] Scope Id: []

No names in cache

Wireless Network Connection:
Node IpAddress: [192.168.1.101] Scope Id: []

NetBIOS Local Name Table

Name Type Status
---------------------------------------------
LAPTOP <00> UNIQUE Registered
MSHOME <00> GROUP Registered
MSHOME <1E> GROUP Registered
LAPTOP <20> UNIQUE Registered
MSHOME <1D> UNIQUE Registered
..__MSBROWSE__.<01> GROUP Registered

C:\Users\cdr>ipconfig /all

Windows IP Configuration

Host Name . . . . . . . . . . . . : LAPTOP
Primary Dns Suffix . . . . . . . :
Node Type . . . . . . . . . . . . : Mixed
IP Routing Enabled. . . . . . . . : No
WINS Proxy Enabled. . . . . . . . : No
DNS Suffix Search List. . . . . . : wildblue.com

Wireless LAN adapter Wireless Network Connection:

Connection-specific DNS Suffix . : wildblue.com
Description . . . . . . . . . . . : Atheros AR5007EG Wireless Network Adapter

Physical Address. . . . . . . . . : 00-1F-E2-C9-DB-F7
DHCP Enabled. . . . . . . . . . . : Yes
Autoconfiguration Enabled . . . . : Yes
Link-local IPv6 Address . . . . . : fe80::90d9:8dea:0:b0f1%11(Preferred)
IPv4 Address. . . . . . . . . . . : 192.168.1.101(Preferred)
Subnet Mask . . . . . . . . . . . : 255.255.255.0
Lease Obtained. . . . . . . . . . : Sunday, April 12, 2009 10:38:42 PM
Lease Expires . . . . . . . . . . : Monday, April 13, 2009 10:44:16 PM
Default Gateway . . . . . . . . . : 192.168.1.1
DHCP Server . . . . . . . . . . . : 192.168.1.1
DNS Servers . . . . . . . . . . . : 75.106.192.61
NetBIOS over Tcpip. . . . . . . . : Enabled

Ethernet adapter Local Area Connection:

Media State . . . . . . . . . . . : Media disconnected
Connection-specific DNS Suffix . :
Description . . . . . . . . . . . : Realtek RTL8102E Family PCI-E Fast Ethern
et NIC (NDIS 6.0)
Physical Address. . . . . . . . . : 00-1E-33-47-81-58
DHCP Enabled. . . . . . . . . . . : Yes
Autoconfiguration Enabled . . . . : Yes

Tunnel adapter Local Area Connection* 6:

Media State . . . . . . . . . . . : Media disconnected
Connection-specific DNS Suffix . :
Description . . . . . . . . . . . : isatap.{3C53C72E-10D6-4BC6-B93D-50DCE4BDD
2CD}
Physical Address. . . . . . . . . : 00-00-00-00-00-00-00-E0
DHCP Enabled. . . . . . . . . . . : No
Autoconfiguration Enabled . . . . : Yes

Tunnel adapter Local Area Connection* 7:

Media State . . . . . . . . . . . : Media disconnected
Connection-specific DNS Suffix . :
Description . . . . . . . . . . . : isatap.wildblue.com
Physical Address. . . . . . . . . : 00-00-00-00-00-00-00-E0
DHCP Enabled. . . . . . . . . . . : No
Autoconfiguration Enabled . . . . : Yes

Tunnel adapter Local Area Connection* 11:

Media State . . . . . . . . . . . : Media disconnected
Connection-specific DNS Suffix . :
Description . . . . . . . . . . . : Teredo Tunneling Pseudo-Interface
Physical Address. . . . . . . . . : 02-00-54-55-4E-01
DHCP Enabled. . . . . . . . . . . : No
Autoconfiguration Enabled . . . . : Yes
 

·
Super Moderator
Joined
·
82,234 Posts
You have a node type problem and may have a firewall problem. Make sure the network is designated 'private' on the Vista, and make sure on each machine that any non-Windows firewall is properly configured. After the following fix please show the nbtstat -n for each machine again.

XP Peer-Peer Node Type:

(from a JohnWill post)

The Peer-Peer node is the issue.
Create a file with the following contents in NOTEPAD. Save it as NETFIX.REG from the File menu of notepad.

--------------------------------------- Include data after this line ---------------------------
Windows Registry Editor Version 5.00

[HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\NetBT\Parameters]

"NodeType"=-
"DhcpNodeType"=-
---------------------------------- include data before this line -----------------------------

Double click the file and say Yes to the merge question. Reboot and see if you're cookin' again.
 

·
Registered
Joined
·
3 Posts
Discussion Starter · #6 ·
Thanks a lot Terry, that did the trick! It's mind-boggling to me that Microsoft would make it so complicated to connect 2 versions of their operating system together, but I guess it's good for the tech support industry. Thanks again, and great forum!
 

·
Retired Moderator
Joined
·
106,726 Posts
You can mark your own threads solved using the
button at the top of the first page of the thread in the upper left corner.©
:)
 
1 - 7 of 7 Posts
Status
Not open for further replies.
Top