Tech Support Guy banner

Solved: Static IP Address Doesn't Work on Server

959 Views 6 Replies 2 Participants Last post by  Couriant

I've build a Dell PowerEdge 2950 NAS box with Windows 2000 Server SP4. I've set a static IP for both integrated NIC's. But both connections don't work. I can't ping anything except for its own address and loopback.

But if I let Windows assign an IP address automatically, then both connections work.

I've checked that the static IP's I've set are not being used. The dns ip addresses are the same for all the other servers.

I've tried updating to the latest Broadcom NIC drivers but static IP still doesn't work.

Dell has switched to a new motherboard and the same issue appears. Anyone have any ideas on why this is occurring. Any help would be much appreciated.
Not open for further replies.
1 - 4 of 7 Posts
Thanks for the reply.

Think I've sorted out the issue. Just found out that all the network ports on my floor go through a switch that's set for a vlan on the subnet.

That's the subnet that's automatically assigned to the server. Hence I can't set it to the subnet as it won't work.

I'll try plugging it in to another port within the server room which I believe is set for a vlan on the subnet and see if it works.

I'm not too familiar with Cisco switches, vlan's etc. Do advise if I'm on the wrong track. Thanks.
I'll get in on Monday and check it out. I do believe there shouldn't be a problem setting the ip to the subnet in the server room. I've done that before rebuilding other servers.

Its just this time, I was building the server in my office instead which is on a vlan. And since its been set up that way, I wouldn't want to mess with it.

Anyway, will go in on Monday and check it out. Thanks for the reply and will post again once I sort it out.
Sorry for the late update. Turns out the ground floor is configured on a .99 subnet while the basement server room is on a .100 subnet. Plugged the new NAS box into the basement ports and there was no problems setting a .100 ip address. Thanks for the help. Case closed.
1 - 4 of 7 Posts
Not open for further replies.