Tech Support Guy banner
  • Please post in our Community Feedback thread for help with the new forum software! If you are having trouble logging in, please Contact Us for assistance.
Status
Not open for further replies.
1 - 6 of 6 Posts

·
Registered
Joined
·
8 Posts
Discussion Starter · #1 ·
Computer: Compaq Presario sr5610f
Ok so my mom, brother, and I were cleaning out my room for new furniture. I had left the room for a bit and when I returned my mom said my computer was making a grinding noise and shut it off, I did not care. Later I opened my computer case to clean it out (didn't turn it on after it got shut down) so I cleaned it out then I was looking at the mobo and wondered if what I was looking at a spare pci slot ( I have been wanting a new graphics card) so I asked my dad and he said yes and asked why I had my comp open and I told him I was cleaning it out, then he asked for it set it down and pretty much looked like he was having to struggle with the processor to get it out, he gave it to me to clean and I noticed the pins were bent and my dad broke a piece off a comb and straightened them.
Here's the problem. The computer starts up the fans go for about 10 seconds then stops. There is no display and no beep codes from the bios.
Please help I just spent 32 minutes typing this on my iPod touch and my fingers hurt.
 

·
Registered
Joined
·
12,661 Posts
When you put it back together, did you clean the old thermal paste off both the processor and the heatsink then reapply new paste?
 
1 - 6 of 6 Posts
Status
Not open for further replies.
Top