Tech Support Guy banner

[SOLVED] Hard Disk Controllers

2658 Views 41 Replies 5 Participants Last post by  jameylynnc

The computer won't run my internal CD-ROM or my external CDRW. When I look at the System Properties, Device Manager I see:

Hard disk controllers
! (with yellow circle) Primary IDE Controller (dual fifo)
! (with yellow circle) Secondary IDE Controller (dual fifo)
VIA Bus Master PCI IDE Controller.

I deleted the VIA Bus Master PCI IDE Controller and it got rid of the exclamation marks. Then I restarted. It ran through the "new hardware" stuff and when I checked the System Properties the exclamation marks and the yellow circles were back.

(It is not this computer that is the problem. I have three computers that I have to keep running and it is a different one that is the problem.)

How do I fix this problem?
Not open for further replies.
1 - 20 of 42 Posts
Got your motherboard driver disk handy? Re-install the drivers from there... (VIA 4-in-1,I think it is...)
OK. Didn't think of that. Thanks.
What OS? Sounds a lot like the issues I have had with Windows 98/95.

One way I've found of fixing that problem is to reinstall windows. But sometimes the motherboard is a little goofy and that doesn't work.

Be sure that your motherboards bios is set to PNP OS = NO and that all resources to the card are available (not reserved)

Sometimes putting the cd-rom as master and your HD as slave on the same channel forces the machine to work albeit slower.

Can you find drivers (4in1) ect for the motherboard? If so give them a whirl and it may fix the problem.

You'll be in for a fight

Good Luck
See less See more
Just discovered that the computer is not recognizing my internal CD-ROM and is recognizing my external in place of the internal. Does that mean anything?

And, how do the drivers for the motherboard get messed up and need to be reloaded?
OK. Installed the 4in1 and checked the drivers for the two items that have the exclamation marks next to them. All drivers are updated and correct, according the the computer. The Primary IDE and Secondary IDE controllers still have the exclamation marks and the yellow circle.

Last year we rebuilt the computer. Replaced everything except the internal CD-ROM. All the other pieces got fried in a power surge (worn out surge protector).

It is not recognizing my internal CD-ROM, could that be the problem? Do you think it might fix the problem to disconnect the internal CD-ROM and try using only the external RW?
Scratch that last. I tried it and it didn't help.
I'd concentrate on getting the internal to be recognised correctly.
Disconnect the external unit and check the BIOS to see if it is seen there correctly.It should be reported in the general summary information,but you may have to do an IDE auto search for it first,then check the summary again.

Couple questions; many IDE devices are you running on the board? you use any IDE controller cards? is the external unit connected?
4.were any of the IDE devices moved,replaced,upgraded before this occured?
5.can you list the motherboard make and model here?

P.S. You are using Windows,which IS a PnP OS...
See less See more
OK. Bear with me. I don't know a lot.

1. What is an IDE device exactly? The computer has the floppy, internal CD, external RW, Microsoft sidewinder steering wheel (I had it, it messes things up), sound card, video card. That is pretty much it.

2. IDE controller card? Don't think so.

3. USB (so is the steering wheel)

4. Nope. My son burned a copy of a CD yesterday, then the machine started having problems.

5. SOYO SY-7VCM, just over a year old.

P.S. (don't understand your abbreviations) Running Windows ME.
See less See more
Unplugged the external and restarted. It shows that it sees the CD-ROM during the startup screen. After the computer is started, I double clicked on the My Computer icon and opened that window. It does not show a CD-ROM drive at all.

Device Manager still shows the exclamation marks and yellow circles in the same place. CD-ROM tab is gone.
ok...,I'll take it slow and answer your questions first.
1.An 'IDE' device is a Hard-drive,or CD-Rom,DVD-ROM,or CD-burner.Most computers are designed to handle up to 4 of these devices,in just about any combination,although it does need at least one hard-drive to operate as a real computer.
2.An 'IDE Controler card' plugs into the motherboard and will usually allow up to another 4 IDE devices to be installed.These are used by people with multiple numbers of hard-drives and optical drives ( CD/DVD-ROMs,burners ).

Do you know how to get into the BIOS screens?

Usually,all you need to do is press 'Delete' as the computer starts.

In the BIOS,you will see a general summary screen that will tell you exactly what the motherboard sees is connected to the IDE junctions.From what I can tell of your system,it will have 2 IDE devices; a hard-drive and the internal CD-ROM.
You may have to do a "Auto Scan" for the IDE devices in one of the other BIOS screens,but at some point it should show the CD-ROM in the summary.
Once it does show up there,you should go to "Save and Exit" and the computer will reboot.
Let me know if you are able to see/do this...
See less See more
OK. I am in the BIOS. It doesn't see any CD-ROM. I went to the PNP/PCI Configuration setting. I enabled the Reset Configuration Data. It said to do that if you had added peripherals and the system was not working right. Restarted the computer. BIOS still doesn't see any CD-ROM.
I just had this problem on an IBM, I fixed it by going to the IBM website and downloading the IDE controller drivers and installing them, no more yellow anything now.
The computer with the problem is not connected to the internet. Can you download to a floppy or CD and install from that? Where would I go for the downloads. A SOYO site?
Also you will not see the CDROM until to correct this problem. You fix the IDE controller, the CDROM will appear.
The drivers are small and will fit on a floppy.
You already did this with re-installing the VIA 4-in-1...
Does the drive have a light on it that comes on when you reboot?
Does it open and close by the button?
1 - 20 of 42 Posts
Not open for further replies.