Tech Support Guy banner
  • Please post in our Community Feedback thread for help with the new forum software! If you are having trouble logging in, please Contact Us for assistance.
Status
Not open for further replies.
1 - 12 of 12 Posts

·
Registered
Joined
·
29 Posts
Discussion Starter · #1 ·
I have a PC and a laptop on my wireless home network, connected by a Belkin Router/Modem..
All was well until about a month ago - about the time a Nokia phone suite was installed on the PC.
I now have an unstable connection on this laptop and I have local or limited access only on the PC.
After uninstalling the Nokia suite I still can not get an internet connection on the PC even with an ethernet cable.
I would be grateful for any advice you can offer. Perhaps I should remove this network altogether and start again from scratch?
 

·
Retired Moderator
Joined
·
106,726 Posts
What's the version and patch level of Windows?
 

·
Retired Moderator
Joined
·
106,726 Posts
TCP/IP stack repair options for use with Vista or Window 7.

Start, All Programs\Accessories and right click on Command Prompt, select "Run as Administrator" to open a command prompt.

In the command prompt window that opens, type type the following commands:

Reset WINSOCK entries to installation defaults: netsh winsock reset catalog

Reset IPv4 TCP/IP stack to installation defaults. netsh int ipv4 reset reset.log

Reset IPv6 TCP/IP stack to installation defaults. netsh int ipv6 reset reset.log

Reboot the machine.
 

·
Registered
Joined
·
29 Posts
Discussion Starter · #5 ·
Done all the above - no change. Also rebooted and reset the router. Still local or limited conectivity. Network and sharing centre shows a connection to unidentified network (Public network) while the tray icon shows Unident... (my network name) Signal strength is excellent.
 

·
Retired Moderator
Joined
·
106,726 Posts
Changes that may help to increase the compatibility of Vista with older networking devices:

Disable the IP Helper service:

1. Hold the Windows key and type R, enter "services.msc" (without the quotes) and press Enter
2. Scroll down to the IP Helper service, right click on it and select Properties
3. In the dropdown box that says "Automatic" or "Manual", set it to Disabled and then click on "Apply"
4. Then click on "Stop" to stop the service from running in the current session
5. Click OK to exit the dialog

Disable IPv6:

1. Hold the Windows key and type R, enter "ncpa.cpl" (without the quotes) and press Enter
2. Right click on each network connection and select "Properties"
3. Remove the checkmark from the box next to "Internet Protocol Version 6 (TCP/IPv6)
4. Click OK to exit the dialog

NOTE: You should do this for each network connection.

Disable the DHCP Broadcast Flag:

Link: http://support.microsoft.com/default.aspx/kb/928233
  1. Hold the Windows key and type R, enter regedit and press Enter.
  2. Locate and then click the following registry subkey:
  3. HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\Tcpip\Parameters\Interfaces\{GUID}
  4. In this registry path, click the (GUID) subkey to be updated.
  5. If the key DhcpConnForceBroadcastFlag does not exist, use the Edit menu, point to New, and then click DWORD (32-bit) Value. In the New Value #1 box, type DhcpConnForceBroadcastFlag, and then press ENTER. If the key exists, skip this step.
  6. Right-click DhcpConnForceBroadcastFlag, and then click Modify.
  7. In the Value data box, type 0, and then click OK.
  8. Close Registry Editor.
NOTE: You should do this for each and every GUID subkey.
NOTE2: (GUID) is a mnemonic for the individual subkeys, the actual text "GUID" does not appaer.

The only program I'm aware of that currently relies on IPv6 is the new Windows Meeting Space. The first 2 changes will cause that program not to work - but will leave all of your normal (IPv4) connections unaffected. If it causes problems that you can't overcome, simply revert back to the original settings.
 

·
Registered
Joined
·
29 Posts
Discussion Starter · #9 ·
This made no difference either.
The IP address of my network adapter is 169.254.154.79 whereas my router IP is 192.168.2.1
I seem to remember something about IP addresses having to be within a certain range. Could this be a problem?
 

·
Retired Moderator
Joined
·
106,726 Posts
Yep, if you have 169.254.x.x addresses being assigned, your machine is not seeing the router's connection.

Try booting in Safe Mode with Networking and see if you can get connected with a wired connection first. The results of that test will determine the next course of action.
 

·
Registered
Joined
·
29 Posts
Discussion Starter · #11 ·
BINGO!
I have MAC filtering enabled on the router - guess which address was missing....
Must have lost it when I restored a backup of the router config.
Many thanks for your help... and your patience.
 
1 - 12 of 12 Posts
Status
Not open for further replies.
Top