Tech Support Guy banner
Status
Not open for further replies.
1 - 3 of 3 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter · #1 ·
Hi All,

I'm getting the balloon "A network cable is unplugged." when I plug my loopback (cable with box) into my NIC. I've verified that the same loopback works on another computer, where I get the message (~approx) "This connection has limited or no use," which means it works there. Do I have a NIC configuration issue? If so, how would I configure it correctly? My OS is Windows XP Home Edition, SP 3. My NIC is a Realtek RTL8168/8111 PCI-E Gigabit Ethernet NIC. The NIC on the other computer is a Realtek RTL8139/81Ox. My external loopback is a CAT-5 Ethernet cable about a foot long that is plugged into a small box at the other end that connects those pins 1 & 3 and 2 & 6 for the loopback.

Best regards,
 

·
Registered
Joined
·
2 Posts
Discussion Starter · #3 ·
Thanks for that, TerryNet.

With that, I was able to Google on external loopback wiring connections for gigabit ethernet and found http://www.tikkiweb.net/loopback , that had the wiring -In addition to 1&3 and 2&6, 4&7 and 5&8 also have to be connected- and a helpful reply about turning off the crosstalk cancellation - setting a loopback creates the appearance of 100% crosstalk. It said to check the datasheet. Googling around and downloading the datasheets, I read that lower than 1 Gbps modes don't have the crosstalk cancellation in my NIC. How to set the lower mode? The datasheet is full of things like "set this pin hi", and "write this register" etc. I realized that the driver installed on my PC should set that stuff. Sure enough, going into Device Manager or Network Connections, one can access configuration of the NIC. I selected the Advanced tab and set Link Speed/Duplex Mode to a 100 Mbps setting (100 Mbps/Full Duplex). Saying "OK" to that, my PC's network connection in the tool tray finally exhibited the correct behaviour, hunting, then displaying the message "This connection has limited or no availability", and my loopback was working.

Best regards,
 
1 - 3 of 3 Posts
Status
Not open for further replies.
Top