Tech Support Guy banner

Solved: ethernet switch possibly not recognized by my router

4881 Views 3 Replies 2 Participants Last post by  JohnWill
Hello everybody, I am in some distress, and would greatly appreciate your help

Here is my set up

Alright so my laptop and PCs (a) and (b) have the access to the internet. however my router sees only these three devices connected, as if my ethernet switch was not connected to the router. My problem is that the switch seems to work sometimes. Vonage is apparently having issues with the network setup so it doesn't work, same with my PS3, however the PC hooked up to the switch as well, sometime has internet and sometimes it doesn't. When it does have internet, Windows Xp pops out saying that there is an IP conflict with another PC on the network and then the connection is out. Any ideas of what is screwing up on my network? Any help would be greatly appriciated.

PS the ethernet switch is made by company Airlink
the modem is made by RCA
and the router is made by Linksys if that helps
See less See more
Not open for further replies.
1 - 4 of 4 Posts
The exact make/model of the modem, router, and switch would be real useful here.

What you seem to be describing is a flaky switch or cable, not much can affect a simple switch in that manner.

As far as the duplicate IP addresses on the network, that could well be a different issue.

  1. Turn off everything on the network, ALL the machines and any other network device like network printers and NAS drives.
  2. Turn off the router and modem.
  3. Turn on the modem, wait for a steady data light.
  4. Turn on the router, wait two minutes.
  5. Turn on the network devices and computers, one at a time.

This issue is usually caused by resetting a router without resetting all the network connected devices.

Another issue that will cause duplicate IP addresses is assigning static IP addresses to devices that conflict with the router's DHCP address range. If you require static IP addressed devices on the network, they should be configured to be in the same subnet but outside the address range defined for the DHCP server.
See less See more
Hello John,

Everything works now. I have done what you advised, and I think that the problem aroused as a result of me resetting each device on separately an not in order. I essentially reset my settings and followed your steps.

Thank you for your help.
Glad it all worked out.

You can mark your own threads solved using the
button at the top of the first page of the thread in the upper left corner.©
See less See more
1 - 4 of 4 Posts
Not open for further replies.