Tech Support Guy banner

[SOLVED] /etc/fstab

1405 Views 9 Replies 3 Participants Last post by  Whiteskin
ok, heres the problem, I updated my gentoo system, updated the configuration files, and not realizing it, updated my /etc/fstab also.... soooo saying that, my /etc/fstab file doesn't match my system now, I rebooted without catching that it got updated, and now it wont boot all the way because it cant mount /dev/ROOT , because it is supposed to be /dev/hdb1..

I have tried going into maintance mode, but the drive is read-only, I have tried unmounting /dev/ROOT , and re-mounting /dev/hdb1 to /, but it doesnt work.. I tried to mount /dev/hdb1 to somewhere else, but like an idiot, when I installed I only created swap and / *doh*

any ideas ?
Not open for further replies.
1 - 10 of 10 Posts
okie the default fstab file i believe is going to be /hda1 for the boot. (I in fact did this with my gentoo system a while ago and am trying to remember what i did to fix it. so try setting it in your lilo, edit it so it points to the hda1. If that doesnt work setting single won't work so other then that erm...having a backup after this would be useful.

that's the only thing i can think of right now is setting it to be the same as the fstab folder.
ok this is what is happening.. lilo boots, I choose my stable kernel, as I watch the letters fly by I see that it does mount /dev/hdb1... it continues to mount /proc and the rest, but when it goes to fsck /, it hangs and gives me the prompt to ctrl d to continue or go into maitnance mode.. ctrl d reboots it, and the rest you know.. last night I was playing with it and saw that in the fstab, It says "/dev/ROOT ext2 blah blah" when I check the /etc/mtab it says "/dev/ROOT xfs blah blah" I never heard of the /etc/mtab before this problem.. I really have no problem blowing it away and re-installing, but I was kinda hopeing that I didn't have to do that.. I just got fluxbox running the way I like.. lol
hmmm mtab i believe is written by fstab (ie overwritten) if i remember...when you mount and unmount so might be /dev/mount that overwrites it. (not 100% positive)

since you can get to your fstab file your actually in a good position, because you need to change the evil changed fstab back to your settings ie /dev/hdb1 ext3 noauto,2 etc. Change it back to the settings you want. instead of /dev/ROOT ext2 blah blah. That will fix it for you :) hope that makes sense ^.^;;.
There is a way to get mount to remount a partition, with diffrent permissions. This is what you need to do: Remount root rw. Then you can edit your fstab as you see fit.
yea, I thought there might be a way to remount it, but I tried to umount the /dev/ROOT and /, and neither worked.. I'll be home in about an hour, I'll be able to try it again..
oh man, have I ever said how much I love the linux community, I tried every single mount and umount command and I wasn't getting anywhere.. did a little checking on the web and found this great project.. the Gentoo Linux Boot Floppy, I will always have a copy of this around, I made the floppy, booted (with no problems) , mounted /dev/hdb1 to a /temp directory, used vi to re-write the /etc/fstab file and boom, it works great now.. well almost, lets just say that I will NEVER update ALL config files again.. lol
Cool. You really do have to love the linux community. When you find a place you belong: Here, There etc, once you have a place you like, you really do feel a part of the community. On, i work under the name geekzen. Look me up sometime.
hmm Whiteskin should use one nickname everywhere :p. I haven't spent much time at linuxquestions. I feel more at home here. Probably because i feel a bit more helpful.
Yeah. That and since gentoo doesnt have its own forum there.... probably because they have some sweet forums themeselves. Actually, i mostly use tragek. Whiteskin is from two years ago.... But i just got used to it here.
1 - 10 of 10 Posts
Not open for further replies.