Tech Support Guy banner
  • Please post in our Community Feedback thread for help with the new forum software! If you are having trouble logging in, please Contact Us for assistance.
Status
Not open for further replies.
1 - 14 of 14 Posts

·
Registered
Joined
·
24 Posts
Discussion Starter · #1 ·
I have tried to disk defrag and I keep getting the error message "Disk Defragment could not start." I've tried to reinstall it, checked to see if any of the solutions at :

http://www.andreasroom.com/blog/archive/2004/01/18/defrag.aspx

and

http://www.dslreports.com/forum/r21061920-XP-Home-Disk-Defragmenter-could-not-start

would help, and neither have, I have run Malwarebites and Hijackthis, both logs availiable if needed, however neither came up with anything.

Disk Defrag will work on my Recovery drive, but not my C: Drive.

Also, System Restore is not working. I get to select the point which I want to restore to, however when I select the continue / next button, nothing happens. Anyone have an idea as to what could be wrong? I've run anti-virus, anti-malware, (AVG, Malwarebites, Hijackthis) and I've re-installed things just in case a program may have erased it, my comp was last defragged 2 days ago. Never had any problems like this before. Thanks for the help in advance!
 

·
Registered
Joined
·
5,156 Posts
You might try right clicking on My Computer (XP) (Computer in Vista) select manage.,
select the defrag there. Sometimes when it won't work the regular way you can get it to work this way.
vicks
 

·
Registered
Joined
·
24 Posts
Discussion Starter · #4 ·
I have 80% of my hard drive space free... There's not much on this computer but the files it came installed with, World of Warcraft, and my virus protection. With that being said, the error message that displays is exactly that which I said before "Disk Defragment could not start."

Also, I have tried to run defrag from the /cmd and from My Computer (running XP Pro), and I get the same result. Works on my D: drive, but not my C: drive.
 

·
Registered
Joined
·
24 Posts
Discussion Starter · #7 ·
I've tried running in safe mode, still has the same error... and with the other disk defrag... I don't want to download anything else until I figure out why my windows defrag (which should run by default) and my system restore isn't working. :( Nothin I've tried so far has worked... always the same errors / non responsive programs, maybe running my Ops system disc that came with the computer will fix ?
 

·
Registered
Joined
·
5,156 Posts
I suspect that you must have an infection of sometype that you haven't been able to pick up. Suggest that you click on report (lower right corner of post) and ask a moderator to move this to the Malware Removal forum. The people there have special training for diagnosing/removing problems and are really good!!! There are only a few (have gold or green shields by their names) so it may take a bit of time for them to get to you.
Vicks
 

·
Registered
Joined
·
4,469 Posts
I believe I remember reading windows defrag needs 25% free space to operate. That is why I suggested an alternative.

This one:
http://kessels.biz/JkDefrag/

and auslogics I believe, can operate with as little as 15% free space.
 

·
Retired Moderator
Joined
·
106,726 Posts
Since you have 80% free space, I'd try a CHKDSK /F first, it will ask you to reboot to run it. After the reboot and CHKDSK run, try to defrag again.

I don't see any indication from your description that malware is involved at this point.
 

·
Registered
Joined
·
24 Posts
Discussion Starter · #12 ·
About 2 hours after my last post, the hard drive corrupted. I still have no idea what was wrong with it, but I had to reformat the drive :(

Good thing I had restore discs handy or we would have lost all the pictures we had of our kids.

Anyway, once again, thanks for all the help!
 

·
Registered
Joined
·
5 Posts
Hello jrm...I had the same problem as you .."disc defragment could not start" It drove me crzy. Also am having problems with explorer not allowing microsoft down loads and up dates. I think its a virus problem, but I did get derfag top work thanks to a post by "RootbeaR" Many thanks Bear.
He sugested to try www.auslogics.com/en/software...efrag/download
It downloaded for me and worked perfectly. Give it a try, and its free too. Good luck....
Cheers....Ray.....
 
1 - 14 of 14 Posts
Status
Not open for further replies.
Top