Tech Support Guy banner
  • Please post in our Community Feedback thread for help with the new forum software! If you are having trouble logging in, please Contact Us for assistance.
Status
Not open for further replies.
1 - 13 of 13 Posts

·
Registered
Joined
·
9,467 Posts
Discussion Starter · #1 ·
I've searched the web and all I'm finding is several years old and does not apply to Firefox 8.

I was using CNN videos until a couple of days ago; but, for a reason I don't understand, the player loads; but, I have nothing but black player screen after that. IE plays videos just fine and I have the latest editions of Flash and Windows Media Player on Windows 7 Ultimate.
 

·
Registered
Joined
·
57,788 Posts
If you can't play in safe-mode then it's blocked by a hosts file you have.
If no hosts file then site is made for IE.
When making change to hosts file the browsers needs to be restarted. No reloaded so close browser down and open it again.

Post a link to what you can't play.

Also newest flash version is 11.1.102.55 and Note the bit version you need.
http://www.adobe.com/special/products/flashplayer/fp_distribution3.html
 

·
Registered
Joined
·
9,467 Posts
Discussion Starter · #7 ·
Video that plays in IE and not in Firefox also applies to any Flash video in Firefox:
http://www.cnn.com/video/?hpt=hp_c2#/video/us/2011/11/12/ted-pamela-meyer.ted

I restarted FF is safe mode and now it tells me to reload Flash. I reinstall Flash, re-enable it and same result.

This is somehow connected to my profile. If I make a new profile, I can play videos. If I move everything from the old profile folder to the new, videos quit working. I have too many settings and scores of bookmarks to discard the whole profile. All I really need is the Bookmarks and Bookmarks Toolbar; but, that profile folder is very confusing to me. Every time I try to determine which files are related to just Bookmarks and Bookmarks Toolbar, it goes haywire.

It was simpler and easier when it used just a single Bookmarks file.
 

·
Registered
Joined
·
9,467 Posts
Discussion Starter · #8 ·
I've narrowed it to the prefs.js file. I deleted that file, started FF and the videos play. I've still got my Bookmarks and Bookmarks Toolbar so I guess I can reset my preferences as I like as I discover what is missing.
 

·
Registered
Joined
·
9,467 Posts
Discussion Starter · #9 ·
I think Prefs.js got corrupted. I looked into the old one (that didn't work) and saw a real mess. I'm uploading it as prefs.txt so you can take a look if interested. Scroll down about half way to see the mess.
 

Attachments

·
Registered
Joined
·
57,788 Posts
So does the prefs.js file just rebuild itself?

Odd we are seeing so many post where flash is not working right.
I did a lot of installs and upgrades and more then trouble with flash happen to me and a sysyem restore fixed it. But I was able to use flash in newer profiles and not ones I have and with many version of firefox and pale moon I did not want to redo each profile so a restore worked for me.

Wow what's all the "user_pref("CT1060933.backendstorage." and add coding?
Sure made the prefs file very big because mine is only 38 KB in one profile and 71 KB in another and 37 KB in another and 27 KB in another.
 

·
Registered
Joined
·
9,467 Posts
Discussion Starter · #12 ·
Yes, the prefs file does replace itself if deleted, but with prefs file with default settings. All that garbage and that huge size of the uploaded prefs file isn't normal, of course.

This wasn't a flash problem. This was a file-corruption problem.
 
1 - 13 of 13 Posts
Status
Not open for further replies.
Top