Tech Support Guy banner
Status
Not open for further replies.
1 - 16 of 16 Posts

·
Registered
Joined
·
45 Posts
Discussion Starter · #1 ·
It seems like every hour, I have to power cycle my modem and router because my connection drops. One minute the connection is fine and the next, I can't even get to my router's configuration page. I am using the opendns servers at the moment. My router is a Linksys WRT54G v8.2 flashed with DD-WRT and my modem is a Westell 6100. My ISP is verizon DSL.

------------------------------------------------------------------------

ipconfig /all:

Microsoft Windows [Version 6.0.6002]
Copyright (c) 2006 Microsoft Corporation. All rights reserved.

C:\Windows\system32>ipconfig /all

Windows IP Configuration

Host Name . . . . . . . . . . . . : Andrew-PC
Primary Dns Suffix . . . . . . . :
Node Type . . . . . . . . . . . . : Hybrid
IP Routing Enabled. . . . . . . . : No
WINS Proxy Enabled. . . . . . . . : No

Ethernet adapter Local Area Connection:

Connection-specific DNS Suffix . :
Description . . . . . . . . . . . : Realtek RTL8168B/8111B Family PCI-E GBE N
IC
Physical Address. . . . . . . . . : 00-1D-7D-A2-A7-5B
DHCP Enabled. . . . . . . . . . . : No
Autoconfiguration Enabled . . . . : Yes
Link-local IPv6 Address . . . . . : fe80::d472:e107:7fb5:9fb9%10(Preferred)
IPv4 Address. . . . . . . . . . . : 192.168.1.101(Preferred)
Subnet Mask . . . . . . . . . . . : 255.255.255.0
Default Gateway . . . . . . . . . : 192.168.1.1
DHCPv6 IAID . . . . . . . . . . . : 251665789
DHCPv6 Client DUID. . . . . . . . : 00-01-00-01-11-38-ED-DB-00-1D-7D-A2-A7-5B

DNS Servers . . . . . . . . . . . : 208.67.222.222
208.67.220.220
NetBIOS over Tcpip. . . . . . . . : Enabled

Tunnel adapter Local Area Connection* 6:

Media State . . . . . . . . . . . : Media disconnected
Connection-specific DNS Suffix . :
Description . . . . . . . . . . . : isatap.{DABAC350-10E9-4546-8E62-55868526E
13D}
Physical Address. . . . . . . . . : 00-00-00-00-00-00-00-E0
DHCP Enabled. . . . . . . . . . . : No
Autoconfiguration Enabled . . . . : Yes

Tunnel adapter Local Area Connection* 7:

Connection-specific DNS Suffix . :
Description . . . . . . . . . . . : Teredo Tunneling Pseudo-Interface
Physical Address. . . . . . . . . : 02-00-54-55-4E-01
DHCP Enabled. . . . . . . . . . . : No
Autoconfiguration Enabled . . . . : Yes
IPv6 Address. . . . . . . . . . . : 2001:0:4137:9e50:6c:a59:b80c:59db(Preferr
ed)
Link-local IPv6 Address . . . . . : fe80::6c:a59:b80c:59db%11(Preferred)
Default Gateway . . . . . . . . . : ::
NetBIOS over Tcpip. . . . . . . . : Disabled

------------------------------------------------------------------------

Thank you.
 

·
Registered
Joined
·
1,249 Posts
So your issue is only that you cannot communicate with your primary DNS server? I notice that you specified a secondary. The secondary works?

I think you are actually losing connection with your router. Disable wireless and connect through an ethernet cable. Still losing connection?
 

·
Registered
Joined
·
6,523 Posts
OK:Since I see no wireless connection on your ipconfig,I'm assuming only a hardwired connection with dhcp not enabled.
If this was not enabled for some reason,ok.If not,might try this:

Johnwill tip for DHCP Vista configuration

Configure DHCP for Windows Vista.
1. Click on the Start menu, and select Control Panel.
2. Click on Network and Internet. (Skip this step if you do not see this Control Panel item.)
3. Click on Network and Sharing Center.
4. Click on Manage network connections.
5. Right click on Local Area Connection and choose Properties. If Windows say it needs your permission to continue, click Continue.
6. Select Internet Protocol Version 4(TCP/IPv4) and click Properties.
7. Select Obtain an IP address automatically.
8. Select Obtain DNS server address automatically.
9. Click OK to close the TCP/IP Properties window.
10. Click OK to close the Local Area Connection Properties window.
11. Click Close to close the Network Connections window.
12. Click Close to close the Control Panel window.
13. Restart your computer.
 

·
Registered
Joined
·
45 Posts
Discussion Starter · #5 ·
So your issue is only that you cannot communicate with your primary DNS server? I notice that you specified a secondary. The secondary works?

I think you are actually losing connection with your router. Disable wireless and connect through an ethernet cable. Still losing connection?
I'm sorry, I should have specified. When my connection drops, and I run the diagnose and repair tool for vista, the error comes back as "Cannot communicate with primary DNS Server" and it gives the option to restart the network adapter but that does not solve the problem. I tried different DNS servers: OpenDNS, level 3 servers (4.2.2.x). I can always connect for ~45min to 2 hours but then the connection drops. I never need to change any settings though. I just power cycle the modem and router and I can connect again.

Also, even when I can't connect to any webpage (including the router's configuration page) I can still successfully ping the router.

OK:Since I see no wireless connection on your ipconfig,I'm assuming only a hardwired connection with dhcp not enabled.
If this was not enabled for some reason,ok.If not,might try this:

Johnwill tip for DHCP Vista configuration

Configure DHCP for Windows Vista.
1. Click on the Start menu, and select Control Panel.
2. Click on Network and Internet. (Skip this step if you do not see this Control Panel item.)
3. Click on Network and Sharing Center.
4. Click on Manage network connections.
5. Right click on Local Area Connection and choose Properties. If Windows say it needs your permission to continue, click Continue.
6. Select Internet Protocol Version 4(TCP/IPv4) and click Properties.
7. Select Obtain an IP address automatically.
8. Select Obtain DNS server address automatically.
9. Click OK to close the TCP/IP Properties window.
10. Click OK to close the Local Area Connection Properties window.
11. Click Close to close the Network Connections window.
12. Click Close to close the Control Panel window.
13. Restart your computer.
I tried DHCP but I can't even connect using automatic settings. My router is set up for DHCP as well.
Which version of DD-WRT is on your router?
version 24 service pack 1
 

·
Registered
Joined
·
45 Posts
Discussion Starter · #7 ·
Very puzzling.
When the connection drops,take a look at the modem and router lights.Do they look "normal".Modem,all lit and solid/blinking ?
Can you ping the default gateway ?
I can ping 192.168.1.1 when the connection drops, yes. I'll have to wait till the connection drops to check the lights. Right now the lights for the modem are: Power, Ethernet, DSL (the modem is in bridge mode so the internet light is not on). The lights for the router are: The orange cisco logo (this is the power light when using DD-WRT), ports 1 & 3, DMZ, and Internet.
 

·
Registered
Joined
·
6,523 Posts
Just a guess,but since you have connectivity to the router,I would say that the problem may be between the router and modem,lost dsl connection,but just a guess right now.
When it fails again,just to be sure.
let's see:
From a Johnwill post on the Networking Forum

Try these simple tests.

Hold the Windows key and press R, then type CMD (COMMAND for W98/WME) to open a command prompt:

In the command prompt window that opens, type the following commands one at a time, followed by the Enter key:

IPCONFIG /ALL

PING <computer_IP_address> For addresses,follow instructions below….

PING <default_gateway_address>

PING <dns_servers>

PING 206.190.60.37

PING www.yahoo.com
Right click in the command window and choose Select All, then hit Enter to copy the contents to the clipboard.
Paste the results in a message here.

<computer_IP_address> - The IP Address of your computer, obtained from the IPCONFIG command above. IPV4 for Vista

<default_gateway_address> - The IP address of the Default Gateway, obtained from the IPCONFIG command above.

<dns_servers> - The IP address of the first (or only) address for DNS Servers, obtained from the IPCONFIG command above.

If you are on a machine with no network connection, use a floppy, USB disk, or a CD-RW disk to transfer a text file with the information to allow pasting it here.
______

If we can still ping the router,but the other pings fail,might tell us something.
 

·
Registered
Joined
·
45 Posts
Discussion Starter · #9 ·
Well, the connection failed about 30 minutes ago, and the lights were exactly the same. Unfortunately, I didn't see your last post before the connection dropped, pedroguy. I saved your instructions in a txt file so I can run the tests if it happens again.
 

·
Registered
Joined
·
45 Posts
Discussion Starter · #11 ·
Version 24 SP1 for broadcom-based routers is very buggy. Read this sticky thread in the DD-WRT forum to learn all about it.

Read this to learn of recommended firmware versions. I think the currently recommend one is called EKO 12548. Install one from the list, then see if the problem continues.
I tried to upgrade, and everything looked perfect. but the Firmware is still v24-sp1 :confused: I selected the file "dd-wrt.v24-12548_NEWD-2_micro-plus.bin" (the EKO one) to upgrade too. Is it supposed to say "Firmware: v24-sp1" with the EKO 12548 firmware?
 

·
Registered
Joined
·
1,249 Posts
I don't know. I believe so, but I cannot recall. I do not have access right now to a WRT54 with DD-WRT. But if I am not mistaken, the date next to the firmware version will change. If not, look around in that thread and the forum itself. That download would not be recommended in that thread if numerous people say it has problems.
 

·
Registered
Joined
·
45 Posts
Discussion Starter · #13 ·
Well I haven't had problems since I "upgraded" my firmware. I use quotes because I'm not entirely sure I did it right. Nevertheless, I haven't had to restart my router in a good 5 hours. If everything is working tomorrow I may as well mark this solved, though I'm not confident. :/
 

·
Registered
Joined
·
45 Posts
Discussion Starter · #15 ·
I'm not sure what you mean. I meant I haven't had any problems since I installed the EKO Build that was recommended. I've encountered multiple annoying hitches and bugs with the original DD-WRT build, but none were serious enough for me to seek help. I could always fix or workaround them myself. I guess this was the last straw. I was about ready to revert back to the OEM firmware! Thank God I didn't have to do that, lol. So with the EKO build, my connection hasn't dropped yet. In fact, I had a download running all last night and the connection never dropped. It's a fairly large download too (~8GB). I think the EKO firmware upgrade did the trick.

Thank you.
 
1 - 16 of 16 Posts
Status
Not open for further replies.
Top