Tech Support Guy banner

[SOLVED] Belkin USB hub problem

23241 Views 20 Replies 3 Participants Last post by  kylake
I hooked up a Belkin model FSU021 USB 4-port hub today. Sofar, I cannot get the computer to recognize the hub.......device manager says unknown device and it (the hub) doesn't light up except briefly on startup. I am running Win98SE, 500mhz AMD, 64ram. Here is what I have done.......the Belkin site said it should just plug and play but if not. Use the Win98 cd-rom. copy the usb.inf file and put it in the Window/INF directory. I have done that and then going into device manager and clicking on the unknown device and selecting the windows wizard I have pointed it (the wizard) in the direction of using the usb.inf file for the hub........but it still doesn't recognize it. Any suggestions?

Thanks in advance. Larry
Not open for further replies.
1 - 20 of 21 Posts
Hi, Did the motherboard have any USB before the hub? If not- you may have to enable it in BIOS.
If you know the make and model of motherboard, or have a manual, it may explain what to do step by step. If its a system with no real good documentation, perhaps we can ID it for you.
Did anything show in Device Manager before for USB?
If the board had an USB controller, there may have been an entry, if it was turned off in BIOS, check for the setting "Disabled" and turn it on....the controller chip should be may not have a driver, Windows CD may not either, but it can be downloaded, either from chipset makers site or motherboard's.
I am assuming you know how to enter the BIOS setup- look at the screens, but dont touch anything except the setting to enable USB if it is not set so. You have to save and exit as it tells you, to make your changes stick.

Thanks for the help and suggestions. I have been in the registry before to fix problems.....but I have never been in the Bios and don't know how to get there. I learn quickly if you have the patience and time to work with me. There are two usb ports on the back of my Everex computer. I have only been using one for an optical mouse and that works fine and never had a problem hooking it up and getting the computer to recognize it.
I looked in the Everex pdf. file and here is what I found: hope this is some help I have a \: Rom PCI/ISA BIOS (2A5SHFOA), COMOS setup utility. Award Software, Inc. There is a setup program built into system BIOS and is stored in the COMOS Ram. Reading further it stated: The F% menu in BIOS is a feature for users to refer to the main board setting in the BIOS top level how do I get into BIOS. I am familar with DOS

Hope this is some help and if not let me know what you need

Thanks again, Larry
Larry- Say hi to another Everex owner....Explora here.
You do not need to go into your BIOS far as I can see, you have USB devices and ports that do work, so that should not be your problem.. All I can give you is, follow the directions from the website for Belkin, use the directions for your OS and model hub you have....the manuals they give you really arent that good.Sorry cant help you more.
Do you know if you have a VIA chipset- Device Manager can tell you- Hard Disk Controllers, is there a VIA Bus master PCI IDE controller listed? For VIA chipset based motherboards, VIA provides updated drivers.... post back.
You can try this from Safe Mode, too- in the Device Manage, highlight the Unknown Device, click Remove, and try again- do this without any devices actually plugged into the hub, tho.
I can't find anything on a Belkin FSU021 USB 4-port hub.

Are you sure it isn't a Belkin F5U021 USB 4-port hub?

If so, did you check for updated drivers?

Thanks for the suggestions. I will check the VIA as you suggested and post back. Yes, my model of everex is also an explora.

Virtual Me, Thanks also. You were right it is an F5U021.....guess I need to use glasses more at my age. I had checked the Belkin page for updated drivers but there was nothing but pdf. under that model number......they seem to think it should just plug and play.

I will get back to both of you shortly as I am cooking at the moment and after I eat I will return if ya'll are still here.

Thanks, Larry
Virtual Me,

I checked the link to the drivers you suggested and that is one of the first places I went to get help. I thought I might have missed something but there are only instructions for connecting and user drivers........boy, I wish there were. I could be an easy fix.

Byteman, I will get back with you in a while.......still have to eat.


It is a VIA BUS Master PCI IDE Controller

I don't know exactly what that means but maybe it will be of some help you in figuring the problem.

Hi, Don't know the age of your computer, my Explora is from 3/2000, and I have updated the VIA 4inone drivers about 3 times.... let's find out what motherboard you have.
Please, when you have time, need not be today- download the Belarc Advisor from here:

it's a small hardware IDer that we reccommend to show you the hardware, chips, devices and software installed on your machine, in an easy to see one page format. It's free.
Download to your desktop, 2 click the file to install, then run the program from the desktop icon whenever you feel like viewing the info. it is prinitable, and does contain you Windows Product Key Code numbers, that you need when you case you do not have them recorded someplace, this is a good time to do so. Saving the page it displays to a floppy disk is also good to do.
Tell me what it gives you for Mainboard or System Board, that is your motherboard ID....mine is a FIC SD-11....if yours is too, I know just where to get an updated driver that has patches you may need for your system. Also, tell me what it shows for Video Adapter (Graphics)....
Whether it fixes anything to do with the USB hub, I cant really say, but it's a good idea to patch the system while you can. These VIA 4inone drivers are self-detecting, they install only what you need, and contain USB updates along with the rest.
The only other thing I can think of is the possibility that your antivirus program, if left on in the background, might have messed up the want to be sure and turn off antivirus temporarily (which means turn it back on after you are done!!) during software, driver, etc installations. Remote possibility that the hub might be slightly bad....let's hope not.
See less See more
I will try what you suggested in your last post. As it is getting late I will probably not install Via updates till tomorrow evening after I get home from work. I get up about 4 am everymorning and because of that, turn in pretty early. Thanks a lot for your help and suggestions and I will try them and get back to you tomorrow if you are online and checking this board.

Thanks again, Larry

I will download and run the Belarc now so that I will know what updated to download for the Via tomorrow.
Larry- Please do whatever you do at your convenience....I should be around tomorrow, but probably not until later in evening. Also, I have edited my last post, as I did not want you to install the VIA stuff till we ID the motherboard and a few other things. See you whenever, Bill

I am back whenever you get back on. I should be ready to give you the information you need as I ran Belarc last night. Hope you are there and I am not out for the night when you arrive.

Thanks, Larry
I just talked with a Belkin tech support......I explained what I had done and where I had the USB hub pointed to get it's drivers in the USB.inf file and they said it should be returned for another unit as it may be bad. Buuuuuut if you have the time I would like to up grade the board........along with your help and see if that fixes it and if not it is probably some thing that needs to be done anyway.

Thanks. Larry
kylake---Ready aim etc. What did you see under Belarc as far as Main or System Board? Chipset? USB?
Here is Main: Board: Everex Systems, Inc. PAG2130 PCB 1.x
Bus Clock: 100 megahertz
BIOS: Award Software International, Inc. 4.51 PG 01/05/00

Here is bus adapters: VIA Tech 3038 PCI to USB Universal Host Controller
VIA Tech 3038 PCI to USB Universal Host Controller

What else do you need?

larry- Here is the page to get the drivers for your system.
Click the win98 link for the VIA Chipset drivers, takes you to FTP page, click the FTP server link.....Right click, Save Target AS.....just put it on the desktop unless you have a special folder created for saved downloads. Find the download when it completes, in Windows Explorer, or on your desktop....double click it to install, follow the prompts. You may or may not have an AGP video card, it may be PCI, or onboard chip....the driver download contains an AGP driver file....if you leave all the boxes for all drivers to install, if you do not need the AGP it will tell you so....follow the directions. It's fairly simple.
As I said, this may not cause any great difference in the hub problem, it could very well be a defective hub. I use the updated VIA drivers, and they seem to make a lot of difference from the original ones that came with the computer back in 2000.
Good luck! Reply if there are any questions.
See less See more
Guess I am dumb........I went to this url
And saw the 5.31 version and clicked on it. Then it gives me a new page with several file folders. I tried double clicking one folder and it brought up another page with more file folders.........I guess I am dumb because I don't know what I am suppose to do to install.
When we get passed this I will go to the next url you listed.

Help from a dummy, Larry
Larry- I had first posted a link to that page, but changed my mind when I tried....that link would work, but the file is in .zip format, was not sure you had WinZip there or any file unzipping program, so changed to an .exe file at the new link....I edited my post, sorry if this confused you....just cancel out of anything before....and try the link in MY post just above your last post. It has links for win98, click that, shows one link in blue, right click on that and select "Save Target AS" put the file on desktop or as I posted up above, in your special downloads folder....and follow directions above from that point.
Byteman, Bill

Thanks for your help. You might have known just when you were giving me directions to try and fix the problem last night my server had a problem and I was booted and couldn't get back on.
Well I ran the VIA 4in1438exe. and I am sure that my computer is a much better person for it...I am sure it was an upgrade that it has needed for a long time and everything (scanner connected to USB) is running ok after the install..............but it didn't fix the Belkin USB hub problem........boy, did I have my fingers crossed. Thanks for all your hard work and effort and I learned some interesting information from you like Belarc (neat utility) and the upgrade for VIA. I always seem to learn alot from a computer problem an a nice person like you that has the patience to help. If you have any other ideas I will try them.
Yes, you were right after you had edited and changed your original suggestion....I was confused and thought I had imagined the first response....what a hoot.

Thanks again, larry
See less See more
Hi Larry- Well, keep trying, perhaps someone will help you out...
glad the VIA drivers got installed... You could I suppose return that hub, try another, that just might be a bad part OR cables you got.
Might save you a lot of frustration, too. Be sure and uninstall the device and drivers as it says to, if support site for Belkin provides any, most places do. I have a lot better luck doing uninstall/reinstall for USB devices and software from Safe Mode.
If you do this, there is a possibility you will be asked for your Windows CD, if the .CAB files are on your hard drive, just set the settings for wizard to search there, usually C:\Windows\Options\Cabs
There may also be a C:\win9x (your operating system version folder) created by whoever installed your system.
They do this for a reason, so you dont need to pop the CD in every time Windws setup wants to see it...
I tried installing a PCI USB 2.0 card for a friend recently, they had an old computer, but did have USB support, win98se, but the USB 2.0 drivers would not install for me- and I have seen others with the same problem. A hub I guess should be easier than a card, the way they claim anyway....hoping that you send it back and get a new, and good, hub. Bad parts are quite common, so are bad install CDs by the way, got one of those for a modem, store took it right back and exchanged for brand new box.
See less See more
1 - 20 of 21 Posts
Not open for further replies.