Tech Support Guy banner
Status
Not open for further replies.
1 - 5 of 5 Posts

·
Registered
Joined
·
238 Posts
Discussion Starter · #1 ·
I am trying to use an old EPSON Perfection 1200U scanner with a new PC running Windows XP. The scanner is several years old and was supplied originally with software for 98SE. I /suspect/ that the USB port may be only USB 1.0. tho' I may be wrong.

I tried the original set-up disks which came with the scanner, but not surprisingly they did not seem to work with XP. The XP hardware wizard reported an error that the 'class controller' would not install the device. I then downloaded new TWAIN drivers from the EPSON website and these /appeared/ to have installed OK, but I still can't access the scanner.

I wrote to EPSON for advice and got the following reply (edited a bit):-

"The 'Class Installer' error message relates to the operating system Windows XP. The class installer is a built in program on Windows XP that will not allow the scanner to be installed more than one time within the Windows registry. This may have occurred if you tried to install the original and unsuitable driver from the CD-Rom and then the latest, suitable TWAIN driver from the Epson website or vice versa.

If the latest drivers have installed correctly then there is no need for concern. You will need to test the drivers with a TWAIN-compliant application such as PhotoShop, Word, Epson Creativity Suite etc. Otherwise, the only resolution EPSON can advise is to do a system restore on the computer to a point where the scanner was working or not installed. If this is unsuccessful or for any reason you can not do this then you will need speak to Microsoft about the class installer and how to disable it."

As the relevant restore point is now about a week ago, and I've been configuring and adding a lot to the PC in the meantime whilst awaiting Epson's reply, I'm loathe to have to go so far back and then repeat all the subsequent work.

Can anyone please suggest anything easier/quicker that might help to (a) get rid of the old drivers and/or registry settings, (b) check whether the problem in fact is with the scanner USB, or (c) diagnose any further to determine the real problem?

Any advice welcome :)
 

·
Super Moderator
Joined
·
65,526 Posts
I dont know the error - so you may want to wait for another answer - but I would look in device manager and see if i can see the device and uninstall from there

also go onto the epson website and get the winXP drivers for that scanner if they exist
 

·
Registered
Joined
·
238 Posts
Discussion Starter · #4 ·
My thanks to those who have responded so far.....

Fortunately, everything seems to have turned out OK in the end - perhaps more by luck than judgement!! I /thought/ that after the attempt to install the drivers last week I might have rolled-back anyway at that stage, so I ran the XP Add Hardware wizard again "just to try".

For some curious reason the wizard would not recognise any of the downloaded Epson files as a suitable driver and went off to download an (apparent) Windows default
usbscanner DLL instead. Neverthless, it is actually Epson Twain 5 that now
runs with the scanner!

Problem fixed - fingers crossed! :up:
 

·
Retired Moderator
Joined
·
106,726 Posts
Great, don't mess with success! :D

You can mark your own threads solved using the thread tools at the upper right of the screen.
 
1 - 5 of 5 Posts
Status
Not open for further replies.
Top