Tech Support Guy banner
Status
Not open for further replies.
1 - 5 of 5 Posts

·
Registered
Joined
·
5 Posts
Discussion Starter · #1 ·
I am still unable to restart on dos-mode. I renamed dosstart.bat to dosstart.old now either of them can be found. Is there anyway other way I can get into dos and how do I get my original dosstart.bat back?
Thank You
 

·
Registered
Joined
·
45,855 Posts
If you renamed it, it should still be there. When you do a Find Files search for dosstart.old if it can't be found, it may be because you spelled it differntly -- perhaps dostart --

You can also use Windows Explorer to go to your Windows directory; select View>arrange icons by name, and then scroll though the directory to see if it shows up with a slightly different spelling.

I don't know why you are still having problems getting into MS-DOS mode, it may be a video driver conflict. Those can be hard to sort out.

The other way to do it is to shutdown. Then restart and press and hold the control key until you get the Boot Menu. Then choose "command prompt" form the Boot Menu. When you get the c:\ prompt, enter:

scanreg /restore

use the arrow keys to select one of the registries you think might predate the problem.
 

·
Registered
Joined
·
5 Posts
Discussion Starter · #3 ·
I will certainly give it a try and let you know the outcome.
I don't know what else to say... I've thanked you do many times. You're a doll
 

·
Registered
Joined
·
45,855 Posts
I just don't want to see you get into any problems more serious than you have. Hopefully restoring a registry, even if it doesn't fix things will not make anything worse. You can always go back to todays date. There's a gremlin in there someplace, as far as the restart in ms-dos mode is concerned, but you should be able to accomplish what you want the other way.
 

·
Registered
Joined
·
2,636 Posts
Once you find/have the dosstart.bat file in the windows directory, then it is time to move onto the 'exit to dos' icon in the windows directory.

right click on the "exit to dos" icon>properties>program tab>make sure "close on exit" is checked>then click on advanced>uncheck "suggest ms-dos mode">then check ms-dos mode>uncheck "warn before entering dos">then select "specify new ms-dos configuration">

Then you just load the drivers in the config.sys and autoexec.bat windows and OK out.

I have had to do this to be able to restart in dos using start>shutdown>restart in ms-dos mode, for my computer cuz it is picky like that.

an example of my config.sys

device=c:\windows\himem.sys
device=c:\windows\emm386.exe noems
dos=high,umb
devicehigh=c:\cd\aoatapi.sys /d:mscd000 /dma

an example of my autoexec.bat

lh mscdex.exe /d:mscd000
lh c:\progra~1\micros~1\mouse\mouse.exe
SET BLASTER=A220 I2 D1 T4
lh c:\windows\asp4dos.com

Note, if by any chance you are multi booting and use a boot loader, make sure the windows Version that you are using to do this, is the default OS in the boot loader. Default meaning, when you are prompted to select an OS at bootup and you don't select anything it will load the the version of windows you are working with.

Also after your computer has restarted in dos, and you are done working in dos, you will want to type "exit" to return back to windows.

You can also create a shortcut to command.com and restart that way by editing the properites like you would with "exit to dos". Then you could just click on the icon to restart.

You can also do the boot menu like Rollin Rog said.

And if you need to get into dos bad enough, you can always boot from a startup disk.
 
1 - 5 of 5 Posts
Status
Not open for further replies.
Top