Tech Support Guy banner

Remote Desktop now times out of a session erratically

1027 Views 15 Replies 2 Participants Last post by  imfloyd
For years I have RDP from home to my store with very little problem. Win7 Pro to Win 7 Pro. However since I updated the PC (clean install of Windows 10 Pro) at my home; when I RDP to the store (Win 7 Pro PC), it connects quickly as always and works. However, the session constantly times out and have to wait while it reconnects. Doesn't seem to be any common circumstance that is pattern. 1- If if continually work in that session, I don't think it will time out. 2- Always noticeable when I work on the local PC (one monitor) and work in the RDP session (2nd monitor). 3- Symptom time is inconstant. Sometimes it times out within 3 to 5 minutes, other times 10 to 15 minutes. Regardless, before the Win 10 I would connect and stay connected for 5 to 7 hours while working in session and or on the local PC.

I intend to upgrade the office PC to Win 10 Pro the next time I am at location location, hoping that will resolve. But I will not be there for 2 months and my productivity is suffering. I have Googled this symptom and checked several of the session settings on both PC's and have found no solution. Most of what I find deals with Win Servers version, neither of which these are. Nothing at the store PC has changed and noticed this symptom just days after the fresh install of Win 10 Pro at my home PC.

Any advise would be extremely helpful.
Thanks, imfloyd
Not open for further replies.
1 - 16 of 16 Posts
Have you tried on the Win 7 Pro, going in to GPedit, the following key :
Computer Configuration
Admin Templates
Windows Components
Remote Desktop Session Host
Session Time Limits
And see if any of the settings there make a difference?

And also in Start > Administrative Tools > Local Security Policy
Security settings > Local Policies > Security Options > Microsoft Network Server: Amount of idle time required before suspending session. Set it to longer than 15 mins
Thanks for the reply. I recheck the 2 settings you recommended. Suggestion 1: (Snippet below) the 1st 2 lines were enabled and set to Never. The 3rd line was not configured, so I enabled it and set to never. The 4th line is at it appears here. Doesn't sound like that is an issue? Rebooted and did not make a difference.

Azure Rectangle Line Font Parallel

Suggestion 2: (Snippet below) I followed the path and found "Amount of idle time required before suspending session" was set at 15 minutes, so i reset it to 360 minutes. Rebooted the PC and find that RDP session times out at 5 to 15 minutes, if I am working directly in that session.

Rectangle Font Screenshot Software Electronic device

By your reply are you suggesting that my issue is in the settings on the Win 7 PC? About the only known I am sure of, is that I have been using RDP since the XP days, then on to Win 7 and don't recall any issues like. I'm not at the store location at which I remote to before the Win 10 install, I would RDP for 6 to 8 hours a day. Nothing has changed on that PC. It's only purpose is to house a few shared program data files available to that users on that local network and for me to RDP into. No one locally has the rights to use that PC as a workstation.

I appreciate your help and will any and all of your suggestions.

Thanks, Dan
See less See more
Try both things on the Win 7 machine and see what happens.
Step 1 On the Win 10 PC: all of those
1st step: all were not configured, so I enabled and set to never. 2nd step: was set to 15 minutes, so i reset to 360 minutes. acts the same way, times out within 5 to 15 minutes. Could be a bug?
Could be a interoperability problem between win 7 and win 10
Ha, well, Thanks for trying. Guess I'm the first in the world to RDP from Win 10 to Win 7.
LunarLander, Concerning this issue, I had an IT professional take a look at this issue. Is his statement true?
"Windows 10 was designed with security in mind - With that said, there is no way to have an indefinite RDP open, at about 15 minutes of inactivity, it will disconnect."
"It is a security protocol within Windows."
That IT professional has a point. But.

Lets check another item. On your Win 10 machine, are you running a 3rd party antivirus ( that is, not Windows Defender )
Windows Defender. But do have Malwarebytes and CClearner services running, not sure if that counts?
UnInstall MalwareBytes . Test and see.
1- I uninstalled CCleaner & Malwarebytes from both PC's to see if there was any change. Still times out, but over the weekend I did notices something. I have been timing the amount of inactive time it takes to timeout. There were times that it disconnected within 3 to 4 minutes and others at 7 to 12 minutes. If it were a timeout issue, wouldn't it be 15 minutes each time? Could this issue be something other than a timeout setting, since so erratic and we have tried a gob of settings & things?

2- I attached a screen shot I took with a phone, is this what you see following a timeout? BTW, when it disconnects it takes about 20 seconds, after clicking on the desktop to reconnect. I discovered that's more time than if launch RDP from the shortcut, does that make sense?

Font Gadget Technology Display device Space

3- I hope not but, ANYWAY the IT person's statement could be right? "Windows 10 was designed with security in mind - With that said, there is no way to have an indefinite RDP open, at about 15 minutes of inactivity, it will disconnect."
"It is a security protocol within Windows."

I really appreciate your persistence with my issue!

See less See more
On your Win 10 PC, start Task Manager, go to the Processes tab and click on the Network column header so that it sorts the list from highest user to lowest. Leave the screen on, to one side but visible, and run your other normal things. See if anything consumes networking that is abnormal.
Watched while working an hour & half. Nothing out of line? when opening most used apps: MS Outlook; 0.1 Mbps Acronis True Image; 0.1 Chrome; 0.1 QuickBooks; 0.1 (after open) when working in QuickBooks would get as high as 0.7 Mbps momentarily, but drop down. However symptom still occours when i log out of Quickbooks. MS Teams; 0.1 RDP; 0.1 MS OneDrive; .01 Mbps ........ as I open other apps see about the same thing.

Noticed while doing this testing, twice RDP disconnected within 2 minutes.
This morning I installed RemotePC on the Win 10 PC and Win 7 PC. I wanted to test a different option. It's interface is pretty ugly (resolution), difficult to print and is a resource hog. Anyway it consistently disconnects as well at around 8 minutes. However it does start right back up immediately, where RDP takes up to 1 minute? RemotePC is not a good replacement for RDP. Tried TeamViewer (private) and it disconnects much the same as RDP.
1 - 16 of 16 Posts
Not open for further replies.