Tech Support Guy banner
  • Please post in our Community Feedback thread for help with the new forum software! If you are having trouble logging in, please Contact Us for assistance.
Status
Not open for further replies.
1 - 2 of 2 Posts

·
Registered
Joined
·
337 Posts
Discussion Starter · #1 ·
The site has been done in flash.
Here is my email form I type all information into it Name, Email,Subject & message it says Message sent
the message doesnt get sent to my email. what am I doing wrong.
Yes I'm a newbie
[email protected] just blanked out
--------------- just blanked out
:confused:
-----------------------------------------------------------------------------------------------------------------------------------------------------------:confused:
<?php

$emailAddress = "[email protected]";

$siteName = "------------------------------";

$contact_name = $_POST['name'];
$contact_email = $_POST['email'];
$contact_subject = $_POST['subject'];
$contact_message = $_POST['message'];

if( $contact_name == true ) {
$sender = $contact_email;
$receiver = "[email protected]";
$client_ip = $_SERVER['REMOTE_ADDR'];

$email_body = "The Name Of The Sender: $contact_name \nEmail: $sender \n\nSubject: $contact_subject
\n\nMessage: \n\n$contact_message \n\nIP ADDRESS: $client_ip \n\n$siteName";

$emailAutoReply = "Hi $contact_name, \n\nWe have just received your E-Mail. We will get
in touch in a few days. Thank you! \n\n$siteName ";

$extra = "From: $sender\r\n" . "Reply-To: $sender \r\n" . "X-Mailer: PHP/" . phpversion();
$autoReply = "From: $receiver\r\n" . "Reply-To: $receiver \r\n" . "X-Mailer: PHP/" . phpversion();

mail( $sender, "Auto Reply: $contact_subject", $emailAutoReply, $autoReply );

if( mail( $receiver, "New E-Mail - $contact_subject", $email_body, $extra ) ) {
echo "success=yes";
} else {
echo "success=no";
}
}
?>
----------------------------------------------------------------------------------------------------------------------------------------------------------:confused:
 

·
Registered
Joined
·
696 Posts
Not nearly enough information to help figure this out.

Try adding this line to the top of your php script and see if your form is being submitted correctly:
Code:
var_dump($_POST)
Check the names and values of the form fields and make sure they are what you expect.

Also check your mail server logs for any messages to see whether there are any problems with your mail daemon.
 
1 - 2 of 2 Posts
Status
Not open for further replies.
Top