Tech Support Guy banner
Status
Not open for further replies.
1 - 20 of 21 Posts

·
Registered
Joined
·
21 Posts
Discussion Starter · #1 ·
Running win xp pro w sp1 and I have run updated antivirus and several antimalware programs in the hopes of fixing this problem but its still here. When i am on the net and click on a link to go to another site it starts to go to the other site but stalls at a white, blank page. I cant even get out of it, cant right click and close it, its just stuck there. The only way to get rid of it is by using task mgr and then "end task" feature. Same thing with outlook express, i click on a link to another site the same thing happens as noted above.Sometimes i can cut and paste the link but i cant just click on it, end up with a blank white page that i cant get rid of. Sometimes the system freezes right up. I can move the mouse around but i cant close anything i have open, nothing. I can open new pages and new folders though. I am running avg a\virus and antimalware, along with spybot and other such progs. Internet is explorer 6 and i am running zone alarm pro, peer guardian. I figure its maybe a setting somewhere but i cant find it or its malware of some type, but cant do any better than that, cant isolate it. Few days ago i tried using "system file checker" but i had to close it because it asked for my win xp pro cd, i put it in both optical drives and i I got a message saying i used the wrong cd. I didnt use the wrong cd as i only have the one. I dont know if this sfc problem relates to the one i am talking about or not. One other thing. Sometimes, the first time i click on internet explorer it wont open, i have to click a few times to get it to open.

Ive changed the batteries on my wireless keyboard and my wireless mouse is working fine as far as i can tell.

Can anyone help me out, please?

thanks
 

·
Registered
Joined
·
1,956 Posts
Here is one possible explanation why your product key is different.
Quoting from the magical jelly bean website:

"Q: Why doesn't the product key returned match the one on
my sticker?


If you purchased your PC with Windows already installed from
a large manufacturer such as Dell or HP, it's likely that Windows
was installed using an OEM key instead of the actual key for
your PC. This saves them (and you) money because it's much
more efficient for these large companies to install Windows once
and then clone the drive."


OK...step one...go here and read/download Magical Jelly Bean.
http://magicaljellybean.com/keyfinder/

Step two...
Then since you are using IE6, go here read/download IEfix.
http://windowsxp.mvps.org/IEFIX.htm
 

·
Registered
Joined
·
21 Posts
Discussion Starter · #3 ·
I dont think step 1 applies to me. I do have a legitimate win xp pro. To that i slipstreamed sp1. But i believe that i installed sp1 on my pc separately so therefore the original cd should work when i run "sfc", but it doesnt.

I will attempt step 2.

thanks
 

·
Registered
Joined
·
21 Posts
Discussion Starter · #4 ·
step 2 doesnt work. I get an error message:

INTERNET EXPLORER FIX
run-time error "429"
ActiveX component cant create object

I will go check that out.
 

·
Registered
Joined
·
1,956 Posts
IEfix will attempt to run SFC (system file checker). If you have
an incorrect product key, IEfix won't work, so that is why I said
to use Jelly Bean to be sure the number you have is correct.
Whether your copy is legitimate, doesn't really enter into it.
You just want to verify the number.

step 2 doesnt work. I get an error message:

INTERNET EXPLORER FIX
run-time error "429"
ActiveX component cant create object
Do you have Visual Basic 6 installed? XP comes with it,
maybe it got damaged. If you are not sure, try installing
again.

http://www.microsoft.com/downloads/...61-7A9C-43E7-9117-F673077FFB3C&displaylang=en

Another reason might be if you have Office installed?
http://support.microsoft.com/kb/260885

I have never tried reg-cure. But notice that it says free scan.
free download. Does not say freeware. And there is a link
for ordering it. My guess: it scans and only fixes a couple
of problems or it fixes nothing until you pay for it.

Here is one that I use and trust after checking several. Only fix
the items it flags as safe to fix. It is freeware. You get a few nags
to register from time to time, but just cancel them out.
http://www.majorgeeks.com/Wise_Registry_Cleaner_d5437.html

Wise may fix something but more likely it will not solve your problems
though.

If problems persist after running Wise, I would verify your product
key first. And either attempt to run SFC on your own or install
VB run-time 6.0 and try to run IEfix again.

Also to be sure nothing is being blocked, temporarily disable all
spyware/anti-virus/firewalls. You don't have to stay connected to
the net to run these programs on your computer.
 

·
Registered
Joined
·
21 Posts
Discussion Starter · #8 ·
I am now trying the directx 9 (i take it vbrun is the same thing?)

Even the links posted here, i cant go directly to them, system freezes up except i can get to task mgr and get going again.
Then i have to copy and paste the link into my browser to get it to work.

thanks to all for their info\help, i really appreciate it. Dont be upset with me if i dont try something i am afraid of, though.
 

·
Registered
Joined
·
21 Posts
Discussion Starter · #9 ·
VistaRookie came up with the solution. I decided to try installing direct x 9 and that seems to have worked. It looks like case solved but its smart to wait a bit.
I will post later today if all is still well or not. But i can now go into outlook express and click on a link and have the browser open to that link, so right now its fixed.
.
Thanks very much to VistaRookie and all those who posted advice Its really appreciated!

I have had this install of xp pro on my MSI neo mobo with pretty much all the same hardware except my newer dvd burner going for 7 to 8 yrs now i believe.
And its filled with tons of trialware, crapware, junkware and goodware. So i have been pretty lucky and now you guys have fixed this so i can continue to work on my new rig and replace this unit that i just love but it has been getting slow, lol.


thanks again.
 

·
Registered
Joined
·
1,956 Posts
Still doing good?
Very nice of you to give me credit but truly the credit goes
to you, I never did mention Direct X.

Why not mark this thread solved?
 

·
Registered
Joined
·
21 Posts
Discussion Starter · #11 ·
The reason i gave you credit was because you pointed me here:

http://www.microsoft.com/downloads/d...displaylang=en

vbrun wasnt listed there but the first item listed was directx and i mistakenly thought they were one and the same!
Since it worked i gave you credit.
It did work to about 75% efficiency. I can click of most links and they will open. But the link in my email, for instance, to this thread didnt work. Windows gets further but still gets stuck trying to open up the page. But as stated, most of the time now i can open links without having to cut and paste them.
I think i should try vbrun now.
I will do that and get back.
thanks
 

·
Registered
Joined
·
21 Posts
Discussion Starter · #13 ·
I think that i have one or more corrupted system files. Maybe i have been done in by a trojan or some other piece of malware, or a setting that i cant fix or dont know how to fix. Its hard for average people to know all that is stated in zone alarm pro, avg antivirus and all the other dozens and dozens of progs on this machine.
 

·
Registered
Joined
·
21 Posts
Discussion Starter · #14 ·
I dont understand why you want me to install the magic jellybean prog when sfc didnt mention anything about my cdkey, it only said i was using the wrong cdrom, and it didnt ask me for any cdkey at all. There can only be the one cdkey that is listed somewhere here in windows and that cdkey i already know. Or i am missing something, lol, so what am i missing here?
thanks
 

·
Registered
Joined
·
1,956 Posts
I installed vbrun and it didnt help me.
The purpose of installing VB run is so that IEfix will run. Try it again. It
could still be the cure for email links because that is part of what it fixes.

So, you have the right key - you just have the wrong CD? Where is the
correct Windows CD?

To fix system files, you will have to get SFC to work. It won't fix files
related to programs you installed such as Zone Alarm, etc.

DirectX helps your computer get more performance out of multimedia
programs such as games and movies. DirectX is a technology that
helps create the special visual and audio effects that come with games.

Since you did re-install Direct X, run the diagnosic for it. Click your
Windows help and type in "direct x" for instructions.

Edit: Maybe you copied the link wrong, there is no mention of
Direct X that I can see at the link I posted.
 

·
Registered
Joined
·
21 Posts
Discussion Starter · #16 ·
Try what again, vbrun or IEfix? I tried IEfix again and still get the same error message.
I will try installing vbrun again.
Im saying i have the right cdkey as i only have one. I did make a slipstream copy of my win xp pro cd so i could have sp1 in it and then i did the same with sp2, only i havent installed sp2. So when sfc asked me for the cdrom i gave it the original because originally, 7 or 8 yrs ago, i installed win xp pro on this rig and hen i installed sp1 on its own some years later. But sfc refused to use
either cdrom, the original or the one with sp1 slipstreamed in. I know i did the slipstream right because i installed the slipstream version on another pc i have, just to make sure it works.
I will try installing vbrun again.
And i will try sfc again.
As for what you said about copying the link wrong, i will do that again, although i have done it a number of times, get the same thing. As for the link you have provided, it seems to be broken, this is it here:
http://www.microsoft.com/downloads/d...displaylang=en

And this is what is on that page, the first item being a link to directx, so i thought maybe its another word for vbrun, apparently not i see now:

Microsoft.com
Downloads
Support
MSDN
TechNet
Company Information
Xbox.com
Communities
WebSearch pages in English all languages

Search Results
1-10 of 86,400 (0.152 seconds) for downloads d displaylang en
Editor's Choice
Download details: DirectX End-User Runtime
Worldwide Downloads ... August 2008 The Microsoft DirectX® End-User Runtime provides updates to 9.0c and ...

www.microsoft.com/downloads/details.aspx?FamilyID=2da43d38-db71-4c1b-bc6a-9b6652cd92a3&...
 

·
Registered
Joined
·
1,956 Posts
I have no work around for SFC. If it refuses to run, not sure
what you can do to check system files.

TSG shortens up the long links. That "search" page you are
getting is not the entire link for some reason. If you already
got VB runtime 6 installed, the link is really irrelevant.

However here is a small link of the same MS page, maybe
this will work so you can see the correct page:
http://www.smalllinks.com/5TP

Moving on...if you can't get IEfix to run, let's manually try some
of the things IEfix does (and also a few other things).

Go down the list in order. Try each item and if you still have the
problem, then go to the next item.

See if this helps:
IE->Tools->Internet Options->Programs Tab.
Click Reset web settings button.
------------------------------------------------

More things to try here:
http://email.about.com/od/outlooktips/qt/et_fix_links.htm

In addition to the files listed there, try registering these:
regsvr32 Shell32.dll
regsvr32 Actxprxy.dll
regsvr32 Oleaut32.dll

You should receive the "DllRegisterServer in urlmon.dll succeeded"
message. If it says something like, LoadLibrary("file name.dll") failed,
it isn't a problem.
------------------------------------------------

Temporarily disable anti-virus/firewall/popup blockers and toolbars.
Including Yahoo! Companion, if you have that. Also Ad Watch from
Ad Aware. If that solves the problem, isolate which program is
causing it and change settings within that program.
------------------------------------------------

Start->Settings-> Folder Options->File types Tab
or you can find Folder Options under Tools in Windows Explorer.
Locate each of the 4 file types listed below. Click Edit and click the
Set Default button.

Also verify that each command line is correct:

URL:File Transfer Protocol "C:\Program Files\Internet Explorer\iexplore.exe"

URL:Gopher Protocol "C:\Program Files\Internet Explorer\iexplore.exe" -nohome

URL:HyperText Transfer Protocol "C:\Program Files\Internet Explorer\iexplore.exe" -nohome

URL:HyperText Transfer Protocol with Privacy "C:\Program Files\Internet Explorer\iexplore.exe" -nohome

If you made corrections to File Types, check to see if there is any difference.

If you still have the problem - also in those File Types, Use DDE may be checked. Try Unchecking it to see if that makes your links work.
 

·
Registered
Joined
·
21 Posts
Discussion Starter · #18 ·
Sorry to take so long to get back. My wifes dad is dying and i have had to pitch in and help get him home, hospital bed set up, etc, etc.

I did re-install vbrun and it seems to have take care of about 3/4 of my problems. At this point i can get internet explorer to start and run well. Sometimes it wont open on the first click, i have to click a few time but it does open. And i have it set in folder options for files and folders to open on one click. But thats only a minor annoyance at this point since it does open and run.
To the other problem. Now about half of links that i click on in outlook express work and the other half dont, they freeze oe right up. But i can cut and paste the link into my browser and that does work.
I havent tried to run sfc again so i will be doing that and some of the other things that vistarookie has mentioned and post the results.

thanks for being patient with me.
 

·
Registered
Joined
·
21 Posts
Discussion Starter · #19 ·
Sorry to take so long to get back, impending death in family.

As it turns out, a bit embarrasing but here it is. I went into ie and changed settings back to default and now all is well. However,i know that i did this before and it didnt work.
So the solution was a combination of re-installing vbrun, re-installing regsvr32 urlmon.dll via the run program and changing ie settings back to default.

Thanks very much for all the help.
 
1 - 20 of 21 Posts
Status
Not open for further replies.
Top