Tech Support Guy banner

printer and camera do not work at same time

770 Views 6 Replies 2 Participants Last post by  StillLearnin'
my pc windows xp... the camera is canon powershot s50. my printer is a lexmark x83 all in one...both connected by usb... when i connect my camera to the computer i have to restart the computer for it to find the camera...when i do printer does not work.. if i unplug the camera and restart the computer, then my printer will work.. both devices will not work at the same time...please help if you can... thanks
Not open for further replies.
1 - 7 of 7 Posts
i just got an email from canon..they said that my problem is there is a limitation with using usb to connect two imaging devices.. only one will work at a time.. is this true...
It sounds to me like you don't have some (either camera, printer or usb) drivers installed properly or at all. I've been using Canon digital cameras for years with computers/scanners/printers and have no problem. I'm using W2kPro so there shouldn't be any difference and I've used them with XP also and they've worked with that operating system. First of all, IF you have the Canon (TWAIN) drivers installed correctly, you wouldn't have to be re-starting the computer. What brand/model number system do you have?
my pc is a dell 8200, windows xp...
i have unistalled and reinstalled drivers several times...i worked on this for about 4 hours last night.. i even tried the wia drivers for the camera... still get the same result... my printer is connected to an usb hub and the camera is connected to the usb port in the front of the pc... this is really driving me nuts...
im thinking if the problem cant be resolve, would a card reader be a cheap solution...

i just did a full reinstall of the computer the other day... but the same thing was happening before i did this..
Have you tried either one or both plugged into the rear usb ports instead of the front or hub? Are you using the WinXP drivers?
i tried a litttle bit of everything... i just took the camera back and bought a sony.... works great.. no problems.. you would think when you spend that much money on a camera, you wouldnt have too many problems... the sony is great.. just plugged it in and started working.. no problems at all...took less than 5 minutes to get going... spent hours on the canon... thanks for your time and help... i guess we can consider this post closed.... thanks again...have a good weekend.
Sorry that we didn't get that solved. I was on the Dell website and I couldn't find any reason why the camera wouldn't install. I went to the Canon site and found no problems there either. I don't know what to say except it's just the kind of thing that can happen when working with different items/componenets/software and computers. Next, somebody will finally see this and post they've got a Dell 8200, WinXP and a Canon S50 and it works fine!!!!!!!!!!!!!!!!!!!! I'm glad you got it solved but I wish I had the exact same setup with your computer and camera in the shop to see what really caused this. Every now and then things aren't as they seem....................... good luck! A last minute thought..................IF anything like this happens again, try using the manufacturer provided cable and try using a tried and true cable of your own to see if there is a difference.
1 - 7 of 7 Posts
Not open for further replies.