Tech Support Guy banner

Plextor PX-716Sa playing up :-(

1623 Views 9 Replies 3 Participants Last post by  blockhead
I was able to burn any dvd I liked, then it was only dvd rw discs that I could burn to, now I cannot burn any DVD :-( I tried reinstalling Nero and tried Clone DVD instead .... no joy :-(

I can prepare the files for burning in Nero but then all I get is "waiting for the drive to become ready" appearing in a pop up window ( the burn icon is by then greyed out )

I have no idea how to fix this :-( Please help, I have data files to burn etc. I have not interefered ie changed any settings.

Thank you.
Not open for further replies.
1 - 5 of 10 Posts
I can read disks yes, the info tool data is way too long to post though :-(
Actually John, I checked and i CANNOT read disks now :-(

Attached is the screenshot as requested :)


See less See more
Sorry I did mean to add a comment about that ! Yes I did uninstall and reboot, sadly such an easy fix failed. I'm just so unlucky with computers. Always got some kind of problem, software conflict or hardware dying :-( My Plextor is just over a year old, I bought it because of the name and reputation ..... hmnnnn. The machine this drive is installed in was built about a year ago by an i.t. professional using all new components btw, I feel gutted.
Hopefully its not shot !
1 - 5 of 10 Posts
Not open for further replies.