Tech Support Guy banner
Status
Not open for further replies.
1 - 19 of 19 Posts

·
Registered
Joined
·
167 Posts
Discussion Starter · #1 ·
Hey guys,

Im doing a forum for my website www.techinfo-4u.com

the link to the forum is www.techinfo-4u.com/forum

i cant get my different forums to show up, i read something about needing to set permissions for them but when i go to try and do it i assign all the roles to the the different groups and then click apply and it just reloads the page and the all come back with no roles assigned again.

I managed to get one of my forums to show up "site review" see the link but that was only because i singled it out and added the permissions that way, its when i try to do it to multiple forums it doesnt work

Any help would be great thanks
 

·
Registered
Joined
·
20 Posts
i cant get my different forums to show up, i read something about needing to set permissions for them but when i go to try and do it i assign all the roles to the the different groups and then click apply and it just reloads the page and the all come back with no roles assigned again.
If there are custom roles (Like able to see but not post stickies) then it will show up as "no roles assigned".

See the attached pic
 

Attachments

·
Registered
Joined
·
20 Posts
I'm pretty sure you just disabled the board until you could get everything worked out, but if not I'll post where to change it. (not sure how much you know about phpBB)

Techforum.jpg is what I see when I go to your site (not sure if that is what you mean by not showing up)

MP.jpg is where to go to enable the forum.

If that is not the case let me know and I will look into it more. Do you have an account that is just a "regular member" account you can test permissions and such with?
 

Attachments

·
Registered
Joined
·
20 Posts
What I would suggest, just to test it out for now, is to set everyone to Read Only for all sections (except Administrators) and unlock the board. Then you can at least log out and see if the forums show up to you as a guest. From there it should just be a matter of setting permissions how you want it. The "no roles assigned" tag is misleading and should say "custom roles assigned" in my opinion.
 

·
Registered
Joined
·
167 Posts
Discussion Starter · #8 ·
Thanks Knight Templar

I actually had to board enabled it was because i was trying to install something on it and i forgot to delete the folder that the board was disabled,
Once i deleted it the board is now enabled again

I can view the forum the same as when i was logged in but i can only see the "site reviews" forum and nothing else because it is the one where i went and manually set permissions for each group

thanks so much for your help
 

·
Registered
Joined
·
20 Posts
Feel free to contact me if you have any more phpBB questions and I'll see what I can do to help.

There are some ways to set permissions in mass, but it is still a long process if you want to do custom permissions (especially if you have the number of sections and groups I do).
 

·
Registered
Joined
·
167 Posts
Discussion Starter · #10 ·
you see thats where the problem is,

i dont want to be setting custom permissions,

for some reason i cant set the permissions on mass, am i correct in saying that my various forum headings wont show up until they have permissions set?

what exactly do i do on this page below?
 

Attachments

·
Registered
Joined
·
20 Posts
Oh, ok. I think I see where the problem is... The quickest and easiest way I know to do it is the following:

First, Select "All Forums"

Second, Select the user groups you want to edit (Shift-click or Alt-click depending on if they are together or not) and click "Edit Permissions"

Third, Set your advanced permissions and click the box next to each forum and user type you want to copy those permissions to.

Apply All Permissions


While that won't completely eliminate all customization, it should cut down on it drastically.
 

Attachments

·
Registered
Joined
·
167 Posts
Discussion Starter · #12 ·
Thanks again for your reply

i dont actually want to set advanced permissions, i just wanted to set the regular ones. I was doing exactly what you told me their before but for some reason it just wouldn't work. Every time i applied the roles the page would just reload, it didnt give me the confirmation that changes were made,

Anyway i came up with a work around, i went through all my forums and told them to copy permissions from the site reviews forum which was the one i set up on its own and was working fine, now they all seem to be working fine if you have a look at it

www.techinfo-4u.com/forums

Except for one! :-( In my site reviews forum the sub-forums dont seem to be appearing, there should be 3 sub forums in there. You'll see on the other forums the sub forums are there fine except for this one..... Any ideas why there not showing? the permissions are set for them the same as all the others

Thanks again for all your help
 

·
Registered
Joined
·
20 Posts
Not seeing anything off hand, but it is a slightly different interface. What does the "Forum Administration" page of one of the ones that is working, say "Tech Help" look like in comparison with "Site Reviews" which you have posted?
 

·
Registered
Joined
·
167 Posts
Discussion Starter · #17 ·
Hi again

Here it is

it appears to be the same

hmm

Update: I just came up with another work around for it, i made another forum and identical sub forums and they worked fine so i just deleted the old ones, now every thing works fine

:)

Thanks so much for all your help, it was much appreciated

I dont suppose you or anyone else would know how to implement wordpress and phpbb forum integration? I want the passwords and usernames etc,.. that people make on my wordpress blog www.techinfo-4u.com/wpnews to work on the forum aswell www.techinfo-4u.com/forum and vice versa

I was looking at Wp-United and it seems like it would work but i cant install it as the instructions are all out of date and folders its telling me to upload to dont exsist on my forums server,

Anyone any ideas?
 

Attachments

·
Registered
Joined
·
20 Posts
I dont suppose you or anyone else would know how to implement wordpress and phpbb forum integration? I want the passwords and usernames etc,.. that people make on my wordpress blog www.techinfo-4u.com/wpnews to work on the forum aswell www.techinfo-4u.com/forum and vice versa
I know the company I have my forum through (freeforums.org) had the phpbb2 forums linked with wordpress blogs but when upgrading to phpbb3 the links all broke and they were unable to set it back up. I think it was a problem with the new (at the time) phpbb3 code but I am unsure if they ever got it working properly.
 
1 - 19 of 19 Posts
Status
Not open for further replies.
Top