Tech Support Guy banner
Status
Not open for further replies.
1 - 14 of 14 Posts

·
Registered
Joined
·
32 Posts
Discussion Starter · #1 ·
I'm needing some advice on a common and annoying networking problem....I've searched TSG and find lots of complaints about this same issue but no resolutions yet.

I have a home network with 3 computers: a desktop (wired) and 2 laptops (wireless) all connected to a netgear ruckus router. All of them are running Windows XP SP 2. I can share my internet connection just fine with all of the computers.

One of the laptops (#2) I just got the other day and every time I try and connect to and access the shared files on computers listed in my workgroup computers, I get this irritating error message every time:

The new laptop appears in in the workgroup but can't be accessed from either the desktop or the legacy notebook. I get the same error message on all" "//xxxxx PC is not accessible. You might not have permission to use this network resource. Contact the administrator of this server to find out if you have access permissions."

The other two computers, the desktop and the other laptop can access each other and share folders just fine as they did before.

I tried turning off my firewalls to see if that helped, but it didn't.
I tried turning the 'guest account' on with each of the computers, again, no resolution.

I remember this same exact problem happening a couple years ago with the same basic setup, and it was solved because one day, when I attempted to access the workgroup computers from the laptop in question back then, I was prompted for a password which I entered and then was always granted access thereafter. All I did then was double click on the workgroup name in 'add a new network place' browse window and tht p/w dialog box opened up.

Why Microsoft networking is so hard to setup and make work I just don't know.

Thank you in advance for any help at all.
 

·
Registered
Joined
·
893 Posts
Hi and welcome…

How are you trying to access the system’s resources?

Can you actually PING the computer in question?

Are you 100% sure you do not have another firewall in place such as Symantec, TrendMicro, or other firewall?

Also, here is a possible solution, but be careful since it requires you to edit the registry!

When you try to access a Microsoft Windows XP-based network computer, you receive an error message that is similar to the following:
XXXXXXX is not accessible. You might not have permission to use this network resource. Access is denied.
Note XXXXX is the IP address or the computer name of the Windows XP-based computer.

You may experience this issue when you use the IP address or the computer name to access a shared folder that is stored on the Windows XP-based computer. You may also experience this issue when you use My Network Places to access a shared folder in this situation.

Cause
This issue occurs if the restrictanonymous registry entry is set to a value of 1 on the Windows XP-based computer.

Resolution
Warning Serious problems might occur if you modify the registry incorrectly by using Registry Editor or by using another method. These problems might require that you reinstall your operating system. Microsoft cannot guarantee that these problems can be solved. Modify the registry at your own risk.To resolve this issue, set the value of the restrictanonymous registry entry to 0. To do this, follow these steps:
1. Click Start, click Run, type regedit in the Open box, and then click OK.
2. Locate and then double-click the following registry subkey:
HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Lsa
3. In the right pane, double-click restrictanonymous.
4. Make sure that the value in the Value data box is set to 0, and then click OK.
5. Close Registry Editor.
6. Restart the computer.

Thanks!

Shane
 

·
Registered
Joined
·
32 Posts
Discussion Starter · #3 ·
Thanks for your reply to my post.

From the new laptop I am trying to access via my network places, add a network place wizard in the subsequent browse for folder window in the windows network tree. It is from there I am attempting to open the workgroup my other computers are in, and that is when I'm getting the error message

I cannot ping the laptop from my desktop - all requests time out. But I got an odd ball IP address when I did an ipconfig on the laptop: 10.0.0.5 - I'm no networking guy as you can surely tell, but this can't be a valid range.

I disabled my A/V (Kaspersky 6x) and firewalls for tests and no luck.

I've already done the registry change on both laptop and desktop PC, and no change. I am getting the same exact error message when attempting to access either the laptop from the PC, or the PC from the laptop.
 

·
Registered
Joined
·
893 Posts
Hi….

What is the network address of your other computers, including the subnets?

I’m guessing you are using a simple network with nothing special in between the computers such as a router or PIX firewall, so if you cannot PING that computer, then either……………

The computer is on the wrong networks segment
The computer has some type of firewall installed that you don’t know about
The computer is behind a second firewall device – I highly doubt this one.

Check the IP settings on the computers that can communicate:

START
RUN
CMD
OK
In the black window type the following
IPCONFIG /ALL

Then do the same on the computer you cannot access and then let us compare the results.

If you are on a PRIVATE network such as a home running on a simple router that has not been seriously configured, then your normal network IP’s should be 192.168.x.xxx with a subnet of 255.255.255.0

Your home networks are usually Class C networks which cover the IP ranges of 192.168.0.0 – 192.168.255.255. (16-bit blocks)

Your Class B networks usually cover IP ranges of 172.16.0.0 – 172.31.255.255 (20-bit blocks)

Your Class C networks usually cover IP ranges of 10.0.0.0 – 10.255.255.255 (24-bit blocks)

This isn’t a 100% true statement, but you usually see 192.168.xxx.xxx addresses in home networks, the 172.16.xxx.xxx networks in connecting networks such as T1’s and so forth, and the 10.xxx.xxx.xxx ranges used in enterprise solutions in businesses.

However, it is not IMPOSSIBLE to configure your home network to use the 10.xxx.xxx.xxx ranges or any other IP range you decide to use. Granted, if you start using PUBLIC addresses, you are going to have some problems.

Sorry, that might all be TMI for you, but I wanted to explain a little.

Thanks!

Shane
 

·
Registered
Joined
·
32 Posts
Discussion Starter · #5 ·
Thanks for all the detailed info - I can't tell you how pleased I am to be receiving advice on this issue from someone who is obviously so knowledgeable.

Did the ipconfig/all on each of my 3 systems. All IP's are in the 10.0.0.X range...subnet is 255.255.255.0. I don't understand about the 10x range IP's...this is no enterprise for sure and I didn't do anything funny when setting up my netgear router.

From the new laptop I can ping my other 2 computers, however from my desktop PC I cannot ping the new laptop.

I have done a check on the new machine and there is nothing obvious re: firewall software other than that which comes with XP pro.

How can I tell if the new laptop is on the wrong networks segment? That sounds like a likely culprit. Again, this problem happened to me before about a year ago, but in that instance, I was able to pull up a user and p/w dialog box by double clicking on the workgroup name I was trying to open for the first time. After I entered the correct info, windows granted me access from that time forward...so I would be able to access other machines on my network typically through the my network places folder.

FYI: last week I purchased another new laptop which came with vista home premium; it connected to the same network and I was exchanging files in less than 2 minutes. I returned that laptop for a refund.
 

·
Registered
Joined
·
8,256 Posts
Do you have simple file sharing disabled?

Assume that the IP address of PC #1 is 10.0.0.1

Assume that the IP address of PC #2 is 10.0.0.2

From PC #1
Start > run
delete contents of long, skinny white box
type: \\10.0.0.2
Left click "ok"
Report results.

Boot PC #1 & PC #2 to safe mode with networking.
Now, try to access the files.

On PC #1, create folder "Test_share_1", without quotes
On PC #2, create folder "Test_share_2", without quotes

RIGHT click on each folder
Set each for file sharing.

This might help.
http://www.practicallynetworked.com/sharing/xp_filesharing/index.htm

RF123
 

·
Registered
Joined
·
32 Posts
Discussion Starter · #7 ·
Okay...good news I think:

I did the procedure:

Start > run
delete contents of long, skinny white box
type: \\10.0.0.2
Left click "ok"

10.0.0.2 happens to be the ip for the desktop PC and the results were that I could open and access my files residing on the desktop that had sharing enabled on them.
I also was able to add some network places by using the \\10.0.0.2\xxxxx\xxx and later open them.

So I can now open using the IP address but not the name path....So what is this telling us?

Thanks for your great help on this. I'll do the safe mode testing tmrw...
 

·
Registered
Joined
·
8,256 Posts
From private correspondence with a colleague .
"if \\OtherPC works with the IP address, but the OP is complaining about not being able to "see" the PC in My Network Places, we know that basic file sharing is working, but there is a problem with names (maybe NetBIOS disabled) or something else very narrow."

On PC #1
Open control panel.
In the upper left, if you see "switch to classic view", left click on the link.
Open "network connections"
RIGHT click your network connection
Left click "properties"
In the white background area, left click "tcp / ip"
Left click the "properties" button
Left click the "advanced" button.
WINS tab

What is selected in the lower 1/2 of the page, regarding NETBIOS?
Left click cancel until you are back at network connections.

Repeat for PC #2 & PC #3
Post your results.

IF you change anything, take meticulous notes!

RF123
 

·
Registered
Joined
·
32 Posts
Discussion Starter · #9 ·
Hi and thanks for your post.

On the desktop PC, in network connections, netbios is set to 'default'.

On the laptop in network connections, netbios is also set to 'default'.

Legacy laptop #3 is out of the picture now, but in network connections, netbios is set to 'default' on that machine also.

Also, simple file sharing is not disabled to the best of my knowledge. I know this is enabled in XP by default, and I haven't played with it on either the desktop or new laptop.
 

·
Registered
Joined
·
32 Posts
Discussion Starter · #10 ·
One more thing:

As I had posted earlier, the advice from rainforest123 allowed me to finally add a network place and access files on the desktop PC from the laptop.

However another strange thing I can't explain has happened. I have enabled shares on all those files residing on the desktop which I need to access from before I got the new laptop. I have also enabled sharing on those files on my laptop.

However I have found that even though I can see many of of the files and folders on the desktop from the laptop I cannot open or copy them between computers. This, even though sharing on the folders and files in question in enabled. And here I was thinking this issue was well on its way to resolution, and could not get more complicated.

From the desktop, I can see the laptop listed in my workgroup, but I cannot open/access any files on the laptop even though I have enabled sharing on select folders on the laptop. I get the damn "may not have permission" error again.
When I attempt to add the laptop using its IP \\10.0.0.5 I get the error: "Windows requires a share to publish to. Please select another location"

This problem is starting to make me nutty.
 

·
Registered
Joined
·
32 Posts
Discussion Starter · #11 ·
One final thing: in my initial post on this thread, I described previously solving the same issue by entering a network password at a prompt I initiated by double clicking onto the workgroup name. For some reason, I cannot get this prompt to show when double clicking onto the workgroup name on the new laptop. This is described int he link http://www.practicallynetworked.com/sharing/xp_filesharing/11trouble.htm.

Can anyone tell me how to get this prompt up so that I can enter the correct network password and access the files properly on the desktop PC?

FYI: I am using the same user name and p/w for administrator login on both the desktop and laptop and the guest account is "on" on both machines. On the network setup between desktop PC and my legacy laptop now not in use, I did not have the guest account 'on' and had none of the challenges that are currently going on with accessing files on the network.
 

·
Registered
Joined
·
32 Posts
Discussion Starter · #13 ·
Problem has been solved - I installed Vista on the notebook and all networking issues are a thing of the past.

Ahhh...life with windozzzzz....

thanks for all the help and advice on this problem...greatly appreciated.
 

·
Registered
Joined
·
8,256 Posts
dgm:
Is the laptop PC #3? If so, I am curious to know how installing Vista on the laptop would solve the problem between PC #1 & PC #2.

You wrote in #3, above:
"I am getting the same exact error message when attempting to access either the laptop from the PC, or the PC from the laptop.".

When you are satisfied that the issue is resolved, please use the thread tools to mark the thread solved.

RF123
 
1 - 14 of 14 Posts
Status
Not open for further replies.
Top