Tech Support Guy banner
Status
Not open for further replies.
1 - 19 of 19 Posts

·
Banned
Joined
·
34 Posts
Discussion Starter · #1 ·
So, I've got this PC right -
3GB DDR2 800 RAM,
E6550 CPU
1TB + 160GB HDs
8600GTS graphics
and a cd drive
all in a Gigabyte G31 mobo.

Now this thing keeps restarting. When I say restarting, it's as if the power just dies then comes back on. It happens with no warning at random intervals. I also can't figure out whether it's my house's power or my PC itself. Nothing else is dying then coming back on though. Help me please?

For some reason, my primal instinct tells me static.
 

·
Banned
Joined
·
34 Posts
Discussion Starter · #12 ·
Im not quite sure what brand it is, think it's foxstar or something. The box is at my parents' house, and they'd be sleeping by now.
It's quite an alright psu though, it didn't come with the case, has a complete sleeving kit and a nice big fan. No piece of crap.
I've had it for about 3 years now though.
 

·
Registered
Joined
·
2,608 Posts
Yeah It sounds like the PSU is failing. It is probably best to replace it with something around 500-600w with a good brand like OCZ or coolermaster. They are more expensive but a much better quality.
 

·
Banned
Joined
·
34 Posts
Discussion Starter · #15 ·
Just want to say, when i was checking my ram, it picked up a bit of static charge. I rubbed it on some paper and it worked again. That was about 4 hours ago and my pc hasnt restarted since. I really do think it could be static. I usually keep my pc case open and i have this massive fan on the side that's full of dust by now. So... I don't know anymore.
 
1 - 19 of 19 Posts
Status
Not open for further replies.
Top