Tech Support Guy banner
  • Please post in our Community Feedback thread for help with the new forum software! If you are having trouble logging in, please Contact Us for assistance.
Status
Not open for further replies.
1 - 10 of 10 Posts

·
Registered
Joined
·
525 Posts
Discussion Starter · #1 ·
When I go into preformance section virtual memory shows 0mb. I click change and set D:\ and set starting and maximum size to 1500mb.
When I reboot I get a message that "System has no paging file or too small"
In the virtual memory box it recommends 766mb.

Where am I going wrong?

Thanks.
 

·
Registered
Joined
·
380 Posts
There is a thumb rule to set the page file size according to the size of ur RAM. the rule is Page size= RAM * 1.5. Multiply 512 with 1.5 and u'll get 768. Thats why the system is recommending 766MB page file. I suggest u set it to this default setting, then reboot and see if it works. If it does then try increasing the page size with 766 as minimum size.
 

·
Registered
Joined
·
525 Posts
Discussion Starter · #3 ·
Thanks opopanax for the reply.
I'll give that a try. I have read that you should make the starting and max. the same as the max.size. I also set them both at 1500 which is larger than 1.5 the ram size.?
 

·
Retired Moderator
Joined
·
106,726 Posts
Another issue is that I believe you need to leave a small paging file on C:, even though you move it to another drive.

One has to question why you feel the need to move the paging file at all, or even tinker with it for that matter?
 

·
Registered
Joined
·
2,736 Posts
Just a random thought. What OS is this?
After you change the values are you making sure you click the Set button? If not, the changes will not be saved. (sorry, had to ask since you didn't mention it).
 

·
Retired Moderator
Joined
·
106,726 Posts
Unless you really beat up the system, the paging file doesn't get fragmented. I've run for several months, and when I check the page file fragmentation on a system with 512mb, it's not fragmented at all. I have the settings to allow Windows to manage the page file settings.

IMO, there is rarely any reason to tinker with the paging file settings...
 

·
Registered
Joined
·
525 Posts
Discussion Starter · #8 ·
Thanks for the replys.
XP Pro in my signature.
Some one told me it was best to have it in on another drive, and both the same size. Which I had done with virtual memory in 98. Any way I set it back on c:\ at the same values it had when I first started messing with it. 766 start 1536 max. and I did hit the set button when I finished.
I am still getting the message at startup.
 

·
Retired Moderator
Joined
·
106,726 Posts
Whoever told you it was better to have it on another drive was referring to a physical drive, not another partition on the same drive. However, as I previously mentioned, the page file is rarely taxed with adequate memory.

For the current issue, have you defragged the boot drive? During initial creation, I think the page file wants contiguous space.
 

·
Registered
Joined
·
525 Posts
Discussion Starter · #10 ·
johnwill, thanks for the reply.
I did try to put it on a different HD, I have sence tryed to put it back on the c:\ and leave it alone. And I still get the message at the boot up. That's what I am trying to eleminate now. I did defrag after install all programs. I will do it again now.

Thanks again.
 
1 - 10 of 10 Posts
Status
Not open for further replies.
Top