Tech Support Guy banner

No permission despite permitted; device not shown in Network

6455 Views 99 Replies 6 Participants Last post by  chueh
I have posted this same thread on various networking/computer forums, yet I have not gotten this problem resolved!!!! Please HELP!


My 1st desktop "desktop-kba" uses Windows 10, and it has no problem sharing files with my MacBook or vice versa (no issue; everything works perfectly between desktop1+MacBook. 2 pictures below show everything being working properly).
Rectangle Font Parallel Number Screenshot

Rectangle Font Parallel Screenshot Software

My 2nd desktop "desktop-ja7" uses Windows 10 Pro. Although file sharing is all on, files cannot be shared to any devices.

Both 1st desktop and MacBook have 2nd desktop listed under NETWORK, but cannot access for "User" folder (only Public available)
Font Rectangle Electronic device Multimedia Operating system

Rectangle Font Parallel Number Screenshot

Rectangle Font Parallel Screenshot Number


I have tried fixing this 2nd desktop for networking for a while, but nothing is successful. Mainly, neither the 1st desktop nor the MacBook are shown under 2nd desktop's "desktop-ja7" NETWORK.

A. I've checked "network discovery under settings. Everything is on.
B. network discovery Defender is on under firewall recovery settings
C. I've checked the "network ID"
D. I've changed Function Discovery Resource Publication service from Manual to Automatic (Delayed Start)
E. I've tried direct access the shares by typing IP address, but nothing happened.
F. Opened "Services.msc" and checked the following already:
  • Function Discovery Provider Host (FDPHost)
  • Function Discovery Resource Publication (FDResPub)
  • Network Connections (NetMan)
  • UPnP Device Host (UPnPHost)
  • Peer Name Resolution Protocol (PNRPSvc)
  • Peer Networking Grouping (P2PSvc)
  • Peer Networking Identity Manager (P2PIMSvc)
All the above I have done did not solve the problems.

Please advise; thanks
See less See more
Not open for further replies.
1 - 20 of 100 Posts
Go to Control Panel > Program & Features > Turn Windows Features on or off > checkmark SMB 1.0/CIFS File Sharing System.

Note this enables the old vulnerable protocol SMB v1. The WanaCry ransomware virus spread using this now deprecated protocol. It encrypted peoples files and asked for a ransom to decrypt them. USE AT YOUR OWN RISK.
thank you lunarlander. Actually, I had this already checked as well
I see from the screen shots you were using Guest for ja7, can you use a real account?
I wanted to use a real account, but I can never use it. That's why I keep posting this problem on various forums, for I cannot share files.
for I cannot share files.
Not surprising, as the Guest account is quite limited.
It can only show GUEST. I cannot access USER at all. Thats' why I posted this thread here
Until you login to an account the is NOT Guest, that is all you will be able to access.
Are you telling us that there is only Guest accounts on this machine?
I own this computer and login as administrator account, which is the only account I created. I could get to the desktop for everything, except other computers in the network cannot access to it but GUEST
If you mean that you have an account that is of the Administrator group, and NOT the builtin "Administrator", then you should have permissions to do MOST actions.

When in this admin group account, what error message do you get when you try to access the other machines?
Also have you defined an share on the other machines?
There is no error message at all. The name of the computer which can never be accessed is simply NOT showed under NETWORK of other devices.

I have already checked file sharing for everything, as well as the discovery.... it's useless!

I also checked the network NAMES...... still no use
Hi Chueh
What I put in Blue text you can either type or copy and paste. What I put in Red is what you do
eg Enter means press the enter key
Can we try somethings first. On both windows 10 machines can you click on start >CMD Enter
When the command prompt opens type in ipconfig /all Enter Look for the IPv4 address.
Then still at the command prompt Ping
and the other windows IPv4 address.
Example: one computer IPv4 Address is and the second computer address is
Then from computer one.
Ping Enter.
Do you get a reply or do you get a time out?
Then do the same from computer two.
Ping Enter
You can then close the command windows.
Click on start
System Enter
Are both computers in the same Workgroup ?

See less See more
Thank you so much for your kindness to write me such a clear instruction.

I did Command CMD Ping for both computers.

1. I did have replies when using jad computer (2nd computer) for getting kba computer (1st computer) address
2. But TIME OUT when using kba computer(1st) to get jad (2nd) computer address.
ok does jad computer log in with a password for the user?
if no go to control panel > user accounts add a password.
Try to ping again.
The way I see things we try and get both windows computers to share. Once they can share we then look at
getting the Mac to share.
1 step at a time is the longer but normally the easiest way
Also in control panel can you open System and check that both Win 10 computers are in the same workgroup
The windows default on setup is workgroup BUT worth checking.
Also when in Control panel Click on Network and Sharing Center > Change Advanced sharing settings
and under all networks check they are both the same Remember KBA is the good one so change nothing in that.
I know you have checked these settings before. But when rattled and trying to get something to work
across different systems it is easy to miss something.
Yes, I have to log in had computer with password in order to go to desktop.

At the mean time while waiting for your further instructions, I'll double check both computers to see if Network sharing setups are the same. thanks
Have you been asked for and account name and password when trying to access another machine from across the network?

If so, then you need to type an account name and password that is on the machine you are trying to access.
Sorry for the delay - Time zone difference. If you let me know your time zone e.g East coast USA
England, Spain etc I will see if I can get online around the same time.
Are you running any other anti virus/Malware protection besides Windows Defender?
Can you Turn OFF some settings on Both windows machines to test ping. We will only turn them off for you to test then turn them back on.

Open windows start menu Windows Security Enter
Left hand side of widow that opens Click on Virus & threat protection> Virus threat protection settings> manage settings. Turn Off Real time protection and Tamper protection

Then in the same screen Click on Firewall & Network protection I hope it shows Private network (Active)
If yes click on Private network (Active) and turn it off. Leave the window open and go back to the command prompt and try ping again. Once you have tried the ping test you can turn the protection back on.

Post result please.

If you are running any other type of protection please do the same steps e.g Disable(sometimes called snooze)

and test ping.

At the command prompt ipconfig /all Enter.
Do both machines have the same details e.g

IPv4 (Last 3 xxx will be different) on this line only
Subnet Mask
Default Gateway
DHCP Server
DNS Servers
NB these numbers are an indication only but both machines should show the same.
Still in this list Netbios over tcpip does it show enabled?

Are these machines connected via wireless or via cable to a switch or router?
If wireless are both machines on the same wireless network ? (seems obvious I know But)
See less See more
Also on both Win 10 at the command prompt net view Enter
What do you see ?
B. network discovery Defender is on under firewall recovery settings
I assume this means in Windows Firewall Allow an app or feature through Windows defender Firewall.
On kba have you shared the users only folder or have you shared C Drive?

Sorry for the long post but I am trying to get as much done because of the Time difference.
Please go through this one step at a time testing as you go.
I am positive that once both windows machines can ping/ share Mac will follow
Thank you so very much for taking your time PeterOz. No worries for time zone differences. This problem has been months; no hurry now as long as i get it resolved.

1. I double checked Fill Sharing being the same for both computers.
2. Both computers default workgroup are called "Workgroup." However, Kba computer's Network ID is in grey (so can't change), whereas I am able to click on jad's Network ID.

Also, you said typing in System, pressing Enter, and see if both are the same workgroup. Under System, there is nothing mentioning about workgroup though. Just for the curiosity, I just clicked on System Information, then Software Environment, and then Network Connections, but there is nothing listed there.
3. Net View under command prompt. It says "This service has not been started," for jad computer. BUT... it says "The command completed successfully," on kba computer with both computer names listed. Both's Netbios over tcpip are enabled.
4. Ping tests for both computers are the same except the IVp4, as you mentioned. Thus, it's good.
See less See more
1 - 20 of 100 Posts
Not open for further replies.