Tech Support Guy banner
1 - 1 of 1 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter · #1 ·
I was trying to change my Legacy BIOS to UEFI. I converted mbr2gpt through command prompt. However, when I restarted and tried to boot, I got a black screen with the error "No boot disk has been detected or hard disk has failed". I tried changing the boot order but to no avail. I ran the HP PC Hardware Diagnostics UEFI and I got PASSED for both short and extensive checks.

Right now I'm looking for a way to boot to my windows 10. On my PC, there is no direct option to switch from UEFI to Legacy. The only option related to 'Boot' on my BIOS is 'Boot order' under 'Storage' menu. I have tried manually disabling UEFI boot sources on there and changing the order but nothing worked. I have also tried booting from Legacy from Boot device menu (F9). When I manually disable Lagacy boot sources, I get the error of "No operating system found".



Is there a solution to this? If yes please tell.


Font Display device Electric blue Parallel Electronic device
Rectangle Font Electric blue Display device Electronic device
Rectangle Personal computer Font Electric blue Display device
Blue Azure Rectangle Font Personal computer
 
1 - 1 of 1 Posts
Top