Tech Support Guy banner
Status
Not open for further replies.
1 - 3 of 3 Posts

·
Registered
Joined
·
15,485 Posts
Discussion Starter · #1 ·
Hi,

I got a Mac G4 running OS X 10.2.8.

The last update brought me Safari 1.0.3. The system also has Internet Explorer 5.2.

I have tried installing the latest version of Firefox, but the system complains it can't find some package manifest or something along that line.

Is this G4 now junk ? I just need it for surfing and need a newer browser more compatible with the latest html standards. In Safari 1.0.3, some websites don't display well.
 

·
Registered
Joined
·
15,485 Posts
Discussion Starter · #2 ·
Found it - Opera 9.64 works on Jaguar 10.2.8. released some time 2009.

Can't believe that Apple would leave its users out of a modern browser when they have an older machine. G4 is still reasonably fast for general use like word processing and surfing.
 

·
Registered
Joined
·
3,012 Posts
Hi,

I got a Mac G4 running OS X 10.2.8.

The last update brought me Safari 1.0.3. The system also has Internet Explorer 5.2.

I have tried installing the latest version of Firefox, but the system complains it can't find some package manifest or something along that line.

Is this G4 now junk ? I just need it for surfing and need a newer browser more compatible with the latest html standards. In Safari 1.0.3, some websites don't display well.
Are you able to upgrade Safari at all? I'm running 5.0.3 on OS X 10.6.6
 
1 - 3 of 3 Posts
Status
Not open for further replies.
Top