Tech Support Guy banner

New router does not connect hardwired devices

684 Views 1 Reply 2 Participants Last post by  etaf
Tech Support Guy System Info Utility version
OS Version: Microsoft Windows 10 Pro, 64 bit
Processor: AMD Phenom(tm) II X4 B55 Processor, AMD64 Family 16 Model 4 Stepping 3
Processor Count: 4
RAM: 3838 Mb
Graphics Card: ATI Radeon 3000 Graphics, 256 Mb
Hard Drives: C: Total - 128466 MB, Free - 57133 MB; D: Total - 109544 MB, Free - 47266 MB;
Motherboard: ASUSTeK Computer INC., M4A78LT-M
Antivirus: Windows Defender, Disabled

I have just installed a new TP-Link TLwr841N router. It connects both wired and wireless pcs to the internet OK. However I cannot get it to connect hard wired printer and network storage unit. I have tried connecting them via a gigabit switch. All the lights show the ethernet connection are working. There is something simple that I am missing - any ideas please
Not open for further replies.
1 - 2 of 2 Posts
I have tried connecting them via a gigabit switch
can you connect direct to the router

whats the TP-Link TLwr841N connected to to get internet - is this a standard modem ?

whats the make and model of the printer

from a working PC do an ipconfig /all
and from the printer - can you print out the networking settings and then compare the IPv4 address and IPv4 gateway , subnet Addresses
1 - 2 of 2 Posts
Not open for further replies.