Tech Support Guy banner

Network - poor performance even on FTP (1 server, two clients)

679 Views 1 Reply 2 Participants Last post by  JohnWill
HI Guys

im trying to get HD stuff to stream and its jerky as hell so, in order to rule out the network I dropped back to a x-over ethernet cable with the server direct to a device (I tried a laptop and a HD media player). However, this was still jerky. So, next step, I put a free FTP server on the server and then tried to connect via FTP and copy over the file. The best I could get was 11meg a second.

For the life of me, in my simple view of things, all seems good so, I thought i'd ask the experts for tips. Please take a quick look at the specs below and see if you can see why I'm only getting 11meg and im open to suggestions!

Desktop(Ftp server)->x-over->Laptop(Ftp client) = 11meg a second
Desktop(Ftp server)->homeplug(bedroom)->Laptop(Ftp client) = 4meg a second

Ouch. So none of these are particuly good considering the direct connection with nothing in the middle.

The PC's specs:

Intel Core 2 Duo E6850 @3.00
Ram 4gb
Vista Home Premium 64
Boot disks SATA1: 2xWD Raptors (stripe)
Storage SATA2: 2x Hitachi 1TB disks (stripe)

Important bit?:

Generic Marvell Yukon 88E8056 Ethernet Controller

Settings below, any ideas?

  • Flow control - TX/RX Enabled
  • Interrupt Moderation - Enabled
  • IPv4 Checksum Rx Enabled
  • Jumbo Packet - 1514 (smallest option, cant disable)
  • Large Send Offload (IPv4) - Disabled
  • Max IRQ per sec - 10,000
  • Priority & VLAN - Priority and VLAN Disabled
  • Receive Buffers - 512
  • Speed & Duplex - Auto-Negotiation (tried forcing 100/full)
  • TCP Checksum Offload (IPv4) - Tx & Rx Enabled
  • Transmit Buffers - 256
  • UDP Checksum Offload (IPv4) - Tx & Rx Enabled

The devices connect at 100meg but I can't see where to see if this is Full duplex or not.

So, any ideas? I'm really struggling.... and very confused :4-dontkno

Thanks in advance!
See less See more
Not open for further replies.
1 - 2 of 2 Posts
Answered on another board. You're confusing bits and bytes here.
1 - 2 of 2 Posts
Not open for further replies.