Tech Support Guy banner
Status
Not open for further replies.
1 - 10 of 10 Posts

·
Registered
Joined
·
11 Posts
Discussion Starter · #1 ·
The computer in question is a packard bell imedia 4605. It is ancient, and originally had windows ME in it, but it has since been upgraded to XP since the person who's computer it is lost the ME disk.

It was not me who did the upgrade, I might add, anyway, everything else is installed but the USB ports don't work and the device manger tells me that the PCI Simple Communications Controller is missing its driver.

Since the computer is so old I cannot find the driver any where online and the Packard Bell site doesn't have anything.

Can anybody point me in the right place to get them?

Thanks.
 

·
Registered
Joined
·
144 Posts

·
Registered
Joined
·
11 Posts
Discussion Starter · #6 ·
through some miracle of good luck the ethernet card (which was never originally on the pc, i installed in 4 years ago) works! So I will download and install the program and let you know the results.
 

·
Registered
Joined
·
11 Posts
Discussion Starter · #7 ·
Device Type: PCI/AGP Device
Vendor: Intel Corporation
Device: 536EP V.92 PCI MODEM
The drivers for this device are not installed (28)
Location: PCI bus 1, device 3, function 0
Hardware ID pci\ven_8086&dev_1040&subsys_10008086&rev_00
 

·
Registered
Joined
·
210 Posts
When you right click My Computer and select "manage" and in the left-hand side select "device manager" what do you see on the right-hand side under universal serial bus controller(s)? If it's a questions mark, right clicking it should give you a chance to "install" or "update." Does windows give you any suggestions for driver installation?
 
1 - 10 of 10 Posts
Status
Not open for further replies.
Top