Tech Support Guy banner

multiplayer issues

1324 Views 3 Replies 3 Participants Last post by  zebanovich
First off thank you all for reading this and for any assistance you may be able to provide me.

I was unsure if should post this in networking or games so i may post in both.

I have been having disconnection and desync issues with multiple strategy games over the last 4 or so months. I have had no issues with other online games at all though. the specific games are, Total war Warhammer 2, Stellaris and Civilization 6. I have googled around during each time i have hit a issue and tried many "fixes" with no luck. My internet is very stable and with a good speed (70mbs to 90mbs in australia with a local ping of around 6 or 7 and a ping of 240ish to NYC). I have run a program to check for packet loss and found none at all (uotrace). I have a direct cable connection to the wall. The person i have been trying to connect with i have played games with many times before without issue, he lives in the same city as me. I am using the Steam application to run games and use Discord to voice chat. I cant seem to see any reason why i am having this issue.

A example is my current attempt in getting a game of civ 6 going. The info is, both he and i tried to host with both having very similar issues. No speed loss or instability in my net was evident, no mods were installed nor used. When he or i were in the lobby if the host changed any game settings it would disconnect the player and put them into a identical lobby without the host and instead they were the host. If all settings were done before the player joining the lobby the game could be started, though after both players hit end turn it would kick the player and put them into their own identical game and notify that they were the last human player. I tried to connect to a random other games and experienced the same issue with all games i was not kicked from due to unfriendly players. I did a check on the validity of the files and had no issues found.

The stellaris game that i tried to play was at the friends insistence heavily modded and had many desync issues, though it did work for the most part for short stretches. It struggled if the game speed was increased and at times the game failed to even start desyncing at launch of the multiplayer game. This was regardless of who was hosting.

And the total war game had issues with desynch between turns, it would freeze the game but i could still see the background moving around. If i pressed ESC the menu would pop up but be greyed out and i was unable to do anything until the friend left the game and i was pushed to the lobby or if i ALT f4 back to desktop. This was a constant issue the resulted in restarting the game multiple times at the start and caused us to lose interest in playing it multiplayer.

In the same time period I have played 7 days to die, Overwatch, Conan exiles and fantasy grounds ( where i host a d&d game online) none of which had any disconnection or desync issues at all. I take this as a sign that since the games work single player fine and i'm able to connect in some small way for the most part that its something small i'm somehow missing. The only router settings i have changed is to open some ports for fantasy grounds to be able to be hosted.

My system specs if it helps are. Computer was made from new parts straight from their boxes 2 years ago.
I5 6400 2.7GHZ
16gb Ram
RX580 8gb
windows 10
Ethernet cable connection.

Again thank you all very much for reading this and i hope someone can point me in the right direction.
See less See more
Not open for further replies.
1 - 4 of 4 Posts
Are you able to play any of these games in a local setting (LAN)?

It does sound like a firewall issue to me.
Are you able to play any of these games in a local setting (LAN)?

It does sound like a firewall issue to me.
Thank you for the reply.

I do not have another computer at home to connect to for a local cabled game. Single player games seem to be completely unaffected.
What kind of a NAT (Network Address Translation) is used by the router?

Log into your router and take a good look under NAT options then report current setting here.
If you have multiple login options/credentials then choose/input Admin login/password.
check under advanced options too.

Possible options of NAT types are as follows:

1. Full cone NAT (Static NAT)
2. Restricted cone NAT (Dynamic NAT)
3. Port restricted cone NAT (Dynamic NAT)
4. Symmetric NAT (Dynamic NAT)

In addition to telling current NAT type setting, tell also what options are available from the list above in your router.

you ca alternatively post a screenshot(s) of all the NAT options.
If you can't find these options, look at place where you did port forwarding, what (additional) options are there?
See less See more
1 - 4 of 4 Posts
Not open for further replies.