Tech Support Guy banner
Not open for further replies.
1 - 20 of 35 Posts

33 Posts
Discussion Starter · #1 ·
Thur Dec 27,'01

msgsrv32 error on boot after reinstall

Recently I had a hard computer crash when I cancelled
a particular program on my machine. It corrupted a lot of
files, including a good many of Norton System Works 2001
files, as well as a good many windows core files.
I fixed a lot of the others, but decided to uninstall
and reinstall NSW. Now when I boot to windows desktop all I
get is "MSGSRV32 ERROR", with no icons and nothing loading
in systrey. When I boot to safe mode I get the same error
message. In neither screen can I get details of the error
message. I am able to boot to command line prompt, but am
not sure how to uninstall from there. I can find nothing in
Norton's knowledge base on how to do this. Please help and
elaborate on the proceedure to do this.

I did a full install of the whole works. Everything. There
was nothing in the readme.txt file that indicated I should
not do a full install.

Fri Dec 28,'01

Here is all the things I inadvertantly let out in my haste
to post.
1. I did run Norton disk doctor in DOS, no problems.
2. I did try rescue disk, it said not advisable to reload
cmos, boot partition and (whatever) because it did not find
anything wrong during scan.

Also, upon further searching in DOS i found out I did a poor
job of replacing corrupted windows files. There are at least
50 pages of DOS "screens" with files that are possibly
still corrupted.

I am considering overinstall of windows to correct all those
files unless there may be a better or easier way. I would
appreciate instructions on how to do this, if possible.

I now realize some of my mistakes, but hey, they aren't my first nor will they be my last, sigh!

Please advise.

Thanks to all who respond in advanced.

11,584 Posts
Welcome to TSG!
Here is an error message that is pretty close to the one you described and the fix from Norton/Symantec for the error.
Keep us posted on your progress.

Click Here for article.

33 Posts
Discussion Starter · #3 ·
to davey7549

I have completely searched thier website several times but cannot find
any information that answers my main question, which is how to best
accomplish the removal in DOS.
As I explained before it hangs at the windows desktop with that error
message, no icons loaded and not responding to a click on details.
The very same thing happens when I boot to safe mode, no icons loaded and not responding to a click on details. I belive the
only way is to try either removal in DOS or at the very least to
rename the directories. (I tnink that would work). Please, somebody
correct me if I am wrong.


33 Posts
Discussion Starter · #4 ·
With all do respect to everybody in this forum,
is there the thought that maybe I should post this in the DOS forum?(just a thought).
Let me know what you think.

11,584 Posts
I was hoping someone well versed in DOS would have some idea and post. My experience is limited in DOS. If you click on the report to moderator link below you post ask them to move it to the DOS forum.
Sorry Dave

11,943 Posts
Jim, this should get you into File Manager and allow you to uninstall Nortons.

Restart the PC and keep pressing F8 til you get the startup menu. Select option 6, "Safe Mode Command Prompt Only".

Then type in Edit c:\windows\system.ini and press enter. Now change the line that reads Shell=Explorer.exe to Shell=Winfile.exe

Now press the ALT key and then use the down arrow to highlight "Save" and press enter.

Now press alt/ctrl/del to restart the PC. Assuming it now boots into "File Manager", click on File>Run and type in the following and press enter.

control appwiz.cpl

Now use Add/RemovePrograms to uninstall Nortons.

When you restart the PC, be sure to boot back to the C:\> prompt and edit the System.ini file line from Shell=Winfile.exe back to Shell=Explorer.exe and save the changes. Then press press alt/ctrl/del to restart the PC and let it boot into Windows.

Let us know what happens ........

33 Posts
Discussion Starter · #7 ·
reply to Brian #1.

To Brian, Thanks

When I read your post I got excited, this sounds like a
winner! However, here's the way it worked.

I booted to safe mode command prompt only.
changed the line to read as directed and C-A-D to reboot.
It rebooted and ran Norton scandisk on drive C:\
Continued on to same bootup screen as before-no icons,
no start menu, Nothing, except msgsrv32 error and
then hangs.

I then tried hard boot.
No luck. Still the same.:eek:

Still hoping someone will come up with something.
Although I'm beginning to think there may not be a
simple solution.


11,943 Posts
Are you sure you remembered to save the changes to the System.ini file? Go back and rerun the Edit c:\windows\system.ini command and be sure the line does read


After you verify that the System.ini file does have the correct line, do this from a c:\> prompt

ren autoexec.bat
ren config.sys

Now press Alt/Ctrl/Del and see if it boots to FileManager now.

As a last resort, if your running W98 or Windows ME, the other thing you can try if you can't boot to FileManager is a registry restore from a DOS prompt.

scanreg /restore

Use the Up/down arrows to select a registry copy dated the day of the Nortons uninstall/install or prior to it and press enter to restore it.

BTW, if your running Windows ME, you need to boot to the Windows ME Boot Diskette, take the "Minimal Boot" option and then run the scanreg /restore command.

33 Posts
Discussion Starter · #9 ·
To Brian,

I did the shell=Winfile.exe back and forth
several time and it didn't work.
Also tried ren autoexec.bat and config.sys
couple of times and that made no difference
also. So I changed them back.And rebooted
to check again.
I am running win95 osr2 clone.
I got to wondering if a copy of bootlog.txt
could be of any help in diagnosing and/or
finding a solution. It's too long
to post, but I can email if it would help.
I did notice that there are an awful lot
of fonts that are not loading with a
failure code 0016. Is there a way to do
a system file check in DOS? Something
like a win98 system file check, only do
it in win 95. Maybe I should mention that
I have Norton SystemWork 2001 installed on
my win98 computer. So it is possible to
access and transfer files with a floppy
disk if that is any help.
Thanks for hanging in there.

45,855 Posts
A bootlog.txt might be useful but you would have to do a "logged boot" from the boot menu for it to be current. Otherwise it just reflects the original install, which typically produces a lot of font load fails which later are corrected.

Since you have Win95 you don't have scanreg /restore as in Win98, you can however revert to the last successful registry -- system.da0 or even system.1st

see this link:;EN-US;q131431;EN-US;q136337

33 Posts
Discussion Starter · #11 ·
Sorry for being so long to reply.
I finally reinstalled win95 thru DOS.
Everything seems to be okay except I seem to be missing dvd and cd-rom drives in device manager.
I can read from both drives "E:\ +F:\". And they show up in "my computer".

I am also missing primary and secondary controllers in DM, and all drives (C,D,E,F)are running in MSDOS compatibility mode file system.

Primary controller is "SiS PCI IDE contoller", if that's any help.

I have tried to find the appropriate downloads but that is all but impossible on thier web site, which is a joke.
I have tried removing controller in DM and rebooting, but that doesn't help.
At the risk of repeating myself, my system is:

win95 osr2
Pll 233mghz
48megs memmory

Any help would be appreciated.

33 Posts
Discussion Starter · #13 ·
To Mosaic1
Good idea for getting a complete listing
of one's system. I use it for myself regularly.
Here is the latest.
(Didn't mean to be so long replying but it seems
I could not get to this site since Jan 10. on
either of my computers).

Computer Profile Summary
Computer Name:*******
Profile Date:Thursday, January 10, 2002 18:42:15
Advisor Version:5.0h
Windows Logon:*******

operating System
Windows 95 B (OSR2)

Processor a
233 megahertz Intel Pentium w/MMX Drives
7.73 Gigabytes Usable Hard Drive Capacity
4.53 Gigabytes Hard Drive Free Space

Generic floppy disk drive (3.5")

Controllers Standard Floppy Disk Controlle
Creative Labs IDE controller
Primary SiS IDE Controller
Secondary SiS IDE Controller
SiS PCI IDE Controller Bus Adapters None detected
Communications SupraMax 56i [Modem]
Microsoft Virtual Private Networking Adapter

System Model
No details available

Main Circuit Board
BIOS: American Megatrends 062600 07/15/

Memory Modules
46 Megabytes Installed Memory

Local Drive Volumes
c: (on drive N) 6.45 GB G4.12 GB free
d: (on drive N) 1.28 GB 408 MB free

Network Drives

Compaq IJ1200 on LPT1:
Compaq IJ1200 on LPT1:
HP LaserJet 5L (PCL) on LPT1:
HP LaserJet 5L (PCL) on LPT1:

SiS 5597/5598 [Display adapter]
Super VGA 1280x1024 [Monitor]

Creative Sound Blaster 16 Plug and Play
Gameport Joystick (no joystick connected)
Wave Device for Voice Modem

Other Devices
Standard 101/102-Key or Microsoft Natural Keyboard
Standard Serial Mouse

I have noticed some things that I have questions about.
One is concerning is the heading "local Drive Volumes"
What does it mean "c: (on drive N)? The sizes of the
drives are correct.
Another question is Why does it not show that I have one
Linksys and one Netgear cards in/on my system
Let me remind everybody that all my drives are running
in "MS-DOS compatibility mode ".

I hope what I'm posting will help diagnose the problem.
If not, let me know what you need.
Thanks in advance.

11,943 Posts
Try downloading and installing SIDE213.exe from <a href=> here<a/>. Once it's done, restart Windows and see if your IDE controllers are ok after that. That should also fix your compatibility mode problem, too.

Let us know what happens.

33 Posts
Discussion Starter · #15 ·
To Brien,
Thanks a lot,that fixed my primary and
secondary SiS ide controllers. However,I
temporarily tripped myself up when I tried
to get my E:\ & F:\ (cd-rom & Cendyne
16 x 10 x 40x burner, repectively) out of
MS-DOS compatibility mode, which I have not
yet figured out how to do.

Some of my screwing around caused to me to be
unable to connect online, but I seem to have
resolved that issue.

I have also become worried that my C hdd may be
on the verge of failing, it seems to sometimes
make a disturbing noise when booting up. I am
going to install DriveCopy 3.0 and try to copy
to disk.

One good thing I can say is I belive I was
able to make a cd-backup up of my D:\, and a lot
of the stuff on C that I wanted to save, at least
it can be read on my win98 machine. So guess it
must have been written too. But E & F
drives are still in the same mode.

7,486 Posts
Boot to Safe Mode. Go to Start >run and type regedit. Press enter.
Look Here:
In the right pane for this entry:
If you find it delete it. Restart Windows.
If that doesn't work. GO into the registry again. On the Toolbar Edit>find
Search for these entries, one at a time
If you find them, delete them:

33 Posts
Discussion Starter · #19 ·
To Mosiac1,
I have tried the noide in all its forms and they do
not show up in the registry.

It seems my piddling around trying to change the
Hdd in my D:\, I now have a bootup that takes
five to ten or even 15 minutes before it is finished
loading and functional.

Seems to run as well as ever when online. But you
never know when "a" click will hang the machine and the only way out is to power off.

Would still appreciate any suggestions.

7,486 Posts
Those registry entries are placed there when the Ide is not recognized. Esdi_506.pdr which is the Windows Driver is not loaded when one or more of these entries are present in the Rregistry. The next boot, Windows sees the entries and doesn't load the protected driver.

You would seem to have multiple problems. I have one quick request. Please open autoexec.bat in Notepad and see if you are loading Mscdex.exe If you are, that will put you in Compatibility Mode.
Win 95. Go to start>Run and type sysedit. Several Windows will pop up. Click on the Autoexec.bat Window.

Place REM and press the Spacebar in front of the line if it exists. Reboot.
1 - 20 of 35 Posts
Not open for further replies.