Tech Support Guy banner

msgsrv32 caused a general protection fault

1593 Views 15 Replies 2 Participants Last post by  spree
This problem is with windows 95: When I boot up the computer it gets stuck or locks down at the win95 boot up screen. When I try to start it in safe mode it gives me an error "msgsrv32 and I have the option to close or ignore" it won't allow me to ignore so I chose close and when I do that it gives me another error message saying "MSGSRV32 caused a general protection fault in module setupx.dll at 0017:0000002e." does anyone have any suggestion as to what i can do I can not reach my desktop or safe mode.

Thanks spree
Not open for further replies.
1 - 16 of 16 Posts
If this were the usual sort of msgsrv32 error, such as this one...;EN-US;q188803 should be able to start in safe mode.

But I suspect the error in setupx.dll (did you just install something?) may be due to a ram fault. Do you have enough to try swapping one out at a time?
The only thing that has been installed on the comp. is quake 2 but I didn't have any problems with it before. I searched the microsoft site support area for any topics and it only came up with one for win 98 that had a error with setupx.dll listed. I am totally clueless for this error I have never had one like this. also before this happened It ran scan disc saying that it was not shut down properly it ran into a couple of file structure errors. someone might have used it when I wasn't around and not shut it down properly. But I didn't save and thing when I told it to fix that problem areas.

Using the pc you are on you might try downloading and installing this memory tester to a clean floppy. Then boot it like a startup disk on the problem one and let it run a few "burnin" loops before pressing esc to terminate.

It's not conclusive if memory passes, but if it fails, I would replace it.

I don't think setupx.dll would normally even be called unless there was an install left to be completed.

Not being able to boot in safe mode puts the focus either on core system files or on hardware.
so you think that it could be a bad memmory module. and not a software conflict?
Safe mode would eliminate most if not all conflicts with 3rd party installed programs. They are bypassed along with protected mode drivers for hardware.

Only core Windows system files are loaded.

One possibility here is a boot sector virus, and for that there isn't much option except to fdisk/format and reinstall.

Otherwise you could try an overinstall or a reinstall into a separate folder (renaming the old windows folder)

This is for 98, but the same principle applies to 95;EN-US;Q193902

Another real possibility is registry damage.

In win95 you may be able to load the last successful registry by renaming system.dat. Instructions on this link...;EN-US;Q131431

see "using system.da0"
See less See more
I think a virus can be ruled out b/c it is not connected to the internet it is only used for network gaming and my mom plays solitare on it. I am running the memory test right now it hasn't come up with any errors as of yet and its on the 3rd loop now.
well I I didn't get any memory errors and I tried restoring the registry from the last successful start up but it keeps telling I have an in correct version of dos? what does this mean and what should I do?
I am using a boot up disk from another computer I have with win 95 on it could that be the reason ?
The boot disk wouldn't matter if it's been removed before starting and if you did not use it to sys the drive.

Do you still get the safe mode error?
Don't use the boot disk to access the command prompt. Remove it and just tap the f8 key repeatedly to get the boot menu. Then select either command prompt or safe mode command prompt.

Using the boot disk to acesss the command prompt may have resulted in the error when trying to run the dos commands if I understand this link correctly because it is loading its version of DOS in to memory.;EN-US;q182358
ok I have tried all of the system registry restores except for the win 95 reinstall it keeps telling me that c:\windows\oldprofiles is an invalid directory. But none of the other ones have made a difference. I am still receiving the exact same error message as before. Anyother suggestions or should I just fdisk the drive?
Scandisk might be a last ditch effort. It can correct some directory and cluster errors which could be a factor. From a DOS prompt, enter:

scandisk /surface /all
well I decided to go ahead and fdisk the drive and I installed win 98, thanks eveyone for all of the assistance too bad I couldn't get running without having to do that
1 - 16 of 16 Posts
Not open for further replies.