Tech Support Guy banner

Mercedes C Class AMG Line 2015 USB "No Playable Files"

5204 Views 5 Replies 3 Participants Last post by  Macboatmaster

I have been trying since last week to get it work. I simply want to play music through USB stick. It is formatted FAT32. I just have mp3 files in there and I am not able to play it even for once!. I only get the message "No Playable Files". I have used multiple USBs but no luck. When I connect my iPhone through the USB it plays the audio from there.

My only issue is that I don't want to fill my iPhone with music that's why I wanted to have a dedicated USB with songs only.

Any of your help will be much appreciated as I am sick and tired of this now! It is quite frustrating to have a luxurious expensive car and you are not able to get this basic feature which is available in every other car these days!.
Not open for further replies.
1 - 6 of 6 Posts
If the music files are from iTunes they are not mp3
They are often commonly referred to as MP3 but they are not
I suggest you take whatever is on the usb pen save it to your computer and then put just one mp3 file on the usb pen
I feel sure it will then play it.

Also if the mp3 files are in a folder that is not recognised by the car system then even if they are mp3 files it still will not pay them.

Thank you for your reply. I am not getting files from iTunes. Infact, I am a musician/singer myself so I have the most original, unconverted mp3 files right out of the audio recording software 320kbps. I am putting these mp3 files straight into the usb stick which is formatted FAT32 but still no luck. I have mp3 files of other songs as well which I have tried putting in directly but still the same message :( I have no clue what to do. When I ask MB they say just for the diagnostic it will cost £168 and if there is any issue then fixing it will be charged separately which is a bit too much for the issue I have.

I believe the USB port itself is fine otherwise I wouldn’t have been able to play songs by connecting my iPhone.
Try formatting the USB as simply FAT not Fat 32
I shall try that too tonight. I will have to work around it as I can only see the formatting options of NTFS, FAT32 and exFAT
It may work, but I do not think that is the problem
IMHO it is the mp3 files
I know you say they are MP3 but I think it depends where they have come from - eg the audio recording software
Are they single files on the root of the drive or in folders and what capacity is the USB pen

You may accomplish the FAT format by
cmd prompt

format x: /fs:FAT
where x is the letter of the usb drive
1 - 6 of 6 Posts
Not open for further replies.