Tech Support Guy banner

Lost 3D acceleration

1516 Views 15 Replies 3 Participants Last post by  Kepiano
I'm not sure if this is the right forum....if not just move me. My OS is Win 98. The last couple of weeks I have been getting random general protection faults in module DIBENG.DLL. I have tried before to upgrade my Diamond Viper 770 driver, but since SonicBlue has taken it over, no luck. I looked on NVidia, but couldn't find anything. I thought I would try the work around suggested by MS and use the Standard Display Adapter (VGA). When I go to the settings I don't have that option...I have 3 Diamond Viper versions listed. To make a long story a bit shorter....I tried a couple of them, but that is when I lost the 3D acceleration. I found a newer Viper build at (I think that is the name.) I downloaded and installed it, but still no 3Dacceleration. Everytime I tried a new version, I lost the previous one that was listed in the Settings. I don't much care if some of the games won't play, but there are a couple of others who will be a bit upset. Thanks for any help. Let me know if you need more info.
Not open for further replies.
1 - 16 of 16 Posts

This site has a link to Nvidia's site for your video card. Looks like you just need to download the latest detonator driver for the TNT.

Download the driver, then on your computer go to "start"-->"settings"-->"control panel". Click on the "System" icon, then the "Device Manager" tab. Open up display adapter on the list, and uninstall whatever drivers you find in there. Reboot, windows should then be using some default driver, don't let it install it's own. Instead install the driver you just downloaded from Nvidia's site, then reboot again. Once back, you'll prolly need to change your resolution back to what it was. Goodluck!
Thanks for the quick response. I will try that and let you know what happens, but first I have to clarify a point........when you say to uninstall the drivers that are there...there is just the one listed you mean just hit the remove button? There is no uninstall option in add/remove for Diamond Viper or in its folder.
Yes, remove the sucker and reboot. As you reboot, you may want to run into BIOS and make sure the "Plug and play aware OS" setting is enabled. Upon booting up again, Windows should detect it, and use a generic driver. Then just install the Nvidia one and you should be sitting pretty. Should be.. :)

Let us know if you run into anymore problems. What you're about to do should be a smooth, simple procedure.
I will let you know what happens. This could take me quite a while. I have started the download. It is over 13 MB an I am on dial-up. It will be a while!!! Talk to you later.
After not very smooth sailing, I finally got the driver downloaded and installed. (NVIDIA RIVA TNT2/TNT2 Pro) I am still getting the same error message when trying games.....unable to access 3D accelerator on this machine or Video card present in your machine is unable to run this game. (It was able to before) At least I haven't had a DIBENG.DLL error today. I should probably just keep my mouth shut or I will have one. Anyhow thanks for the help and if there is anything else to try I would appreciate you letting me know.
It never takes the easy way, does it?

Alright, you said you can't even get into games now, so that last driver wasn't totally compatible. The best thing to do then is to run back to Sonic Blue's site and grab it's latest driver for your card at:

Remove Nvidia's driver the same way you did as last time, reboot, and reinstall the Sonic Blue driver. On that webpage, they also have a driver update utility, so you may want to run that as well after installing the driver to make sure you have the latest driver.

One thing i'd like you to try is to reboot your machine into the BIOS. Check your video settings and make sure its set to AGP instead of PCI (after checking some info out on your card, it appears its AGP compatible).

Also, what version of DirectX do you have installed? If you're still using 8.1, it wouldn't hurt to upgrade to DirectX 9.

Is your motherboard AGP 1x/2x compatible or 4x compatible? If the motherboard supports AGP 4x, go into your BIOS and see what the AGP slot is set to. Also, there's jumpers on your video card itself that selects either AGP 1x/2x (default setting) or 4x.

I apologize about that last driver by Nvidia. Since the card is TNT2 based, i wouldn't have thought that it would make things worse. Check those things out, and let us know the details. We'll get your card working right soon enough =]
See less See more
I may have misled you a bit. I can play games....just not certain ones. e.g. Superbike, Muscle Car '76. Can still play Combat Flight Simulator. Those are the 3 I have tried. I do have DirectX 8.1, so I will upgrade that and go to SonicBlue and get the driver you suggested. I sure did a swell job of searching those sites for driver updates didn't I? Okay, will let you know how it goes. It will probably take me all night to download those 2 things. Thanks.
When I go to SonicBlue and try to download, I get the message:
426 connection closed; transfer aborted
Actually, I did find this yesterday and got the same message. I will now try the DirectX.
I have downloaded DirectX 9. Still no luck.....didn't expect there to be with just that. In the BIOS: AGP - 2X Mode Enabled
Just thought I would give you the latest update.
Both those two available driver downloads on the SonicBlue site are working perfectly ok for me. Maybe try again, or just keep trying.

You really need to follow the instructions and change the Display Adapter to Standard Display Adapter (VGA) before installing the drivers. Full instructions are provided in the readme.txt on the SonicBlue site (the link just underneath the .exe download)

Standard VGA will be listed under Show All Devices -> Standard Display Adapters.
Still can't download from there. I am using Netscape 7. I will try IE and see what happens. When I go to Control Panel>Display>Settings..........there is no 'change display type' button. I can to to Advanced>Adapter>Change, but I still do not get a Standard Display Adapter (VGA)
Okaaay . . . now it's a long time since I've used a Win9x OS,
so let's see if I can remember the exact procedure.
You're definitely right though, the instructions in that readme.txt are a bit skew-whiff.
I don't ever remember there being a "Change Display Type" button either...

Display Control Panel -> Settings -> Advanced -> Adapter -> Change

Checkmark "Show all devices"
(instead of "show compatible devices")

Under "Manufacturers", scroll to the very top of the list.
Here you should see:
(Standard Display Types)
and when this in hi-lighted, you should then see in the right pane
"Standard Display Adapter (VGA)"

See less See more
Yes, it is there. I missed the wee option at the fault. I should have found it regardless. I am going to SonicBlue now to try and download from there. I am using the IE browser. Should I first try to reinstall the NVidia with the change in the 'standard display types' done properly this time? Thanks again.
I got the download from SonicBlue. I decided to first try with the one from NVidia again, so I removed it, set 'standard display types (VGA)' and reinstalled the driver. Same as before, so I removed it and installed the Diamond Viper from SonicBlue. Same thing. I still have it installed, but I am going to remove it and put the NVidia one back on. This one will only let me set the pixels to 640X480.
After those many, many installations the problem is solved. I checked my hardware acceleration and it was set on the lowest setting. I set it on full and everything works great. Thanks for the help and if a moderator reads this, it can be marked as 'resolved'.
Thanks again.
1 - 16 of 16 Posts
Not open for further replies.